none
Windows 10 - Unable to change domain password when password has expired and computer is locked RRS feed

  • Question

  • We have recently migrated over to Windows 10. Prior to that we were on Windows 7 and this worked fine.

    We have fast user switching disabled for all computers by group policy in our domain. It is quite common that users don't change their password even though they are given password expiration notice.

    On Windows 7 clients when a domain users account password had expired after they had logged in and the computer gets locked (for lunch or they were idle) they came back and were able to change the password as they had a switch user option as shown below.

    However, in Windows 10 when the same situation happens we get the following prompt:

    "Your password has expired. To set a new password, select OK, select Switch user,
    re-enter your current password, then follow the prompts on the screen.

    So we click ok and now there is no longer a switch user option? Please note there is no other users in the left hand corner of the screen.

    Is this a bug in Windows 10 or is it the case that having fast user switching disabled in a domain environment is no longer viable as we do not want to manually have to manage user passwords.

    Thanks.

    Ashley.


    • Edited by Ashley-H Tuesday, August 23, 2016 7:16 AM
    Tuesday, August 23, 2016 7:16 AM

All replies

  • Hi Ashley-H,

    Are you remoting to the machine?

    According to my experience, we should get a screen to change the password when we click "OK".

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com



    Wednesday, August 24, 2016 2:08 AM
    Moderator
  • Hello MeipoXu,

    Thank you for your reply. We are not remoting in. Do you have fast user switching disabled in your environment?

    Wednesday, August 24, 2016 11:08 AM
  • Ok so in my lab I have created

    A new Server 2012 R2 Domain Controller updated with latest August updates. New Windows 10 Pro version 1511 with latest August updates. GPO created with Hide Entry Points for fast user switching set to enabled.

    Problem still occurs so this looks like a bug, is there anyone out there to help replicate this issue?


    Wednesday, August 24, 2016 6:31 PM
  • Yes can recreate this with Windows 10 Enterprise 14393, Domain is Server 2016 TP. Stuck cannot login. Set 'Hide entry points for Fast User Switching' expired the password for the user whilst there screen was locked. Same screens as you.

    Get the one normal login box (only accessibly and network icon the other things on screen). Enter my current password;

    Enter a new \ different (only once in the only available box) password told my password is wrong. Hmm locked out the machine.

    Wednesday, August 24, 2016 8:33 PM
  • Thanks for confirming this. Looks pretty certain this is a bug then.

    Just as a sanity check I also tried this with Windows 8.1 Pro on the same domain.

    Lo and behold it works as expected. Interesting it doesn't mention about switching the user.

    Anyone here be able to advise how to get Microsoft to acknowledge and fix?

    Wednesday, August 24, 2016 10:59 PM
  • Hi Ashley-H,

    Please submit the issue with the built-in "Feedback" tool.

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, August 30, 2016 2:30 AM
    Moderator
  • This problem is resolved by installing the most current cumulative update starting with
    KB 3194798 Cumulative update for Windows 10 Version 1607 and Windows Server 2016: October 11, 2016 
    Released October 11th, 2016

    Thursday, October 13, 2016 3:12 PM
  • Hello eventtrac,

    We have yet to go 1607 and are still on 1511. I have tested 1607 and can indeed confirm this works on 1607. It has not been fixed on 1511.

    I'm presuming microsoft would have applied this fix to all releases of windows 10 but this doesn't appear to be the case.

    I have tested the latest cumulative update for 1511 - October 11, 2016—KB3192441 (OS Build 10586.633). 

    Thanks.

    • Edited by Ashley-H Monday, October 17, 2016 12:53 AM
    Monday, October 17, 2016 12:52 AM
  • I have this issue as well.  Is there a solution?  I'm on 10.0.10240 Build 10240 of Windows 10 and this is affecting our entire organization.  Do I not have the needed updates?  I know we are having some issues with SCCM so we don't have the latest updates pushed out yet.
    Monday, January 16, 2017 2:05 PM
  • I understand your pain, i'm on 1511.

    It seems Microsoft isn't listening. Having already reported it as a bug I don't know what else I can do as I'm not willing to pay to open a case with Microsoft.

    Can you please report the bug too maybe if more people report it they will listen?

    I'm surprised that more people haven't experienced this issue on 1511 or below?


    • Edited by Ashley-H Monday, January 16, 2017 6:38 PM
    Monday, January 16, 2017 6:36 PM
  • Dear Justin Tuner,

    Thank you for the response.

    May I know if there are any articles that actually indicates that the issue affects Build 1507 and below and is resolved at Build 1607 after installation of KB3194798?

    Monday, January 22, 2018 7:38 AM