locked
Event 701 - The Application Impact Telemetry (AIT) Agent is not running because AIT is disabled. RRS feed

  • Question

  • In a survey of several Windows 7 systems, in the Application-Experience Program-Telemetry log, I found daily instances of Information Event 701 "The Application Impact Telemetry (AIT) Agent is not running because AIT is disabled".  The trigger for this event is execution of the built-in scheduled task to run Aitagent.exe daily at 02:30.

    The message "AIT is disabled" is puzzling to me. 

    I checked participation in the Customer Experience Improvement Program (CEIP) on the idea that a setting to disable participation could translate into "AIT is disabled", but CEIP is set to Yes (participate).

    I checked Windows Error Reporting settings - they are set to "Automatically check for solutions and send additional report data, if needed"

    I checked the REG_DWORD value AITEnable in HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\AIT is set to 0x1, which should indicate that AIT is enabled.

    I would appreciate if anyone can explain where/how AIT is disabled.

    Thanks

    Monday, December 6, 2010 4:59 PM

Answers

  • Update, and answering my own question: Event 701 can be eliminated by enabling participation in the CEIP via Group Policy - the setting is Computer Configuration > Administrative Templates > System > Internet Communication Management > Internet Communication Settings: Turn Off Windows Customer Experience Improvement Program. Change this setting to Disabled, and restart.  Now, running AitAgent.exe does not generate Event 701.

    The registry value associated with this Group Policy setting is the REG_DWORD value CEIPEnable in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\SQMClient\Windows.  When the above-described Group Policy setting is set to Disabled, this value exists and is set to 0x1.

    • Marked as answer by Arthur Xie Monday, December 13, 2010 6:03 AM
    Wednesday, December 8, 2010 6:22 PM

All replies

  • How does it work if you install ACT in the systems?

    Microsoft Application Compatibility Toolkit 5.6


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, December 7, 2010 6:50 AM
  • Arthur Xie-

    Thank you for suggesting installing the Microsoft Application Compatibility Toolkit 5.6 (ACT).  This is quite an enterprise-level program (the Step-by-Step guide says "We recommend that you collect your data from approximately 10,000 computers")! 

    Anyway, installing the ACT and sending an empty data set to Microsoft worked, but did not eliminate Event 701 when the scheduled task to run AitAgent.exe executed (as scheduled or manually) or when AitAgent.exe was run from an Administrator command prompt.

    Since the scheduled task to run AitAgent.exe is part of a out-of-box installation of Windows 7, and its description states "Aggregates and uploads Application Telemetry information if opted-in to the Microsoft Customer Experience Improvement Program", it would seem that it would run without error, at least when participation in the CEIP is enabled.

    Wednesday, December 8, 2010 3:48 PM
  • Update, and answering my own question: Event 701 can be eliminated by enabling participation in the CEIP via Group Policy - the setting is Computer Configuration > Administrative Templates > System > Internet Communication Management > Internet Communication Settings: Turn Off Windows Customer Experience Improvement Program. Change this setting to Disabled, and restart.  Now, running AitAgent.exe does not generate Event 701.

    The registry value associated with this Group Policy setting is the REG_DWORD value CEIPEnable in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\SQMClient\Windows.  When the above-described Group Policy setting is set to Disabled, this value exists and is set to 0x1.

    • Marked as answer by Arthur Xie Monday, December 13, 2010 6:03 AM
    Wednesday, December 8, 2010 6:22 PM
  • Setting Disable didn't work for me.  I am still getting the error.  I am going to try "enable" instead of "disable"

    Saturday, July 19, 2014 11:57 AM