none
Excel 2016 Not Appearing in Default Programs

    Question

  • Hi Technet Community,

    I have been faced with a weird behaving issue for Excel 2016.  Several of our end-users in our environment cannot set Excel 2016 as their default program for uncommon file extensions (ie: .csh .trs .css).  When browsing and choosing C:\Program Files\Microsoft Office\Office16\EXCEL.EXE from the Open with... option, it goes back to the Open with dialog box, but Excel does not appear.

    The Excel 2016 icon only appears when selecting C:\Program Files\Microsoft Office\Office16\excelcnv.exe, but these file types do not open with this application.

    This works on a newly created account with Administator rights, but not and existing, recently upgraded to Office 2016 account.  I also granted her account temporary Administrator rights to the computer without luck.

    I have repaired Office several times.

    Our end-users are on Windows 7 Enterprise x64, running Office 2016 x64.

    Has anyone else had this issue? I wanted to reach out to TechNet before I chose the next step in deleting and recreating the Windows 7 profile.


    Daniel Scoland MCP 70-698 CompTIA Security+, Network+, A+ IT Professional

    Monday, October 02, 2017 6:51 PM

All replies

  • Hi dscoland,

    Please try the following steps and see if there will be any improvement (The screenshot is from Windows 10 and may be slightly different from Windows 7.):

    1. Go to Control Panel > Default Programs > Set Associations.
    2. Scroll to select the uncommon file extension (ie: .csh .trs .css), click the Change Program button and see if the default application can be changed to EXCEL.EXE.

    If the above doesn't work, please try to launch Excel 2016 first, then go to File > Open,choose All files, browse to the file with uncommon extension. If the file can be opened properly, please try setting the default program again using Open with.

    Hope this can be helpful. Please feel free to let me know if you need further assistance on this.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, October 03, 2017 5:27 AM
    Moderator
  • Hi dscoland,

    By the way, do the problematic machines happen to have a different version of Office installed previously?

    If this is the case and the above methods doesn't work, the problem might occur when there's a change to the installation location of Microsoft Office.

    Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.
    Please refer to this article about how to back up and restore the registry in Windows.

    Please try to check the path in the registry path below and see if it points to the correct location:

    HKEY_CLASSES_ROOT\Applications\EXCEL.EXE\shell\open\command\(Default)

    If the path is not proper, please try to set it to the right path where "Excel.exe" is located and check if this would fix the issue.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, October 03, 2017 6:11 AM
    Moderator
  • Hi dscoland,

    How's everything going with this issue? Was the problem resolved?

    Any update, please post back at ease.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, October 16, 2017 12:42 PM
    Moderator
  • Thank you so much! this resolved my issue!

    For some reason, the path was showing Office14 even though I've never loaded any version that would be 14, I corrected this to Office16 and it immediately showed up as a program for me to pick from!

    Hope this helps the original author of this thread, but for me 100%!

    Friday, November 10, 2017 4:10 PM
  • Hi Francisco,

    Great to see that this method can help fix your issue :)

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Saturday, November 11, 2017 4:10 AM
    Moderator