locked
Configuring memory resources used by the PCI bus driver RRS feed

  • Question

  • Hi,

    I am having trouble getting an ISA card working under Windows XP. This card has to be able to use the D0000-DFFFF region of the upper memory area; there are no jumpers etc. that allow this region to be changed. Looking at the memory resource usage in Device Manager I can see that pci.sys is using the C0000-DFFFF memory region. I suspect this conflict is the reason I cannot access the ISA card (which works fine in an another computer).

    Is there any way I can configure pci.sys to not use that region? Device Manager will not let me change the PCI bus resources. I tried adding an EMMExlcude line to system.ini (which was a long shot). I also tried disabling just about everything that can be disabled in the BIOS.

    Thanks.
    Wednesday, March 23, 2011 10:49 PM

All replies

  • Hi,

    I am having trouble getting an ISA card working under Windows XP. This card has to be able to use the D0000-DFFFF region of the upper memory area; there are no jumpers etc. that allow this region to be changed. Looking at the memory resource usage in Device Manager I can see that pci.sys is using the C0000-DFFFF memory region. I suspect this conflict is the reason I cannot access the ISA card (which works fine in an another computer).

    Is there any way I can configure pci.sys to not use that region? Device Manager will not let me change the PCI bus resources. I tried adding an EMMExlcude line to system.ini (which was a long shot). I also tried disabling just about everything that can be disabled in the BIOS.

    Thanks.

    I Suggest you check device manager if there is any other device using the desired resource for the ISA card. Then try swapping other resources with them
    Tunde Abagun MCP,MCSA,MCTS,MCITP en p "for the love of Computers"
    Thursday, March 24, 2011 3:22 PM
  • No other expansion cards are using that memory region. Device manager reports that the "PCI bus" driver (pci.sys) is using that memory region. Is there any way I can configure pci.sys to not use that region?

    Thursday, March 24, 2011 9:42 PM