none
Problems installing MRO on ubuntu RRS feed

  • Question

  • Hello

    I had no problem to install and run mro 3.2.5 on ubuntu machine but when I try to install and run 3.3.1, I can no longer run R. What I did was " sudo ./install.sh -a -u" and then ln -s ..../R /usr/bin and ln -s .../Rscript /usr/bin. 

    When I issue the command R on a terminal I got an infinite number of the following error msg:

    > Error in nchar(dcall, type = "w") :
      4 arguments passed to .Internal(nchar) which requires 3
    In addition: Warning message:
    An unusual circumstance has arisen in the nesting of readline input. Please report using bug.report()

    When I try to call RStudio the following error msg comes up:

    <style type="text/css">p, li { white-space: pre-wrap; } </style>

    R shared library (/usr/lib64/microsoft-r/3.3/lib64/R/lib/libR.so) not found. If this is a custom build of R, was it built with the --enable-R-shlib option?

    The old version, that is, 3.2.5 does have libR.so but the new one does not seem to have it.

    What am I doing wrong?

    Many thanks

    Ed

    Thursday, October 6, 2016 7:45 PM

All replies

  • Something went wrong when you attempted to install Microsoft R Open 3.3.1, though I am not sure exactly what, as I can't reproduce the problem when attempting to do a silient install as you did.

    What version of Ubuntu are you running on?

    I tried it on both Ubuntu 14.04 LTS and Ubuntu 16.04 LTS and in both instances installing MRO-3.2.5 first and then doing a silent install of Microsoft R Open 3.3.1 worked.

    If you want to run two versions of Microsoft R Open side-by-side, you should rename the old 'R' and 'Rscript' scripts in 'usr/bin':

    1).  /usr/bin$ mv R R-3.2.5

          /usr/bin$ mv Rscript Rscript-3.2.5

    2).  ln -s /usr/lib64/microsoft-r/3.3/lib64/R/bin/R /usr/bin

          ln -s /usr/lib64/microsoft-r/3.3/lib64/R/bin/Rscript /usr/bin

    Hope this helps.

    Stephen Weller

    Microsoft R Open Product Team


    Wednesday, October 26, 2016 8:51 PM
  • I would also check and make sure that you aren't loading a personal .Rprofile file that is somehow causing bad behavior on startup. If you are using a personal .Rprofile, it would be helpful if you could paste the contents here, as this might help us determine why you are getting these messages on startup.
    Thursday, November 10, 2016 12:39 AM