locked
Windows 10 Internet Explorer 11 Enterprise Mode Not Working RRS feed

  • Question

  • I am having a strange issue where I can not get Enterprise Mode in IE 11 on Windows 10 to work. I have changed the local computer policy to allow users to toggle enterprise mode in IE, but when I click on Tools -> Enterprise Mode it does nothing. This used to work in Windows 7 and 8.1 without issue. Has anyone run into this before?
    Tuesday, August 4, 2015 2:35 PM

Answers

  • I think I have found a fix if you want to give this a try. Delete the following registry keys, they will be recreated when you launch Internet Explorer and then Enterprise mode should work.

    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieModeList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieSiteList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieUserList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\LowCache\Extensible Cache\EmieModeList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\LowCache\Extensible Cache\EmieSiteList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\LowCache\Extensible Cache\EmieUserList

    • Proposed as answer by John 75 Friday, August 21, 2015 5:59 PM
    • Marked as answer by Roger Lu Tuesday, September 1, 2015 5:10 PM
    Friday, August 21, 2015 3:56 PM

All replies

  • Hi,

    Based on my test, please open a website, then enable Enterprise Mode for test. 

    If problem persists, try to reset IE and restart computer for test.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, August 7, 2015 6:19 AM
  • I have enabled Enterprise Mode via local policy so I can toggle it on and off via the Tools menu, but clicking on that has done nothing. I did an IE reset, I also tried uninstalling and reinstalling Internet Explorer, none of these were successful in allowing enterprise mode to work in IE 11.

    I did an inplace upgrade of Windows 10 from Windows 8.1 if that makes a difference.

    Monday, August 10, 2015 12:24 AM
  • We are having the same issue.

    I have done a little more testing and have found that either an inplace upgrade or imaging the PC from SCCM TS still does not work. But taking the ISO and installing it as a fresh install on a PC works fine. 

    The issue is that it just does not enable or see the site list. It does not matter if it is enabled by GPO or by the registry keys. I can see the Enterprise Mode option in the tools menu, but clicking on it does nothing. If i enable it from the developer tools, the icon for EM shows up and is displaying the site in the emulated mode, but once i close the tools it does not work. 

    Edit: We are also using windows 10 enterprise.


    • Edited by Timms22 Friday, August 14, 2015 4:21 PM added Win 10 version.
    Friday, August 14, 2015 4:17 PM
  • Please confirm you have tried the following steps for enabling enterprise mode for IE 11 in Windows 10:

    1. Press Windows key + R on your keyboard to launch the local group policy editor

    2. Enter gpedit.msc into the run dialog and press enter

    3. In the local group policy editor, navigate to user configuration > administrative templates > Windows components> Internet explorer

    4. Find "Let users turn on and use enterprise mode from the tools menu option" and double click the option

    5. In the dialog windows, click on enabled which allows users to enable enterprise mode manually

    6. Click apply, then ok to accept the changes

    7. Close the group policy editor

    8. Close all open IE 11 browser windows

    9. To activate Enterprise mode press the Alt key when you re-open IE 11 and navigate to the tools menu to select enterprise mode

    Friday, August 14, 2015 4:53 PM
  • Yes. I have done all those steps. Even set it up from just using registry settings instead of using group policy. Still Nothing.

    I have found some articles that show that deleting the profile and recreating it works, but we are not able to successfully get that to work, and i don't think that is a solution. It's just a band-aid.

     All profiles that i could possibly delete have been deleted and recreated. Nothing happens when i click on the Enterprise mode link in the tools menu, and it does not pull any settings from the site list. Windows 7 and 8.1 computers are not having any issues. Only Windows 10. 

    Friday, August 14, 2015 6:56 PM
  • I definitely know I have done this because I already have the menu option as I specified in my first post. Clicking on this menu option does nothing. I can confirm that going through developer tools Enterprise mode does work, so that is good. But the menu option isnt working when i click on it.
    Friday, August 14, 2015 6:58 PM
  • I am glad someone else is experiencing the same issue, I had a hard time finding anyone with a similar issue.
    • Proposed as answer by Timms22 Friday, August 14, 2015 7:27 PM
    • Unproposed as answer by Timms22 Friday, August 14, 2015 7:27 PM
    Friday, August 14, 2015 7:02 PM
    • Can you downgrade IE11 and try?
    Friday, August 14, 2015 7:24 PM
  • Its Windows 10, it comes with IE 11. Just to clarify, this is not Microsoft Edge. I have also tried uninstalling and reinstalling Internet Explorer and it had no effect.
    Friday, August 14, 2015 7:26 PM
  • It comes with IE11, but is it possible to downgrade to IE10 on windows 10?

    Friday, August 14, 2015 8:41 PM
  • That's not possible, and that's the whole point of EM for IE11. Also, since they are depreciating support for anything older than IE11 in January, why would they allow an older browser version to install on their new OS? 

    I'll just continue to troubleshoot this until someone finds an answer to why the function just does not work on some Win10 computers.

    Some further testing also shows that the Site List GPO for the Edge Browser does not read the Site List XML either.

    "Use Enterprise Mode Site List.

    Lets you use the Enterprise Site List. If you use this option, you must also include the location to your XML site list in the {URI} box. This is the default value."

    Tuesday, August 18, 2015 7:18 PM
  • Same problem here

    We upgraded a few computers to Windows 10 and Enterprise Mode does not seem to work anymore.

    The Enterprise Icon never appear nor disappear, when we try to toggle on or off the Enterprise Mode from the menu

    Hope they solve this fast, as many enterprises (including mine) rely on this do run some legacy web apps

    Wednesday, August 19, 2015 2:24 PM
  • I opened a ticket with Microsoft yesterday about this issue. They connected to my computer but got fixated on it being a GPO issue. Hopefully they come back to me and start looking at IE when they realize the GPO is working.
    Wednesday, August 19, 2015 2:36 PM
  • We have the same problem. We upgraded about 5 computers from Windows 7 or Windows 8.1. None of the upgrades can toggle Enterprise Mode from the Tools menu. Also, the Enterprise Mode Site List seems to be ignored. You can only toggle Enterprise Mode by changing the Browser Profile using F12 Developer Tools.

    We have one instance of Windows 10 that was not an upgrade and Enterprise Mode works on it.

    Friday, August 21, 2015 12:07 PM
  • I think I have found a fix if you want to give this a try. Delete the following registry keys, they will be recreated when you launch Internet Explorer and then Enterprise mode should work.

    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieModeList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieSiteList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieUserList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\LowCache\Extensible Cache\EmieModeList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\LowCache\Extensible Cache\EmieSiteList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\LowCache\Extensible Cache\EmieUserList

    • Proposed as answer by John 75 Friday, August 21, 2015 5:59 PM
    • Marked as answer by Roger Lu Tuesday, September 1, 2015 5:10 PM
    Friday, August 21, 2015 3:56 PM
  • Deleting these reg keys worked for me. Thanks!

    Friday, August 21, 2015 5:59 PM
  • I have the same issue but deleting hte reg keys didnt help.

    the key EmieSiteList in Cache and LowCache didn't exist for me nor are they created when the browser starts.

    the other 4 are recreated when IE starts.


    Tech with Alberta Education

    Tuesday, August 25, 2015 7:22 PM
  • I think I have found a fix if you want to give this a try. Delete the following registry keys, they will be recreated when you launch Internet Explorer and then Enterprise mode should work.

    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieModeList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieSiteList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieUserList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\LowCache\Extensible Cache\EmieModeList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\LowCache\Extensible Cache\EmieSiteList
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\LowCache\Extensible Cache\EmieUserList

    Thank you! I was having the same issue, but on my system the EmieModeList was not there instead there was EmieBrowserModeList.  I deleted the EmieBrowserModeList as well as the others listed above and it work when I relaunched IE with a site in my site list. I wonder if just renaming the key from EmieBrowserModeList to EmieModeList would have worked since that is how it came back when I relaunched IE.  I'll have to give that a try on another system.

    Doing a reset of Windows and needing to reinstall all my applications (which I did on a different system) seemed to defeat the purpose of an in-place upgrade, I knew if I waited someone would figure it out. Thanks!

    Wednesday, August 26, 2015 3:12 PM
  • Thank you! I was having the same issue, but on my system the EmieModeList was not there instead there was EmieBrowserModeList.  I deleted the EmieBrowserModeList as well as the others listed above and it work when I relaunched IE with a site in my site list. I wonder if just renaming the key from EmieBrowserModeList to EmieModeList would have worked since that is how it came back when I relaunched IE.  I'll have to give that a try on another system.


    Following your suggestion of what you thought might work...   I renamed

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieBrowserModeList

    to

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache\Extensible Cache\EmieModeList

    and then IEEM worked perfectly.

    Now, the odd thing is that the registry key on my Win7 test system (freshly built VM) does use the EmieBrowserModeList name and IEEM works as properly there too.  Apparently the key changed for Win10, but since my machine was a Win8.1 to Win10 upgrade, the key didn't get changed... Seems to be the best explanation I can figure.

    Now I just have to figure out if we'll run into the problem if we use WET or USMT to migrate user profiles to Win10.  Wheeeeee.


    • Edited by jp-fna Thursday, August 27, 2015 2:17 PM fixed verbiage
    Thursday, August 27, 2015 2:12 PM
  • We have this exact same issue. Upgrade from Win7 to Win10 via SCCM - Enterprise Mode at the client level stops working completely. Build new Win10 system with .iso - Enterprise Mode works fine.
    Wednesday, September 2, 2015 5:59 PM
  • This worked for me.

    My situation came about after doing an in place upgrade from windows 8 to windows 10. All the fresh installs didn't cause the problem but EVERY instance of an upgraded PC from 8 to 10 that previously was using enterprise mode caused enterprise mode failure in 10.

    Thanks for the fix bshamster!

    Thursday, September 24, 2015 2:00 PM
  • I have the same issue on both my home PC (Win 10 Professional upgraded from Win 7) and my office PC (Win 10 Ent upgraded from Win 8.1). Tried the fix bshamster1 provided here and it works on my home PC. I will try it on my office PC tomorrow!

    Thanks a lot!

    Sunday, October 18, 2015 12:29 PM
  • This worked perfect! Thank you!

    This seems to be an issue whenever you do a USMT migration from one version of Windows to another.  I had this issue when I went from Win 10 - 10240 to the insider builds. 

    Thank you!

    Chris.

    Wednesday, October 28, 2015 6:40 PM
  • UPDATE: It looks like the Windows 10 1511 update disables enterprise mode.

    I just installed the 1511 update on 2 machines, one that I did a windows reset on to fix the issue after installing windows 10 and the other I used the above fix to get enterprise mode working with a site list. Following the 1511 update enterprise mode was not working so I check the settings and it was not enabled.

    I simply had to re-enable the group policy site list setting and pointed to my existing site list to get it working again.

    This might get annoying if we have to remember to re-enable this every time there is a major update to windows 10.

    Tuesday, November 17, 2015 3:25 PM
  • Same here. After installing the fall update, Enterprise mode stops working. Deleting the registry keys still doesn't get enterprise mode to work.
    Saturday, November 21, 2015 6:32 AM
  • Same here. Does anyone have a solution?
    Thursday, February 11, 2016 8:54 AM
  • Same here. Tried the solution above but it does not work.
    Thursday, March 10, 2016 9:32 AM
  • I'm seeing the same thing on a clean Win10 Enterprise 1511 build.

    We just want the ability to toggle EM on and off.  We're not interested in creating a site list or getting feedback on what sites the users are using EM for.

    I did a clean install of 1507 on one system and 1511 on another.  The source for these installs are ISO's that MS volume license office has provided.  So my 1511 is not an upgraded 1507.

    EM toggles on/off on the 1507, but does nothing on the 1511.

    On both systems, I did the direct reg poke to get the EM toggle visible in the Menu bar under Tools.

    HKLM\Software\Policies\Microsoft\Internet Explorer\Main\EnterpriseMode /v Enable /t REG_SZ /d ""

    This is the equivalent of going into Policy Editor and enabling the "Let users turn on and off Enterprise Mode from the Tools Menu" policy under Computer Config | Admin Templates | Windows Components | Internet Explorer.

    To get EM toggle working on the 1511, I added this reg setting:

    HKLM\Software\Policies\Microsoft\Internet Explorer\Main\EnterpriseMode /v SiteList /t REG_SZ /d ""

    This reg setting does have a policy associated to it, but if you use GPEDIT to try to set this, it wants you to put in a string for the sitelist location.  For the string, type in "fred" or "whyisEMbroken"...any bogus string.

    Test and see if it works for you.

    SpottedTreeFrog

    PS.  The policy for the SiteList string is "Use the Enterprise Mode IE website list".

    • Edited by SpottedTreeFrog Thursday, March 10, 2016 8:04 PM
    • Proposed as answer by Tom Sp Friday, January 6, 2017 12:30 PM
    Thursday, March 10, 2016 7:58 PM
  • Tried the solution above . It works for me. Thanks a lot! 
    Wednesday, April 6, 2016 8:52 AM
  • Thank you SpottedTreeFrog. On Win 10 Threshold 2 (v1511 fall update) deleting the cache registry keys didn't work but adding a blank "SiteList" registry key did the trick and made the manual toggle option work (rather than doing nothing at all!)

    On Redstone 1 (v1607 anniversary update) this is not required, for some reason.

    Friday, January 6, 2017 12:33 PM