none
Sharepoint Explorer View problem RRS feed

  • Question

  • I am no longer able to access a SharePoint document library through Explorer View

    I can however access the document library fine from SharePoint (i.e. without using Explorer View).

    The error that I am getting in Internet Explorer when I try to open the library with the Explorer View is:

    "\\server\documentlib\doc is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. A device attached to the system is not functioning"

    Note also the following details

    -This used to work until about a week ago when for some reason is stopped working.

    -Security is fine (i.e. same user can access fine the document library in SharePoint – only opening using the Explorer view doesn’t work)

    -There are other document libraries on the same site which works ok using Explorer View

    -I tried using various clients (Windows XP SP3, Windows 7) and none works

    -There are about 10,000 documents in the library (about 10GB in total) where the Explorer View access doesn’t work

    -I already review KB912152 and doesn’t seem to be the case here (since I tried also XP SP3 and Windows 7 and it does the same thing)

    I am running MOSS 2007 Service Pack1 on a Windows 2003 Server Service Pack 2

    • Moved by Mike Walsh FIN Monday, August 15, 2011 6:22 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Sunday, August 14, 2011 5:23 PM

Answers

  • Hi ,

     

    I understand that you can open the document library using ‘Open with Windows Explorer ’ before .But now it will prompt that you don’t have permission to access it .You can try this workaround on your windows  server 2003 .

    1.       Click Start, click Run, type services.msc, and then click OK.

    2.       In the Services window, right-click Workstation, and then click Stop.

     

    Thanks,


    Entan Ming
    Tuesday, August 16, 2011 6:08 AM
    Moderator
  • Hi,

    You can use the functionality of explorer view by mapping your library to a netwrork drive.

    Have you tried this? If not refer this

    http://blog.makeitcomplete.com/2008/09/map-sharepoint-document-folder-to-a-network-drive/

     

    I hope this will help you out.

     


    Thanks, Rahul Rashu
    Tuesday, August 16, 2011 9:34 AM

All replies

  • HI,

    Check if webclient services is up and running fine.

     


    Thanks, Rahul Rashu
    Monday, August 15, 2011 10:51 AM
  • Yes as mentioned by Rashu, Rahul try to restart the webclient service

    Also in your previous comments you mentioned that the KB -KB912152  is not the case as you also tried in Windows 7 and it was throwing error, i checked the windows 7 settings and the default webdav file limit is the same ,
     can you please try the KB912152 and let us know if it works or not ?

     so that we can look for some other alternatives . Thanks


    Thanks & Regards Posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, August 15, 2011 2:49 PM
  • yes the webclinet services is up and running fine .
    Monday, August 15, 2011 7:17 PM
  • I tried  KB912152 on Windows XP SP3 IE7 and is working fine.  I apply the registry changes(KB912152) to Windows XP SP3 IE8 and is not working I have the same error. Thank you.

     

     

    Monday, August 15, 2011 7:27 PM
  • Hi ,

     

    I understand that you can open the document library using ‘Open with Windows Explorer ’ before .But now it will prompt that you don’t have permission to access it .You can try this workaround on your windows  server 2003 .

    1.       Click Start, click Run, type services.msc, and then click OK.

    2.       In the Services window, right-click Workstation, and then click Stop.

     

    Thanks,


    Entan Ming
    Tuesday, August 16, 2011 6:08 AM
    Moderator
  • Hi,

    You can use the functionality of explorer view by mapping your library to a netwrork drive.

    Have you tried this? If not refer this

    http://blog.makeitcomplete.com/2008/09/map-sharepoint-document-folder-to-a-network-drive/

     

    I hope this will help you out.

     


    Thanks, Rahul Rashu
    Tuesday, August 16, 2011 9:34 AM
  • Found this post while investigating for same problem.

    Configuration : MOSS 2007

    My issue resolved using this article .

    http://support.microsoft.com/kb/912152

    Sorry for late reply though may help to other user facing identical isue.

    Wednesday, April 17, 2013 7:11 PM