none
UAG with Windows 10 (And IE 11) RRS feed

  • Question

  • It does not seem to work as it should in IE 11.

    I do not get prompted for a plugin install.

    Changing the user agent settings a bit I was able to get the plugin installed, but this changed nothing. The plugin still does not appear to work properly.

    Any advice on how to get this working?

    Tuesday, July 28, 2015 1:49 PM

All replies

  • I have the same problem. I cannot access the company webpage now with IE11 on Windows 10. Can anybody help?

    • Proposed as answer by Pascal Visscher Thursday, September 10, 2015 8:12 PM
    • Unproposed as answer by Pascal Visscher Thursday, September 10, 2015 8:12 PM
    Wednesday, August 12, 2015 5:12 AM
  • I'm not sure about Windows 10, but I know I had issues with IE 11 and the UAG on previous versions of Windows and I ended up having to use Compatibility Mode to get an internal site to display.
    Wednesday, August 12, 2015 2:55 PM
  • Having the same problem....
    Wednesday, August 12, 2015 6:53 PM
  • Similar problem here.

    UAG site already in compatibility of IE11, I can use most of the UAG but for the JAGUAR remote services.

    It seems that the SSL Application Tunneling component of UAG (ver 4.0.4083.10000) is not installed.

    Found two hotfixes KB2475733 and KB2647899 and the full install of my version of UAG (KB2861386) but unfortunately all of them failed to install claiming that the software to be upgraded was not already in my computer.

    Any ideas welcome.

    Thanks


    • Edited by tty82 Monday, August 24, 2015 8:48 PM
    Monday, August 24, 2015 8:47 PM
  • I have the same problem, but I'm able to install the UAG Client components manually (install msi file).

    Then switch UAG site in IE11 to compatibility mode and I can Login without any Problems. The client components detects all System components (OS version, Antivirus version, IE), only the Windows 10 Firewall cannot detect correctly. The only main issue I have, inside Portal the Client can't see any shared RDP applications.

    Wednesday, August 26, 2015 9:17 AM
  • same ploblem
    Monday, August 31, 2015 5:23 AM
  • Hello, any official response?

    The data above this text is pseudorandom, brace yourselves.

    Saturday, September 5, 2015 8:43 PM
  • I found a workaround on a technet blog

    This will make IE 11 in Windows 10 function with UAG:

    - On your UAG server

     - open web.config in Program Files\Microsoft Forefront Unified Access Gateway\von\InternalSite
    - add following lines of code:

    <DetectionExpression Name="Windows10" Expression='UserAgent Contains "windows nt 10.0"' DefaultValue="false" />
    < DetectionExpression Name="WindowsNewerThan2000" Expression='UserAgent Contains "windows nt 5.1" OR UserAgent Contains "windows nt 5.2" OR Vista OR Windows7 OR Windows8 OR Windows8_1 OR Windows10' DefaultValue="false" />

    Origanal Source:

    http://blogs.technet.com/b/edgeaccessblog/archive/2015/06/19/rollup-2-for-forefront-unified-access-gateway-2010-service-pack-4-is-available-for-download.aspx

    From: Kevin

    • Proposed as answer by Ty Glander Monday, October 26, 2015 11:27 PM
    Thursday, September 10, 2015 8:17 PM
  • I'm afraid the official response is that there is no roadmap for Windows 10 support in UAG:

    Based on product strategy, customer feedback, and prevailing market dynamics, Microsoft has made the decision not to deliver any further full version releases of UAG and TMG. To maintain business continuity with Windows 10, we recommend migrating to Web Application Proxyand Azure Active Directory Application Proxy.

    This is from System requirements for Forefront UAG client devices.

    Tuesday, September 15, 2015 3:14 PM
  • One month later...
    Something new about it?
    We installed UAG 2010 Service Pack 4 Rollup 2 and tried the Workaround, but still the same Problem.
    When we add the changes to the web.config, all other Clients can't see the RDP-Sessions, too.

    With the old web.config  it worked again with all old Clients, but not for Windows 10...

    Any other ideas?

    Web Application Proxy is no alternative product - less functions...

    Wednesday, October 14, 2015 1:48 PM
  • What did you Change?
    Wednesday, October 14, 2015 1:48 PM
  • UAG is only supported with Windows 10 Enterprise.  Hope this helps.

    • Proposed as answer by MatthewEUK Thursday, November 5, 2015 7:09 PM
    • Unproposed as answer by MatthewEUK Thursday, November 5, 2015 7:09 PM
    Monday, November 2, 2015 7:35 PM
  • I have found a solution to this - 

    • Open regedit.exe (Run -> Regedit.exe)
    • Navigate to the Registry Key : Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION
    • Right click the blank space beneath the other keys once you’ve navigated to this folder.
    • Select New -> DWORD (32-bit) Value. Once this is made, enter the name “iexplorer.exe” without the quotations.
    • Enter/Modify (Right Click -> Modify) this new entry to have the following values:
    • Value data: 9000
    • Base: Decimal

    This then in essence 'tricks' IE11 into acting like IE9, which allows RDP Terminal Servers to display on UAG however I'm unsure if the change we made on UAG Server Side mentioned in 'Web Config' added to this success so I'd advise doing that too. This is because we made the web.config change and it made no difference to our Windows 10 installations - the above fix has worked on an Enterprise and Pro edition external to the network.

    I'm aware the above answer states that Enterprise edition is the only option - Yes this edition does have 'Enterprise Mode' inbuilt into IE11, this therefore allows the page o load as if it was IE8.

    Reference: http://maffew.uk/2015/11/05/windows-10-uag-fix/


    Thursday, November 5, 2015 7:14 PM
  • Hey Kenneth981,

    Try emulating to IE9 just to trigger the install of Active X. After installing the UAG components, it would work normally again

    • Proposed as answer by Ducatista Thursday, January 14, 2016 10:49 AM
    Monday, January 11, 2016 4:27 AM
  • I finally managed to install UAG components on a fresh new Windows 10 instalation.

    Here it is what I did:

    Get your WhlClientSetup-All.msi and run it, once it loads the welcome screen, open task manager, find that window on the list and open file location. You'll see the contents of the MSI. In case you don't have access to it, I uploaded the extracted msi files to http://www.4shared.com/rar/WICO_Z2Lce/ClientSetup.html.

    Now right click on setup.exe > compatibility > set the compatibility to Windows 7 and click ok.

    Run setup.exe, click Next and select Custom, select all the items and click next, next, finish. (you should see the progress bar running, if it just skip to the final screen, something went wrong).

    If the previous step succeed, you'll have a folder C:\Program Files\Microsoft Forefront UAG\Endpoint Components\3.1.0;

    Go to this folder, find WhlClnt3.exe, right click etc etc and set compatibility to Windows 7 as well.

    Now open IE 11 as administrator, go to your VPN url, and as soon as you hit enter, press F12. Go to emulation and select User Agent String: Internet Explorer 9.

    Enter your credentials... and enjoy!

    Hope it helps!

    Bruno


    • Edited by brunopiovan Saturday, January 23, 2016 2:13 AM typo
    Saturday, January 23, 2016 2:09 AM
  • Hello there,

    Best way is to get the service pack upgraded to SP4 with latest rollups.

    I did this in our environment and it works perfect.

    You need to keep a recovery point and configuration backup before you do so. 

    Below is the sequence I followed,

    Get windows updates up to date on all servers in array.

    SP3 rollup1 is pre requisite for UAG SP4

    Below link has clarity on the steps. Please let me know if anyone need more details on this upgrade

    Monday, January 25, 2016 10:31 AM
  • In Windows 10 Home with Internet Explorer 11 I was able to create an RDP connection by pressing F12 before logging in and (in the emulation tab) set the document mode to 7 and the user agent to IE8. Keep the emulation tab open en log in. The RDP options were available after this. (Make sure you accept all ActiveX prompts which are sometime hidden behind the 'save password?' popup.)
    Wednesday, January 27, 2016 8:07 AM
  • IE 11 on Windows 8.1 (Pro) works as expected.  I cannot believe Microsoft will let this stand.  Nearly all Dept-Of-Defense sites require use of client-side certificate (CAC) as the only way to access a resource (e.g. web sites).  Many use Silverlight, so IE 11 is also required.  If Windows 10 does not allow the client certificate to be required and processed, then Windows 10 will not roll out for them.

    Eric JohnsonAtProModel

    Monday, May 23, 2016 9:06 PM
  • Hi Bruno,

    Hats Off to you...Man ! I was having trouble finding WhlClientSetup-All.msi  file but thanks to you I was able to download and install UAG client in Win 10 and followed the rest of the process and it worked just fine. I have seen and tried numerous ways given in various forums. But your process has worked for me and it should work for others also.  I really appreciate your help on this.

    Sunday, March 17, 2019 5:59 PM