none
DL is not receiving emails from external address.

    Question

  • Hi Team,

    We have one particular DL not receiving email from external addresses.Internal emails are getting delivered.

    we are getting this error when checked from Connectivity analyser.

    _______________________________________

    Attempting to send a test email message to informatica@xyz.test using MX mx record name.
      Delivery of the test email message failed.
     
    Additional Details
     
    The server returned status code 451 - Error in processing. The server response was: 4.7.1 Service unavailable - try again later
    Exception details:
    Message: Error in processing. The server response was: 4.7.1 Service unavailable - try again later
    Type: System.Net.Mail.SmtpException
    Stack trace:
    at System.Net.Mail.RecipientCommand.CheckResponse(SmtpStatusCode statusCode, String response)
    at System.Net.Mail.RecipientCommand.Send(SmtpConnection conn, String to, String& response)
    at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, Boolean allowUnicode, SmtpFailedRecipientException& exception)
    at System.Net.Mail.SmtpClient.Send(MailMessage message)
    at Microsoft.Exchange.Tools.ExRca.Tests.SmtpMessageTest.PerformTestReally()
    Elapsed Time: 766 ms.

    ______________________________

    we are getting this error when checked from Gmail.

    ________________________________

    The error that the other server returned was:
    550 5.2.0 mailbox unavailable.

    _____________________________

    we have checked all settings for this DL, external delivery is also enabled.

    Please assist.

    Thanks


    Abhishek Saxena

    Wednesday, December 23, 2015 1:03 PM

Answers

  • If the telnet test directly to your Retarus failed, for some reason, it doesn't have your group in its directory lookup.

    Will Martin ...
    -join ('77696c6c406d617274696e2d66616d696c6965732e6f7267' -split '(?<=\G.{2})' | ? { $_ } | % { [char][int]"0x$_" })

    Wednesday, December 23, 2015 3:57 PM

All replies

  • Just checking - is the error from the GMail test coming from your system or from GMail?

    As for the errors from the connectivity analyzer, did you test with another email address as well as the one for this distribution group?

    Do you have a separate message hygiene system in place?  If so, does it also check for valid recipients?  And if so (again), did it have this distribution list in its recipient list?


    Will Martin ...
    -join ('77696c6c406d617274696e2d66616d696c6965732e6f7267' -split '(?<=\G.{2})' | ? { $_ } | % { [char][int]"0x$_" })

    Wednesday, December 23, 2015 1:47 PM
  • The text is from NDR i have received in gmail when sent a test email to this address.

    yes did checked other DL's from connectivity analyzer result was successful.

    Yes we have Retarus gateway in place and it it does check for valid recipients, i have ran a sync to update all address yesterday and i was expecting that it should work today but it didn't.

    yes this DL have 10+ members.


    Abhishek Saxena

    Wednesday, December 23, 2015 2:06 PM
  • If you telnet to your Retarus system on port 25 and try to send to that distribution group, what response do you get?

    Will Martin ...
    -join ('77696c6c406d617274696e2d66616d696c6965732e6f7267' -split '(?<=\G.{2})' | ? { $_ } | % { [char][int]"0x$_" })

    Wednesday, December 23, 2015 2:41 PM
  • Tested sending email from Telnet

    It was successfully queues to delivery queue.


    Abhishek Saxena

    Wednesday, December 23, 2015 3:34 PM
  • Hi,

    Is the telnet test email actually delivered to the mailboxes? If there are any bouncebacks, these will go to the from address you used in the telnet test.

    Thanks.


    Please mark as an answer if this answers your question

    Mark Gossa

    MCSE 2003, MCITP Enterprise Administrator 2008 R2, MCSA 2012 R2, MCTS Exchange 2010, MCTS SQL 2012, MCTS SharePoint 2007, VCP4, VCP5, CCNA

    Blog: http://markgossa.blogspot.com   LinkedIn:

    Posts are provided “AS IS” without warranty of any kind, either expressed or implied.

    Wednesday, December 23, 2015 3:44 PM
  • it was not delivered received a bounce back message 

    Technical details of permanent failure:
    Google tried to deliver your message, but it was rejected by the server for the recipient domain XTZ.EST by MX_RECORD_NAME [IP ADDRESS].

    The error that the other server returned was:
    550 5.2.0 mailbox unavailable.



    Abhishek Saxena


    Wednesday, December 23, 2015 3:48 PM
  • i have tested on some other mailboxes and DL they were delivered.

    Abhishek Saxena

    Wednesday, December 23, 2015 3:49 PM
  • If the telnet test directly to your Retarus failed, for some reason, it doesn't have your group in its directory lookup.

    Will Martin ...
    -join ('77696c6c406d617274696e2d66616d696c6965732e6f7267' -split '(?<=\G.{2})' | ? { $_ } | % { [char][int]"0x$_" })

    Wednesday, December 23, 2015 3:57 PM
  • ill open a case with them to check.

    Thanks Will for all your support, ill keep you posted.


    Abhishek Saxena

    Wednesday, December 23, 2015 4:03 PM
  • Hi,

    Can you check the email address tab for that user. Any external mail specified over there..Get the NDR mail & check the message header. Whether the mail has been reached to your domain or not.

    Could you post which Mail gateway are you using. If its logix or Exchange edge DL name should be reflected in order to reach the mail to recipient.

    Wednesday, December 23, 2015 10:57 PM