none
Allow blocked content (Javascript) on local HTML files IE11 RRS feed

  • Question

  • We are moving from IE8 to IE11 and one of our users is having a problem viewing locally saved HTML files since they had IE11 installed.

    In IE8 when they open the HTML files they receive a prompt to "Allow Blocked Content" which is accepted, and then the page displays.

    In IE11 (with exactly the same settings as in IE8) the page opens then hangs. When I press F12 and go to debugging it says "It appears that you may have JavaScript disabled) but it is enabled.

    When I open this page as a local administrator I do get a prompt to allow blocked content. When I click on that I get a message "It appears that you may have JavaScript disabled". Again, I can confirm "Active Scripting" is enabled.

    Any ideas anyone please!?

    Wednesday, April 8, 2015 1:54 PM

All replies

  • Tools>Internet Options>Advanced tab, check "Allow active content to run in files in MyComputer"

    reboot your computer for the full changes to take affect.

    or

    apply the setting using GPO.

    see http://blogs.msdn.com/b/ieinternals/archive/2011/03/23/understanding-local-machine-zone-lockdown-restricted-this-webpage-from-running-scripts-or-activex-controls.aspx

    <quote>

    I
    strongly recommend that you leave the Allow active
    content to run in files
    box unticked, as it is by default.

    </quote>

    Regards.


    Rob^_^

    Thursday, April 9, 2015 12:38 AM
  • Sorry, I forgot to say I had already tried that. It didn't make any difference.
    Thursday, April 9, 2015 7:36 AM
  • Hello faulknerp1,

    Only one user has this issue?

    Please refer to the following article to enable JavaScript in Internet Explorer.
    https://support.microsoft.com/en-us/gp/howtoscript

    Please try to reset the Internet Explorer and check if the issue still exists.
    https://support.microsoft.com/en-us/kb/923737

    Best regards,
    Fangzhou CHEN


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, April 10, 2015 5:30 AM
    Moderator
  • Hi, thanks for your reply.

    I think this person saves HTML files from an application. These HTML files do not open on ANY computer that runs IE11. When you open them on an IE8 machine it's OK.

    The only way around it I have found so far is inserting the line <meta http-equiv="X-UA-Compatible" content="IE=8"/> directly into the HTML file and then opening it in IE11.

    I don't think that's a practical solution as he regularly saves HTML files and I can't expect him to manually edit each file every time.

    Friday, April 10, 2015 8:04 AM