none
DNS issue on new domain controller - Win 2012 R2 RRS feed

  • Question

  • Hi,

    I am on a remote office .. SAN died and all other servers.

    I have quickly build a new server running DNS, DHCP, AD .. All users via cable and wifi can go online and even ping internal servers from other sites.

    However I cannot properly ping internal servers from this DNS server itself, sometime it does other time does not.

    In network card property I have used DNS1 as DNS server from 1 site and DNS2 as DNS server from other site and same as forwarders..

    Event viewer have error 4015:

    The description for Event ID ( 4015 ) in Source ( Microsoft-Windows-DNS-Server-Service ) cannot be found. Either the component that raises this event is not installed on your local computer, or the installation is corrupted. You can install or repair the component on the local computer, or contact the component manufacturer for a newer version.

    But dcdiag /test:dns and sfc /scannow completes without any error.

    I have installed all available updates and added correct subnets + connections to other sites, 

    please suggest.


    • Edited by Beadmin Tuesday, March 27, 2018 9:14 AM
    Tuesday, March 27, 2018 5:52 AM

All replies

  • Hi,

    Have a nice day! Thanks for your question.

    << However I cannot properly ping internal servers from this DNS server itself, sometime it does other time does not.

    Please check the following to see if it works.

    1.Check if the server is configured security policy such as NPS or RRAS to block the ping traffic.

    2.Make sure ADDS is functioning properly and check for any event logs about your AD DS to see if there is any problem of AD DS.

    Since the DNS Server service relies on Active Directory Domain Services (AD DS) to store and retrieve information for AD DS-integrated zones. Event ID 4015 indicates that AD DS is not responding to requests from the DNS Server service.

    Please refer to the following link:

    https://technet.microsoft.com/en-us/library/cc735674%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

    Highly appreciate your effort and time. If you have any questions and concerns, please feel free to let me know.

    Best regards,   

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, March 28, 2018 7:17 AM
  • Hi,

    How are things going on? Was your issue resolved?

    Please let us know if you would like further assistance.

    Wish you have a nice day!

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, March 30, 2018 11:33 AM
  • Hi,

    How are things going on? Was your issue resolved?

    Please let us know if you would like further assistance.

    Wish you have a nice day!

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, April 2, 2018 1:16 PM