none
4.3.2 QUEUE.TransportAgent; message deleted by transport agent

    Question

  • Hi

    We have a big problem here!
    A lot of messages are just deleted by the transport agent. I don't know why that happens. Message tracking just show me the following entries:


    TrendMicro Scanmail has been installed on the server, and from that point I get these entries. So there must be a relation between, but I don't know what.

    Any Suggestions?

    Regards
    Peter


    • Edited by PeterN22 Wednesday, September 23, 2015 11:40 AM
    Wednesday, September 23, 2015 11:24 AM

Answers

  • Disable the scanmail transport agent:

    Get-TransportAgent

    then Disable-TransportAgent <agent>

    I assume it has one.

    If that doesnt work, uninstall Scanmail and test.

    I would open a case with Trend if that is the cause.


    Twitter!: Please Note: My Posts are provided “AS IS” without warranty of any kind, either expressed or implied.

    • Proposed as answer by David Wang_Moderator Thursday, September 24, 2015 1:36 AM
    • Marked as answer by PeterN22 Thursday, September 24, 2015 5:49 AM
    Wednesday, September 23, 2015 12:32 PM

All replies

  • Disable the scanmail transport agent:

    Get-TransportAgent

    then Disable-TransportAgent <agent>

    I assume it has one.

    If that doesnt work, uninstall Scanmail and test.

    I would open a case with Trend if that is the cause.


    Twitter!: Please Note: My Posts are provided “AS IS” without warranty of any kind, either expressed or implied.

    • Proposed as answer by David Wang_Moderator Thursday, September 24, 2015 1:36 AM
    • Marked as answer by PeterN22 Thursday, September 24, 2015 5:49 AM
    Wednesday, September 23, 2015 12:32 PM
  • Hi Andy

    Thanks a lot for answering.

    There are 2, a Scanmail Routing Agent and a Scanmail SMTP Receive Agent.
    I increased the attributes in message tracking and found on every FAIL event under MessageInfo the following: 
    ...CAT|CATRS|CATRS-ScanMail Routing Agent

    So I disabled the ScanMail Routing Agent.

    I will take a look tomorrow, if there are still deleted mails by Transport Agent, and keep you updated.

    Regards
    Peter

    Wednesday, September 23, 2015 2:27 PM
  • Hi Andy

    It works, these message deleted entries are gone.

    Thanks a lot for your quick answer.


    Regards
    Peter

    Thursday, September 24, 2015 5:51 AM
  • Hi Peter,

    How did you increase the attributes in message tracking. I have the same problem and would like to identify the agent causing the issue.

    Thanks!

    Regards

    Manuel

    Friday, December 16, 2016 10:08 AM