none
TIMESTAMP MARKER ON LOG FILE

    Question

  • I developed an application I want to deliver to users with SQL Server 2008 Express.  Quite mode installation of SQL Server 2008 Express failed because of timestamp error with the description that "The timestamp marker on log file file has not been set.  The timestamp must be set prior to it being used for the first time".  I have used the solution suggested by David Young - MSFT but the error persist.  Below is the installation syntax I used:

    Setup.exe /qs /Action=Install /Features=SQL /InstanceName=SQLExpress05 /SecurityMode=SQL /SAPwd=MyPassword /SQLSvcAccount="NT Authority\System" /SQLSysAdminAccounts=MyLaptop\"Ayotunde Sodipe" /TimeStamp="%04d%02d%02d_%02d%02d%02d"

    Please, what am I doing wrong?

    Thank you very much.

    Sunday, August 19, 2012 1:54 AM

All replies

  • Is there a reason you need to set the timestamp?  If you remove the timestamp parameter, will setup succeed?  You will also want to fix the quotes location in the SQLSysAdminAccounts.  They should be surrounding the entire account.  (ex: /SQLSysAdminAccounts="MyLaptop\Ayotunde Sodipe")

    Can you make these two updates and try again?

    Thanks,
    Sam Lester (MSFT)


    My Blog

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you. This can be beneficial to other community members reading the thread.

    Sunday, August 19, 2012 4:41 PM
    Moderator
  • Sam,

    Thank you very much for your prompt response to my problem.

    You asked if there is a reason I need to set the timestamp parameter.  There is no need for me to set the timestamp but when I do quiet installation of SQL Server 2008 Express without the timestamp parameter, the installation failed and gave the same error prompt "The timestamp marker on log file file has not been set.  The timestamp must be set prior to it being used for the first time".

    I have corrected the quote signs around my name in the /SQLSysAdminAccounts parameter and the installation still failed with the same error prompt.

    Please what should I do next?

    Thank you very much again.

    Yours,

    Ayotunde.

    Monday, August 20, 2012 1:13 AM
  • Would you please share and upload SQL Server setup logs, you can use file sharing service like SkyDrive.com

    to view and analyze SQL server setup logs 

    http://msdn.microsoft.com/en-us/library/ms143702(v=sql.100).aspx


    Regards,
    Ahmed Ibrahim
    SQL Server Setup Team
    My Blog
    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you.
    This can be beneficial to other community members reading the thread.

    Monday, August 20, 2012 1:32 AM
    Moderator
  • Sam,

    Again, thank you very much for your assistance.

    I have tried everything possible but still did not work.  In order to save time, I decided to leave the users with instructions/procedure on how to install SQL Server 2008 Express prior to installing the application I am deploying.

    Thank you very much again.

    Yours,

    Ayotunde.

    Monday, August 20, 2012 10:28 PM
  • Sorry I didn't have time to dig into this one, I'm curious why it was requiring the timestamp parameter.  My guess would be that something in the command line was slightly off, but nothing jumped out.  The setup logs may contain the answer if you want to supply those for someone to dig in. 

    Best of luck,
    Sam Lester (MSFT)


    My Blog

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you. This can be beneficial to other community members reading the thread.

    Tuesday, August 21, 2012 12:37 AM
    Moderator