locked
Hiding users from Global Address List in Exchange 2010 RRS feed

  • Question

  • I am attempting to hide users no longer in our company from our GAL.  I have been trying to do this through Active Directory.  I verified the 'hide from Exchange address list' in AD is checked for these users, but they still shows up.  On my own PC I deleted the *.oab files and downloaded the offline address book again, but it still shows.  I also checked OWA and they show in there as well.


    Is there anywhere else that would hold these?  I have searched but could not find much related to this.  We are running Exchange 2010 SP1.


    Any help would be appreciated.

    Monday, August 29, 2011 12:54 PM

Answers

  • We figured it out.  The person in charge of disabling was doing so in an Active Directory 2003 environment.  When I opened the EMC it showed as disabled but must have missed telling the GAL somewhere.  I had to uncheck the hide box, apply the settings, recheck the hide box, and apply the settings again.  After doing this, it disappeared from the GAL.  Going forward, he will hide from the EMC.

    Thanks everyone for the responses.

    • Marked as answer by jparf86 Monday, August 29, 2011 5:11 PM
    Monday, August 29, 2011 5:11 PM

All replies

  • If the account is disabled in AD, it should automatically hide it in the address book.
    Monday, August 29, 2011 3:10 PM
  • You should use the Exchange Management Console (EMC).  For bulk-hiding, the Exchange Management Shell (EMS) would be more appropriate.

    Open the Properties dialog box for the mailbox-enabled user account by double-clicking the user name in the Exchange Management Console.
    On the General tab, select the Hide From Exchange Address Lists check box and then click OK

    You will see these changes almost immediately in OWA and Outlook in online mode. For cached mode, an update to the Offline Address Book must be generated, distributed and be downloaded by the clients.

    Exchange 2010 - Hide Mailbox from Global Address List
    http://mockbox.net/exchange-2010/384-exchange-2010-hide-mailbox-from-global-address-list.html


    MCTS: Messaging | MCSE: S+M
    • Proposed as answer by Ron Proschan Wednesday, March 21, 2012 10:53 PM
    Monday, August 29, 2011 3:13 PM
  • Hi,

    Try to hide it thru EMC as given below and then check.

    http://technet.microsoft.com/en-us/magazine/ff381467.aspx

     


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    Monday, August 29, 2011 3:13 PM
  • This box is checked.  I should have said I did this as well in the original post.  We are thinking maybe the contacts list is also pulling from our Public Folders.  Is there anywhere in the EMC to configure where the GAL is pulled from?  I'd like to see if somewhere in there it tells to pull from the wrong list.  When we go into the GAL in Webmail/OWA, and highlight the person, there is no organization drop down for them, if that makes sense.  Most of the users have this drop down.  At first I thought maybe they were set up as a contact in AD, but again, searching for them yields nothing.
    Monday, August 29, 2011 4:47 PM
  • The Default Global Address List is a collection of all mailbox-enabled users, mail-enabled users, mail-enabled contacts, dynamic distributions groups, mail-enabled groups, mail-enabled public folders, and system mailboxes in your Exchange organization.

    Perhaps you should issue

    Get-GlobalAddressList| Update-GlobalAddressList

    This should remove hidden users from the GAL.

    While about Exchange, this does also apply to Exchange 2010 (afaik).
    Address Lists in Exchange 2007 (Part 1)
    http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/address-lists-exchange-2007-part1.html


    MCTS: Messaging | MCSE: S+M
    • Proposed as answer by JoeShmo101 Monday, August 7, 2017 7:53 PM
    Monday, August 29, 2011 5:08 PM
  • We figured it out.  The person in charge of disabling was doing so in an Active Directory 2003 environment.  When I opened the EMC it showed as disabled but must have missed telling the GAL somewhere.  I had to uncheck the hide box, apply the settings, recheck the hide box, and apply the settings again.  After doing this, it disappeared from the GAL.  Going forward, he will hide from the EMC.

    Thanks everyone for the responses.

    • Marked as answer by jparf86 Monday, August 29, 2011 5:11 PM
    Monday, August 29, 2011 5:11 PM
  • On Mon, 29 Aug 2011 15:10:03 +0000, ty72182 wrote:
     
    >If the account is disabled in AD, it should automatically hide it in the address book.
     
    That's not true. If it were then "shared" mailboxes (where the accout
    is disabled) wouldn't show up.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Wednesday, August 31, 2011 1:06 AM
  • Hi, 

    Do u know how to hide account from GAL in exchange 2010. i disabled the account by checking the box in the general tab but it is still showing in GAL.

    Thanks

    Thursday, August 16, 2012 5:45 AM
  • Monday, October 29, 2012 6:27 PM
  • I had the same issue like this and it was resolved by unhidding it then hide it again. It is the best thing to do in PowerShell so here is the commandlet. This works for me. Happy PS. 

    set-mailbox -id user@contoso.com -HiddenFromAddressListsEnabled $False

    set-mailbox -id user@contoso.com -HiddenFromAddressListsEnabled $True

    Happy to solve MSISSUE.

    • Proposed as answer by Vinci Marticus Wednesday, January 23, 2013 1:29 PM
    Wednesday, January 23, 2013 1:28 PM
  • Just wanted to confirm that this worked for me too.

    I had been using ADUC to select "Hide user from exchange".  The box was still checked in EMC, but the user was still visible in the GAL.

    I simply unchecked the box in EMC, hit Apply, then checked the box again, hit Apply.

    Then downloaded a new Address Book and voila! the name is now gone.

    Wednesday, August 27, 2014 11:26 PM