locked
Does anyone come accross the following error RRS feed

  • Question

  • When i build the management pack it got succeeded and when i deploy the management pack to management server it is showing following error

    Date: 6/9/2015 11:54:38 PM
    Severity: Error
    Message: Deployment task failed
    
    System.ArgumentException: The requested management pack is not valid. See inner exception for details.
    Parameter name: managementPack ---> Microsoft.EnterpriseManagement.Common.ManagementPackException: Cannot find resource with ID ImagesMP.Computer.Seed.Diagram.
       at Microsoft.EnterpriseManagement.Common.Internal.ServiceProxy.HandleFault(String methodName, Message message)
       at Microsoft.EnterpriseManagement.Common.Internal.ManagementPackServiceProxy.TryImportManagementPackWithResources(String managementPack, String keyToken, Dictionary`2 resources)
       at Microsoft.EnterpriseManagement.ManagementPackManagement.TryImportManagementPack(ManagementPack managementPack, IDictionary`2 resources)
       --- End of inner exception stack trace ---
       at Microsoft.EnterpriseManagement.ManagementPackManagement.TryImportManagementPack(ManagementPack managementPack, IDictionary`2 resources)
       at Microsoft.EnterpriseManagement.ManagementPackManagement.ImportManagementPack(ManagementPack managementPack, IDictionary`2 resources)
       at Microsoft.EnterpriseManagement.ManagementPackManagement.ImportBundle(ManagementPackBundle package, ImportPackagedManagementPackCallback handler)
       at Microsoft.EnterpriseManagement.ManagementPackManagement.ImportBundle(ManagementPackBundle package)
       at Microsoft.SystemCenter.Authoring.ProjectSystem.Deployment.Services.NativeImporter.ImportBundle(ManagementGroup mg, String fileName)
       at Microsoft.SystemCenter.Authoring.ProjectSystem.Deployment.Services.NativeImporter.ImportManagementPack(String fileName)
       at Microsoft.SystemCenter.Authoring.ProjectSystem.Deployment.Tasks.ImportTask.DoWork()
       at Microsoft.SystemCenter.Authoring.ProjectSystem.Deployment.DeploymentTaskBase.Run()
    : Cannot find resource with ID ImagesMP.Computer.Seed.Diagram.

    The error arises only if the following code is added to MP

    <Categories>
        <Category ID="Cat.ImagesMP.Service.Diagram" Target="ImagesMP.Service.Diagram" Value="System!System.Internal.ManagementPack.Images.DiagramIcon" />
        <Category ID="Cat.ImagesMP.Service.Icon" Target="ImagesMP.Service.Icon" Value="System!System.Internal.ManagementPack.Images.u16x16Icon" />
      </Categories>
      <Presentation>
        <ImageReferences>
          <ImageReference ElementID="ImagesMP.Service" ImageID="ImagesMP.Service.Diagram"/>
          <ImageReference ElementID="ImagesMP.Service" ImageID="ImagesMP.Service.Icon"/>
        </ImageReferences>
      </Presentation>
      <Resources>
        <Image ID="ImagesMP.Service.Diagram" FileName="serverx80.png" Accessibility="Public" HasNullStream="false" Comment="ConfigMgr 2012 Client Icon Diagram" />
        <Image ID="ImagesMP.Service.Icon" FileName="serverx16.png" Accessibility="Public" HasNullStream="false" Comment="ConfigMgr 2012 Client Icon Small" />
      </Resources>
    Can anyone help me in resolving this error?

    Thanks & Regards, Suresh Gaddam


    Wednesday, June 10, 2015 6:59 AM

Answers