none
Microsoft Windows section missing under Installed Updates

    Question

  • I am having a problem uninstalling some updates that were automatically installed by windows because the section that contains those updates in "Installed Updates" is just missing. Normally you would go to Control Panel > Uninstall a Program > View Installed Updates then you would see a list trees with updates in each section. The section for Microsoft Windows isn't there. I'm not skipping over it, it's just not there.

    Example of not showing the section for Microsoft Windows:

    Example of showing the section for Microsoft Windows:

    I am running windows 7 on a domain environment. I am trying to uninstall IE11 update to revert back to IE9 (this was previously installed). My hunch is that this is a group policy setting somewhere, but haven't found anything pertaining to this yet.

     I am one of two admins for the company. This is actually happening to all the computers that I've checked, so I assume it's a systemic problem.
    I have been working on a new pc today that I needed to create an image for and noticed it isn't having the issue yet. However, a computer I recently imaged (Tuesday) is already having the problem.

    I did gpupdate /force on the new pc without the issue, and it still is working fine. I'm starting to wonder if it may be a side effect of using sysprep on the machine before putting it into service. Once I'm done with this new pc image I will sysprep it and watch for any changes.

    Any help is appreciated.

    Friday, December 13, 2013 7:13 PM

All replies

  • Well I used sysprep on this machine and checked afterwards. It did not have this issue at the time. I will be reconnecting it to the domain, and placing it back into it's correct OU in AD to see if this could still be a group policy issue.
    Friday, December 13, 2013 11:05 PM
  • I added this back to the domain in it's correct container. I ran gpupdate /force on the machine and reboot it. Currently it is not having the current issue I am concerned with on my other machines, but I will allow it to sit on the domain for the default 22 hours in group policy to allow it to check for updates and see if that has any effect.
    Friday, December 13, 2013 11:13 PM
  • Over the weekend was enough. It's not missing from the newly imaged computer. So once again group policy? Anyone? HELP!
    Tuesday, December 17, 2013 3:06 PM
  • Hi,

    In addition to the assumption of you, I want to confirm whether you see the section before?

    If yes, we can try running system restore.

    Start>type System Restore in the search box>click System Restore>Follow the steps in the wizard to choose a restore point and restore your computer.

    Or run SFC to see whether some system files are missing or corrupted.

    Start>type cmd in the search box>right click cmd and Run as administrator.

    Type the command: SFC /scannow.

    And we can also try to reset windows update components.

    How do I reset Windows Update components?

    http://support.microsoft.com/kb/971058/en-us

    If nothing work, please check whether we can see some updates not listed in Installed updates in update history.

    Hope this helps,


    Ada Liu
    TechNet Community Support


    • Edited by v-Ada Monday, December 23, 2013 9:24 AM
    • Marked as answer by Cloud_TSModerator Monday, December 23, 2013 9:26 AM
    • Unmarked as answer by Wadz Monday, December 30, 2013 3:51 PM
    Tuesday, December 17, 2013 3:29 PM
  • A system restore would not work for almost all of the computers because they have been in service longer than the restore would go back. This will not be an option for us.

    I'll check out the rest and report back.

    Monday, December 30, 2013 4:47 PM
  • Hi Wadz,

    I don't have any answers for you, but I just wanted to chime in and say that this is definitely a problem.  I am seeing the same thing all over the place (the Microsoft Windows section completely missing from View Installed Updates).

    As best I can tell, it only happens to PCs that are built from a sysprepped image.  The installation of a new version of IE (in my case it is the installation of IE10 rather than IE11) seems to trigger the issue on sysprepped machines.

    Being domain joined may also be one of the contributing factors but I am not certain about this.  There are no group policy settings which can hide just this single section so I don't think the issue is caused by GPO, but I can't rule it out.

    This is a big problem and fairly easy to reproduce.  A quick search on the Internet and I can find heaps of people having the same problem.  Almost everyone who posts about this issue gets a stupid reply from someone explaining how to find the "Microsoft Windows" section in the "View Installed Updates" area and completely misses the point that the section is GONE.

    Microsoft - this is a bug, look into it!

    Using System Restore is not a solution either.  The problem will just come back next time IE is upgraded.  In my case, I don't even want to remove the updated IE - I just want the "Microsoft Windows" section back!

    Cheers,
    David

    Monday, December 30, 2013 9:56 PM
  • Thanks David,


    Only happening to Sysprepped images is an interesting idea. We sysprep everything. Something about how images used to cause issues with each other being identical unless you used sysprep. I understand this is better with windows 7 and was only a real issue with xp.


    I have a test computer setup that sits outside of my domain OU and I am slowly linking group policies to it. So far so good. I can still see the microsoft windows section in installed updates. But I do know that when I add the machine to the domain OU it will drop out. I'm not sure if I remove it from the OU if it will go back or not.


    I have another test machine at my disposal. Maybe I'll give your sysprep idea a try too. I can just image the thing, sysprep it and slap it in my domain OU to see if it has the same issue.



    Thanks for sharing!



    • Edited by Wadz Friday, January 31, 2014 8:48 PM
    Friday, January 31, 2014 8:45 PM
  • Has there been any headway on finding a solution to this issue?  I'm having the same problem with a client of mine. Computer suddenly would not update past the KB3024777 update, which itself was to remove update KB3004394.

    I'd love to manually remove the 4394 update so that I could get past the 4777 update stalling any further updates, but, much like the OP of this article, I do not have a "Microsoft Windows" section in my installed updates, it just doesn't exist.  I've tried the suggestions here, but have come up empty handed.

    Anyone found a solution to this yet?

    Monday, February 9, 2015 8:51 PM
  • Has there been any progress on this?  I'm have the same issue with a client and was curious if anything has been discovered since this last post.
    Monday, February 9, 2015 8:56 PM
  • I have/had the same problem. It's a day late and a dollar short, and this is an old post, but I looked all over for the answer to this.  I have Win7 Pro 64-bit and what solved it for me was Microsoft's KB971509.  It won't let me post a link, so you'll have to go look it up.

    I read a second reference somewhere about how that very same fix applies to this "Installed Updates" problem.  Sure enough, one of my Win 7 machines was already set correctly and the Windows Section was viewable.  The other machine (with no Windows Section) was NOT set correctly.  After the change and a reboot, all is good!

    What a PITA!

    • Proposed as answer by Jon Tashman Monday, February 15, 2016 4:32 AM
    Monday, January 11, 2016 8:48 PM