locked
[SOLVED] Can't change the profile for any network adapter (Wired / Wi-Fi) RRS feed

  • Question

  • Hello,

    I just went from Windows 8 Pro to Windows 10 Pro and are having a new learning experience.

    My Wired network was automatically set to public and I have been trying to find how to change it to Private but I simply can't

    The option is missing.

    I followed this guide with perfect step-by-step pictures. But I am missing the option shown in the last step: https://tinkertry.com/how-to-change-windows-10-network-type-from-public-to-private#fix-for-wired-network-connections

    Please see this screenshot of my settings in the same dialogue: https://drive.google.com/open?id=1PPaV7Fj6xtOw6BeUZEj_6Mvezep7tXEC


    Thankful for any W10 professionals trying to help!

    Thank you in advance



    • Edited by Charkel_ Friday, July 20, 2018 5:05 PM Adding solved to title and adding it affected WiFi adapter too
    Sunday, June 24, 2018 6:58 PM

Answers

  • Ok, recreated what you are seeing, Admin rights are needed to change the network profile. I have logged in with a standard user and see the same as you. So from an Admin PowerShell prompt (right click start);

    Get-NetConnectionProfile

    #Note the InterfaceAlias

    Set-NetConnectionProfile -InterfaceAlias Ethernet -NetworkCategory Private

    #Substitute InterfaceAlias you noted for what is in that command.

    Alternativley login with a admin account and make the change.

    • Marked as answer by Charkel_ Friday, July 20, 2018 5:03 PM
    Saturday, June 30, 2018 9:09 PM

All replies

  • What Windows 10 version is this? Type winver in the start search, what is the version and build?
    Sunday, June 24, 2018 7:33 PM
  •   If it is a recent version you should be able to change that from Network Status>Change network properties.


    Bill

    Monday, June 25, 2018 2:15 AM
  • If it is a recent version you should be able to change that from Network Status>Change network properties.


    Bill

    The option simply does not exist in there

    OBS WIRED CONNECTION 

    Winver = Windows 10 (dont say Pro but I have Pro)
    Version
    1803 (OS Build 17134.137)



    • Edited by Charkel_ Saturday, June 30, 2018 12:53 PM
    Saturday, June 30, 2018 12:52 PM
  • What Windows 10 version is this? Type winver in the start search, what is the version and build?
    Winver = Windows 10 (dont say Pro but I have Pro)
    Version 
    1803 (OS Build 17134.137)

    Saturday, June 30, 2018 12:54 PM
  • Ok, recreated what you are seeing, Admin rights are needed to change the network profile. I have logged in with a standard user and see the same as you. So from an Admin PowerShell prompt (right click start);

    Get-NetConnectionProfile

    #Note the InterfaceAlias

    Set-NetConnectionProfile -InterfaceAlias Ethernet -NetworkCategory Private

    #Substitute InterfaceAlias you noted for what is in that command.

    Alternativley login with a admin account and make the change.

    • Marked as answer by Charkel_ Friday, July 20, 2018 5:03 PM
    Saturday, June 30, 2018 9:09 PM
  • Ok, recreated what you are seeing, Admin rights are needed to change the network profile. I have logged in with a standard user and see the same as you. So from an Admin PowerShell prompt (right click start);

    Get-NetConnectionProfile

    #Note the InterfaceAlias

    Set-NetConnectionProfile -InterfaceAlias Ethernet -NetworkCategory Private

    #Substitute InterfaceAlias you noted for what is in that command.

    Alternativley login with a admin account and make the change.

    Oo totally forgot about this thread and just noticed the issue again so I remembered. Thing is also I had to switch to WiFi and got the same issue. I didn't get the question to set priv/pub like I always did on W8

    Thank you so much for taking your time and coming up with a simple solution!

    Ran powershell as admin and followed your steps and now Private. Thank you so very much. I'm keeping this codepiece

    HOWEVER there only exists one account and that is the admin account. So how would I log onto the admin account that you are speaking of? :(

    Yes I'm on ck_ch not Guest, didn't even know I had Guest must be always installed automatically

    Checking the users on the machine

    PS C:\Windows\system32> net user
    User accounts for \\DESKTOP-B7M3DLU
    -----------------------------------------------------
    Administrator            ck_ch                 DefaultAccount
    Guest                    WDAGUtilityAccount
    The command completed successfully.

    And checking the only admin user more detailed

    PS C:\Windows\system32> net user ck_ch
    User name                    ck_ch
    Full Name                    Charlie K
    Comment
    User's comment
    Country/region code          000 (System Default)
    Account active               Yes
    Account expires              Never
    
    Password last set            2018-06-23 19:37:43
    Password expires             Never
    Password changeable          2018-06-23 19:37:43
    Password required            Yes
    User may change password     Yes
    
    Workstations allowed         All
    Logon script
    User profile
    Home directory
    Last logon                   2018-07-19 00:45:17
    
    Logon hours allowed          All
    
    Local Group Memberships      *Administrators       *Users
    Global Group memberships     *None
    The command completed successfully.




    • Edited by Charkel_ Friday, July 20, 2018 5:08 PM
    Friday, July 20, 2018 4:54 PM
  • HOWEVER there only exists one account and that is the admin account. So how would I log onto the admin account that you are speaking of? :( 

    Well you are logging in as an admin then, so no idea why you don't see the network profile settings in Settings...

    Friday, July 20, 2018 7:56 PM
  • I found that the section to change network profile doesn't appear when you have UAC set to the highest level.
    Thursday, January 24, 2019 9:10 AM
  • While I had a slightly different issue which was that I was able to see these options, but I would try to update from Public to Private and the change wouldn't stick. The next time I went back to view the profile it just went straight back to Public.

    I was able to resolve by going into my Anti-Virus' (Avast) Firewall settings and changing to Private there - and I saw that the change finally saved to the Window's network settings as well. So if you use 3rd party firewall software, it's worth checking to see if you can change your network type there.

    I know this is an old thread, but I would have saved a lot of headache if I saw this answer when I pulled this thread up the first time, so I figured I'd share for the next person who stumbles upon here. Surprisingly I was not able to find any other topic that would fix my issue. 


    • Edited by K'Davis Thursday, April 30, 2020 7:08 AM Fixed simple typo
    Thursday, April 30, 2020 7:08 AM