locked
How to replace default.aspx with an amended version? RRS feed

  • Question

  • This should be too hard for you sharepoint buffs! ;)

     

    I have Sharepoint MOSS 2007, and I have made a copy of one of the default.aspx files made some changes to it, and want that inplace of the origional default.aspx file. Can anyone point me in the right direction?

     

    Thanks,

    Sky


    • Edited by Mike Walsh FIN Thursday, April 7, 2011 9:53 AM Title change to better problem description in question form
    Thursday, April 7, 2011 9:49 AM

Answers

  • Please enable the SharePoint Server Publishing by going to Site Action > Site settings > under Site Actions category > click on Manage site features.

    But SharePoint Server Publishing feature won't be activated unless you activate SharePoint Server Publishing Infrastructure from Site Action > Site settings > under Site Collection Administration.

    Hope that helps.


    Mai Omar | Senior Solutions Developer | ITEgyptCorp | MCP, MCTS, MCPD, MCITP & MCT Microsoft Certified Trainer | Email: mai_omar_86@live.com | Blog: http://maiomar.itegyptcorp.com
    • Marked as answer by Fitz_ Thursday, April 7, 2011 12:07 PM
    Thursday, April 7, 2011 11:32 AM

All replies

  • Hi,

    If you have SharePoint Designer installed , open the site in SharePoint Designer and then replace the existing default.aspx page with your modified default.aspx page.

    or 

    If SPD is not installed open the site in windows explorer and replace the existing default.aspx page with your modified default.aspx page.

    hth


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Thursday, April 7, 2011 10:15 AM
  • Thanks for your help.

     

    I don't have SPD installed, and when I try to replace the existing one in windows explorer it comes up with the error:

    "cannot rename default: Cannot read from the source file or disk."

     

    How do I get SharePoint Designer, and do you know how to get round my error msg? I restarted the service, and kicked everyone out of Sharepoint and tried to rename it again but that didn't work either..

    Thursday, April 7, 2011 10:28 AM
  • Hi,

    you can download SPD 2007 from

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=baa3ad86-bfc1-4bd4-9812-d9e710d44f42&displaylang=en

    And the existing default.aspx page is in checked out state ?

     


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Thursday, April 7, 2011 10:39 AM
  • Hi, well i have a solution for you, if it works or satisfy your needs, then it will take from you just seconds...

    You can change your welcome page to be yours and not SharePoint default.aspx page, from go to Site Actions > Site Settings > Under Look & Feel category > click on Welcome Page, just change it to your page which is in pages library for example.

    Thanks.


    Mai Omar | Senior Solutions Developer | ITEgyptCorp | MCP, MCTS, MCPD, MCITP & MCT Microsoft Certified Trainer | Email: mai_omar_86@live.com | Blog: http://maiomar.itegyptcorp.com
    Thursday, April 7, 2011 11:07 AM
  • How do i check out / uncheck out a default.aspx file?

     

    Unfortuantely I need things explained in laymans terms ;)

    Thursday, April 7, 2011 11:09 AM
  • I tried doing what you suggested Mai, but it didn't have the 'Welcome Page' option under Look & Feel..

    I would attach an image, but it doesn't seem that i can.

    Thursday, April 7, 2011 11:24 AM
  • Please enable the SharePoint Server Publishing by going to Site Action > Site settings > under Site Actions category > click on Manage site features.

    But SharePoint Server Publishing feature won't be activated unless you activate SharePoint Server Publishing Infrastructure from Site Action > Site settings > under Site Collection Administration.

    Hope that helps.


    Mai Omar | Senior Solutions Developer | ITEgyptCorp | MCP, MCTS, MCPD, MCITP & MCT Microsoft Certified Trainer | Email: mai_omar_86@live.com | Blog: http://maiomar.itegyptcorp.com
    • Marked as answer by Fitz_ Thursday, April 7, 2011 12:07 PM
    Thursday, April 7, 2011 11:32 AM
  • Mai,

    If I could kiss you.. I would..

    (For anyone else who reads this)

    for Sharepoint Server Publishing I found it under SharePoint Server Publishing Infrastructure from Site Action > Site settings > Site Collection Features > Activate: SharePoint Server Publishing Infrastructure

     

    Then SharePoint Server Publishing by going to Site Action > Site settings > under Site Actions category > click on Site features. and Activate:  SharePoint Server Publishing.

     

    Thanks Mai! 

     

    I have to test that the option works, but I can't do that till tomorrow. I'll leave it as answered and come back if I have any problems.

    Cheers!

     

    Moderator Note:

    Re. "I'll leave it as answered and come back if I have any problems."

    Best practise is to not mark the post as the answer UNTIL you have checked it and had no problems. Marking it as an answer means that it works for you  NOT that it's a good idea that you will try.

    • Edited by Mike Walsh FIN Thursday, April 7, 2011 1:08 PM Moderator Note added
    Thursday, April 7, 2011 12:07 PM
  • Aye aye Mike Walsh FIN, I will just ignore the Unmark as Answer button..

    Anywhoo,  Mai, it did work,

    • Edited by Mike Walsh FIN Friday, April 8, 2011 7:58 AM Other questions go (only) to new threads. Deleted
    Friday, April 8, 2011 7:27 AM