locked
UAG Active Sync Mailtransfer for mobile devices RRS feed

  • Question

  • Hello.

    As we did try to upgrade from IAG to UAG, an issue with the Active Sync Mailtransfer occured. There is no choice to creatte an "Basic Trunk" on the UAG as on the IAG. We decided to create an "Portal Trunk" with Exchange Services "Exchange ActiveSync for 2003". When this was done, the UAG did not automaticaly create the rules for Active Sync. When I did copy them from the IAG (also regular expressions), several issues occur, it did not work as wanted.

    example for an error while doing the sync from Windows Mobile 6.5 (event report UAG):

    A request from source IP address XXX.XXX.XXX.XXX on trunk activesync; Secure=1 for application ActiveSync of type ExchangePub2003SP1 failed. The URL /Microsoft-Server-ActiveSync?User=franz.mach&DeviceId=D7E7B9C572D1793532C44013377A1430&DeviceType=PocketPC contains an illegal path. The rule applied is Default rule. The method is OPTIONS.

    Why does UAG not create the rules (as IAG) and how to create them? Is someone able to give me an advice?

    Thank you in advance!

    Monday, July 12, 2010 9:05 AM

Answers

  • Yes, I checked the  "Publish exchange applications via the portal" checkbox. I found a workaround to solve the problem. In the default configuration UAG don't know the method "Options", which is required for ActiveSync with Exchange 2003. I export the URL rules to an ini-File and add the method "Options" manually. Then I import the file again and a popup asked me to add "options" to methods. Now ActiveSync works fine :-)
    • Marked as answer by Stefan.7 Monday, July 12, 2010 1:22 PM
    Monday, July 12, 2010 1:22 PM

All replies

  • Did you check the "Publish exchange applications via the portal" checkbox when you created the Portal Trunk? - In my case the ActiveSync trunk worked first time, just by following the wizard, although I am using Exchange 2007.

    Perhaps you could temporarily create an Exchange 2007 trunk, just to get TMG rules setup correctly?

    Peter

     

    Monday, July 12, 2010 10:18 AM
  • Yes, I checked the  "Publish exchange applications via the portal" checkbox. I found a workaround to solve the problem. In the default configuration UAG don't know the method "Options", which is required for ActiveSync with Exchange 2003. I export the URL rules to an ini-File and add the method "Options" manually. Then I import the file again and a popup asked me to add "options" to methods. Now ActiveSync works fine :-)
    • Marked as answer by Stefan.7 Monday, July 12, 2010 1:22 PM
    Monday, July 12, 2010 1:22 PM
  • I think this was addressed in 'UAG Update 1' or 'Rollup 1 for Update 1'

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Monday, July 12, 2010 2:09 PM