none
Issues with FIM 2010 UPR1 Oracle Management Agent for 11g RRS feed

  • Question

  •  Hi All,

    Facing challenges getting it to data imported from Oracle DB / View into FIM, typically the Oracle Management Agent hangs for 30-40 minutes and then at times it completes the sync, other times it just returns with Schema Mismatch error.
    Whereas if we run the query via command line tools for 11g it responds with a 1000 records in under 10 seconds.

    Running FIM 2010 UPR1 (4.0.3531.2) on Windows Server 2008 R2

    Oracle 11g client tools 64 bit (Release 11.2.0.1.0) on the same box

     


    Blog Link: http://blogs.cyquent.ae | Follow us on Twitter: @cyquent | ADRMS Wiki Portal: Technet Wiki

    Wednesday, January 18, 2012 6:10 AM

All replies

  • Just to add to the above .. get the following on the connection log

    Status=Failed-connection

    Error= Schema-out-of-date

    Error code= 0x80230823


    Blog Link: http://blogs.cyquent.ae | Follow us on Twitter: @cyquent | ADRMS Wiki Portal: Technet Wiki

    Thursday, January 19, 2012 11:59 AM
  • It looks like you'll need to at least update the Oracle client tools.  See this post for more information.

    Chris

    Thursday, January 19, 2012 6:55 PM
  • Thanks Chris

    Update the client tools to which version??

    Already been thru the post, thats how we arrived here.

    Thanks


    Blog Link: http://blogs.cyquent.ae | Follow us on Twitter: @cyquent | ADRMS Wiki Portal: Technet Wiki

    Friday, January 20, 2012 9:22 PM
  • Ah, sorry about that.  I was looking at the smaller revision release numbers and somehow completely missed the fact that you were on 11.x and not 10.x.

    Based on this post, you might need to set Self-Tuning = False or install 11.2.0.1.2 according to this post on another site linked in that other post.  If a 10g client can talk to an 11g server, it might be interesting to see if downgrading to a 64-bit-compatible 10g client would give you the same results.

    That's really all I've got since I don't have a handy way of trying out this combination myself.  Maybe another forum contributor will chime in.

    Chris


    Friday, January 20, 2012 10:44 PM
  • Thanks Chris,

    No luck with the above suggestions either, no change even after setting the Self tuning parameter.

    Plus we Upgraded the client versions to 11.2.0.1.3 but still the same result.


    Blog Link: http://blogs.cyquent.ae | Follow us on Twitter: @cyquent | ADRMS Wiki Portal: Technet Wiki

    Sunday, January 29, 2012 7:01 AM
  • Adnan,

     

    If this pause is when initializing the Oracle MA during creation or import attempt, this might be known issue. Starting with Oracle client 10g version, it seems as though the instructions sent to client by FIM generate a query that takes a very long time to complete; it seems to be enuerating every object in the DB.

     

    One workaround I have heard about involve creating a table called All_Objects. Create this table with the same column names and types as the actual DB you care about but there shouldn't be any actual data(rows) in it. Verify that the account used by the Oracle MA has access to this table. According to customer I worked with, he stated that what used to take 3hrs now takes seconds.

     

    I have had other customers state that this does't work for them and they used a different workaround, such as replicating data in table or view to SQL and then using SQL MA. This seems to affect both 10g and 11g client versions and I have yet to hear about any configuration changes that fix it.

    Monday, January 30, 2012 5:18 AM
  • Hi All,

    I am facing a similar issue with Oracle MA after trying to run a profile. The error is

    Status=Failed-connection

    no-start-database-schema-mismatch

    Error= Schema-out-of-date

    Error code= 0x80230823

    The query on this view is taking just 90 seconds using a client tool.

    Any help on this would be appreciated.


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.


    • Edited by DPS Bali Wednesday, July 18, 2012 6:11 PM
    Wednesday, July 18, 2012 5:52 PM
  • Hi All,

    Any one got solution for this issue ? I am facing same issue . My environment is win 2012 , FIM 2010 R2 SP1 with latest update, Oracle client 12.1.0 ( initially I tried with 11gR2 but got same issue).

    Only first time I can able to import the data from Oracle view. Then I am not able to import the data. Same error in Full Import.

    Status: Failed connection

    no-start-database-schema-mismatch

    Error:Schema-Out-of-date

    Event Viewer Error:

    Event ID: 6016

    The management agent "Test" failed on run profile "Full Import" because the management agent has detected that the database schema has changed.

    User Action

    Refresh and verify the schema for the management agent.


    Enayathulla.S

    Wednesday, September 24, 2014 10:18 AM