none
Enable External Load Balancing error RRS feed

  • Question

  • Hello,

    I'm trying to create a DirectAccess farm with 2 external Load balancers (Step 3.1.1 http://technet.microsoft.com/en-us/library/jj134166.aspx)

    The first server is configured (Behind a Edge with 2 NICs) and working but when trying to enable External Load Balancing, I immediately receive this error when applying the settings:

    Initializing operations before applying configuration
     Backing up GPOs...
    Updating cluster settings
     Retrieving server GPO details...
     Opening the server GPO...
     Error: The configuration data for this product is corrupt. Contact your support personnel.
    Finishing operations after applying configuration
     Information: Attempting to roll back the configuration...

    The DirectAccess dashboard shows that all services are fine, the DC is available and no errors are logged in the Event Viewer.

    I can't find any explanation about a possible corrupted configuration.


    • Edited by Gérald Mathieu Thursday, June 5, 2014 9:23 AM Hyperlink not working
    Thursday, June 5, 2014 9:00 AM

All replies

  • Ok... Found the problem... You can't mix Internet IP and LAN IP to create the VIP...
    Thursday, June 5, 2014 11:59 AM
  • Gerald,

    Long time back, but im having a very similar problem to this with our new DA environment, but your solution doesnt quite make sense to me, could you elaborate on what you did...

    Aaron

    Saturday, June 11, 2016 10:55 PM
  • Hi,

    It was a long time ago so I can't remember exactly and it was for a test lab in VMware using a virtual BigIP.
    I think the problem appears when Internet and Private IP are used on the External adapter at the same time.

    I don't use the Wizard anymore to configure an external NLB in DirectAccess.
    The PowerShell command seems to work better.

    What problem do you have?

    Sunday, June 12, 2016 10:17 AM
  • Got one DA server up and running fine, not much more than the basic configuration. So went to enable the load balancer, as were planning on having a 4 server LB environment, 

    Setup using the Addresses similar to those below. DA01 works fine, until i run through the LB setup, choose ELB and give it the two new addresses at the bottom of the table.

    Pseudo IP Settings (Each server has two virtual network adapters)

    Server

    CDN IP

    DMZ IP

    DA01

    192.168.0.100

    151.178.0.100

    DA02

    192.168.0.101

    151.178.0.101

    DA03

    192.168.0.102

    151.178.0.102

    DA04

    192.168.0.103

    151.178.0.103

    DA.domain.com

    151.178.1.100 (NATTED) terminated at NetScaler LB

    DA1 Cluster (Provided during LB wizard)

    192.168.0.104

    151.178.0.104

    As soon as i complete the wizard, and restart the Remote access console, i get the following in the console and hitting reload does nothing at all. I can see the GPO has updated on our DC's at the time i completed the wizard, but something its written to it doesn't compute !

    Have not tried any power shell on it yet, but iv rebuilt this twice now trying a few different things, but once it gets to this state, its a case of wiping the reg key controlling the DA setup and starting again... 

    Aaron

    Sunday, June 12, 2016 10:37 AM
  • Ok,

    So it's not the same problem I got. I was not able to finalize the wizard with mine.
    I never saw this error. Sounds like something wrong was detected by the server after applying the new configuration.

    I suppose that 151.178.0.104 should be the DirectAccess entry point for outside clients.
    Is this IP resolvable as your new entry point?

    Gerald

    Monday, June 13, 2016 9:18 AM