Anytime Upgrade from Vista Home Premier to Ultimate Fails because "cannot configure a system component" RRS feed

  • Question

  • If this is the wrong forum for this, please let me know where the correct one is.


    I was running Vista Ultimate on my Dell XPS 710 (Core Dual, 4GB RAM), which was a successful Windows Anytime Upgrade from the factory installed Vista Home Premier.  As part of a XPS upgrade path, Dell offered to swap out my motherboard with a XPS 720 and an Intel Core quad processor.  I accepted the upgrade and a Dell tech came to my home and installed the XPS 720 motherboard and new Intel Quad processor.  The upgrade went well and the system fired up on the first try.  Dell recommended that the OS be wiped and reinstalled, so I did that and reinstalled Vista Home Premium from the factory disk. Again, all went well and Vista sees the quad CPU and the system works great.  I take the next step and do the Windows Anytime Upgrade to get the Vista Home Premier to Vista Ultimate as before and that is where I hit problems.


    During the installation at what I would guess is close to the end of the install I will get a pop up error that says:


    "Windows vista cannot continue the upgrade because it cannot configure a system component. Resolve this issue and reinstall windows vista."


    It then reboots and rolls back to my Vista Home Premier install.  I have tried this install several times and no luck.  Someone recommend I try it will only 1GB of RAM install and I got the same error.  I also have pulled all external equipment off the system except for my USB keyboard, USB mouse, and DVI monitor.  I have contacted Dell, and their response is to get support from Microsoft because the system works with the factory installed Windows Vista.  I am at a loss on what to do next.  I really only need Ultimate because I need to Remote Desktop into other systems, but I am dying without that functionality. 


    Any suggestions on how I can get this upgrade to work correctly?





    Tuesday, September 25, 2007 9:30 PM

All replies

  • Sorry, I cannot help you with this, but I am running into the exact same problem with a brand new HP Pavillion which came with Vista Home Premium preinstalled and upgrading to Ultimate fails exactly in the same way you describe. I hope someone can help us with this.

    Wednesday, September 26, 2007 8:23 PM
  • I was finally able to get Ultimate installed after many many attempts.  Here is what finally worked for me.  I am not sure if this had any impact, but I did change this setting in the BIOS first:  I disabled the multicore CPU.  I really don't think that is what allowed it to install, but it was one of the first steps in the process for a successful install.


    I got it to work by Installing the license and when Vista brought up the choice of update with the latest patches at the end of your install or do it later on your own, I choice do it later on my own.  The next step was when the choice of Upgrade Vista or Install a fresh copy came up, I now chose install a fresh copy.  This wipes out your Windows directory and all your files, but a copy of everthing is put in a folder called Windows.Old.  The system installed correctly this time.


    The only other issue I had was a  2 blue screen right after I brough the system back up and was trying things out.  The system had no updates on it nor did it have a video driver that would go beyond 1024x768. After installed all MS updates for Vista and the latest Nvidia driver, the system has been working like a dream.  No blue screens and everything is working great.


    Installing it this way had another benefit when it came time to restore my user data.  Because Vista make copy of the User folder and puts it in the Windows.Old folder, I was very easy able to copy over my files to the new User folder.  It was quicker and easier than restoring from back up over my network.


    I hope this helps.


    Thursday, September 27, 2007 2:31 AM
  • Ok, I've found some other discussions on the net suggesting the same approach you took should the upgrade fail. It seems that the reason for the upgrade failing is that it lacks some drivers for some built in components. The upgrade differs from a clean install in the sence that a clean install is capable of prompting you for drivers or perhaps even ignoring this an move on, where as the upgrade will simply fail and roll back without prompting for any missing drivers.


    What some people managed to do was to remove hardware such as WLAN, TV card, USB-devices etc. as well as disable all devices in the Bios Setup that are not needed when upgrading. Then run the upgrade, and if it works, then add the hardware back.


    What I now ended up doing was disabling the sound card and the network card in Bios and remove the TV-card as well as the WiFi/WLAN card. In addition to that I disconnected all USB-devices, and replaced the HP wireless USB keyboard & mouse and used a standard PS2 keyboard and mouse.


    Now magically it worked and the upgrde was completed!


    br. míkael

    Thursday, September 27, 2007 5:54 AM
  • Had the same problem here.  My issue turned out to be the following:


    I had a PS2 keyboard plugged in, but no mouse as I was using a usb bluetooth wireless keyboard and mouse.  Both Microsoft products http://www.microsoft.com/hardware/mouseandkeyboard/productdetails.aspx?pid=081


    After install failing twice, I removed the usb wireless dongle, plugged in a normal PS2 mouse, and viola!  Upgrade complete!  I find it fairly ironic, given the wireless keyboard and mouse are "vista compatible" Microsoft products.  Go figure...

    Saturday, October 6, 2007 10:53 AM
  • I had the same problem upgrading from Vista Home Premier to Vista Ultimate (HP Pavilion a6130n).  I tried removing Norton Internet Security, and then the Vista Upgrade Advisor would run, but the installation still failed.  Then I tried kicking my husband and children off the XBox 360 and the network (which did NOT go over well), and the installation burned down, fell over, then sank into the swamp.  


    Then I checked the setupact.log file and found the "CMI    Callback_CBS_Do_OnlineInstall:Calling startup processing failed " line.  So, I tried the install/upgrade again, but this time when it asked if I wanted to go online to get the latest updates, I elected to just install from the disk.  In fact, I disconnected the PC entirely from the network/internet.  I also deleted my HP OfficeJet G85 printer definition, unplugged my Maxtor USB drive, and exited Messenger, and this time the castle stood.  The upgrade took about 3 hours to complete, but at least it was finally successful.


    Monday, October 8, 2007 7:02 PM
  • I just went through this upgrade on a new HP Pavillion. It came with Vista Home Premium and needed to be upgraded to ultimate for connecting to the domain.  Tried severl times to do upgrade with no success similar to previous posts. The one variable that seems to be constant with getting this to work is not letting windows try to do the updates during the install.  I followed the previous posters method of removing the network connection just to be sure and was able to get the upgrade to work.

    Thursday, October 11, 2007 10:14 PM

  • I am in the process of upgrading from windows vista home premium to ultimate and I am getting the same error.
    I have a gateway GT5628 which came with vista pre installed.  I have tried 3 times and keep getting the same damn error and then it rolls back the install (thank god that at least works!)

    For this attempt I tried pulling all usb devices, network cables, and changed to ps2 mouse and keyboard.  I'll keep my fingers crossed.  Next it will be disabling everything i can in the BIOS.  Its insane that you have to go through this *** when vista premium works just fine.
    Saturday, November 3, 2007 5:30 PM
  • I had this problem, too. Thanks to all the suggestions, I was able to solve it. I first unplugged a bluetooth doggle but that didn't solve it. Then I decided to do the upgrade again with the network cable unplugged; I entered my product key, but left unchecked the box that says "Activate Windows when I'm online." Don't know if that last bit made a difference or not. I was able to upgrade without a hitch, then plugged my network cable in again and clicked "Active Windows now." All is well.
    Tuesday, December 15, 2009 4:23 AM