locked
An error occured when validating interfaces RRS feed

  • Question

  • Hello,

    I am setting up an DA Server with two Network interfaces. They are already configured with static IPv4 Adresses.

    I am going in the Remote Access Management Console > DirectAccess and VPN > Step 2 "Edit" > Network Adapters

    Its equal if an adapter is selected or not it tells me every time this error: An error occured when validating interfaces

    Technet says in the "Step 1: Configure the DirectAccess Infrastructure" Tutorial: Ensure that the second network adapter and any additional network adapters are classified in the domain profile.

    What does that mean? What do i have to do?

    I would be very thankful if someone could help me.



    Tuesday, May 31, 2016 3:21 PM

Answers

  • This might be WinRM conflict

    Ensure the WinRM group policy is not running on this server

    To confirm this run Power Shell elevated "winrm enumerate winrm/config/listener"

    You need to ensure the WinRM group policy is set to Not Configured. The GP setting you need to check is "Allow remote server Management through WinRM to Not Configured"

    Sunday, March 5, 2017 3:06 PM

All replies

  • Hi,

    This is the Windows Firewall profile. Your server must be joined to your domain and the Internal NIC is using the Domain profile if it can access your domain through it.
    In a 2 NIC setup, you have the external adapter, facing Internet and the Internal adapter, facing your internal network.

    The internal adapter configuration needs to be able to access your Active Directory.
    You need to configure it with a static IPv4 address without entering a default gateway and configure your  internal DNS on this card.
    Then you need to configure a static route (with netsh) to forward the traffic to your domain.

    Gerald


    Thursday, June 2, 2016 2:50 PM
  • Hello Gerald,

    thanks for replying me.

    I think i did the Network setup correctly: The Network sharing Center says on the internal interface "Domain network" and on the outgoing interface "Private Network"

    A static route to the internal network and the default gateway only on the external interface is configured and working.

    IPv6 is enabled but not configured.

    Interesting is that if I use the Remote Access Setup Wizard it displays me the error: An error occured when validating interfaces

    And if I use the Getting startet Wizard: Network adapter settings cannot be located for the public name or IP address used by remote clients to connect to the Remote Access server. Verify address settings.

    I have no idea what's cousing this error.


    • Edited by LiyAp Thursday, June 2, 2016 4:05 PM
    Thursday, June 2, 2016 4:05 PM
  • The setup is not able to resolve the public (Internet) DNS name your clients needs to use to contact the Direct Access server when they are traveling.

    Have you published the name on your public DNS server?

    Friday, June 3, 2016 8:15 AM
  • did you ever get this resolved, i have exactly the same issue

    thank you

    Tuesday, February 28, 2017 10:22 PM
  • This might be WinRM conflict

    Ensure the WinRM group policy is not running on this server

    To confirm this run Power Shell elevated "winrm enumerate winrm/config/listener"

    You need to ensure the WinRM group policy is set to Not Configured. The GP setting you need to check is "Allow remote server Management through WinRM to Not Configured"

    Sunday, March 5, 2017 3:06 PM