none
New Microsoft Excel Worksheet.xlsx is locked for editing by "username". Click "Notify" to open a read-only copy of the document and receive notification when the document is no longer in use. RRS feed

  • Question

  • Hi,

    In SharePoint 2013 Library, I open the file in explorer from SharePoint document library ribbion. In explorer I right click and created the excel file. After creating the file in explorer once I open the file to enter the record Its shows below message :-

    Checked Out Required to modified the server work book

    when I click on Check Out button then its shows below message

    New Microsoft Excel Worksheet.xlsx is locked for editing by "username".
    Click "Notify" to open a read-only copy of the document and receive notification when the document is no longer in use.

    I just created the new file in explorer and its not open or use by anyone then why its showing second above message New Microsoft Excel Worksheet locked.

    Please advice.

    Thursday, July 4, 2019 11:16 AM

All replies

  • Hi,

    Please try to publish a major version of the document from SharePoint UI in browser. Then try to edit again. You can also check "library settings -> manage files which have no checked in version". If your document is listed here please checkout and checkedin again.

    Thursday, July 4, 2019 1:56 PM
  • Hi,

    I would like to confirm a few things with you:

    1. Does this issue happen when to only Excel files or also to other types of files, e.g. Word?

    2. Does this issue happen when you modify an existing file in the document library?

    3. What permission do you have in this document library?

    Please check as following for basic troubleshooting:

    1. Upload this new Excel file to the document library and check out the file. Open it with Excel client application and see if the same issue will occur.

    2. Open the document library with File Explorer and check "Hidden items" in the View tab. Open the Excel file and check if there is any temporary file in the File Explorer named as "~$<filename>" which corresponds to the file you are editing. If there is, delete the temporary file and edit the Excel file again.

    3. Go to Library Settings > "Manage files which have no checked in version" under Permissions and Management and check if the file is listed under this location.

    Here’s a link of similar issue for your reference.

    Tutorial to Fix “Microsoft Excel File is Locked for Editing/in Use” Issue.

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, July 5, 2019 7:30 AM
  • Please find my comment below :-

    1. Does this issue happen when to only Excel files or also to other types of files, e.g. Word? - This issue is with only Excel. 

    2. Does this issue happen when you modify an existing file in the document library? - No, First time when user create Excel File in Document Library Explorer and Try to add the record while open the new created excel file its shows the file is already checked out. But once he close the excel and checked in the file from document library then again open the excel file to add or edit the record he's not getting this issue. But he don't want to repeat this for new excel file. 

    His question is why always while creating the new excel file in Open with explorer he's getting File is already checked out error. He don't want to go in SharePoint Library to do checkedin every-time for new file and close and reopen same file again to add the record. Please advice.

    3. What permission do you have in this document library? He have contribute permission.

    Sunday, July 7, 2019 8:48 AM
  • Hi,

    Please follow these steps to narrow down your issue:

    1. Select "No" for "Require Check Out" via Library Settings > Versioning settings and see the result.

    2. Select "Automatic logon with current username and password" via IE (32-bit) > Internet Options > Security > Custom Level > User Authentication and then click OK. Test again to see the result.

    3. Create a new library and see if the same issue will occur.

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, July 8, 2019 8:39 AM
  • Hi,

    Is there any progress on this issue? 

    If you find any replies helpful to you, please remember to mark them as answers. If you have solved the problem yourself, you can reply the solution and mark it as the answer. 

    It will help others who meet the similar question in this forum. 

    Thank you for your understanding.

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, July 11, 2019 9:02 AM
  • Dear Chelsea,

    I'm checking with user and update you. Thanks for your support.

    Sunday, July 21, 2019 11:18 AM
  • Hi Chelsea,

    Your provided solution is not working.

    1. Select "No" for "Require Check Out" via Library Settings > Versioning settings and see the result. - This option is not valid, we cannot disable check out.

    2. Select "Automatic logon with current username and password" via IE (32-bit) > Internet Options > Security > Custom Level > User Authentication and then click OK. Test again to see the result. --Its already enabled.

    3. Create a new library and see if the same issue will occur. - Created still user getting the same issue.

    Thanks

    Monday, July 22, 2019 10:04 AM
  • Hi,

    Based on your test results, this is most likely an Excel related issue.

    What version of Excel are you using? We recommend Office 2013 or upper version to integrate with SharePoint 2013.

    You can also perform a Repairing procedure to Office in the Programs and Features and see the result. 
    Here's your reference.

    Repair an Office application.

    https://support.office.com/en-us/article/repair-an-office-application-7821d4b6-7c1d-4205-aa0e-a6b40c5bb88b

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, July 23, 2019 7:37 AM
  • Hi Chelsea,

    User who is facing this issue have office 2016 and issue is only with Excel 2016 with SharePoint 2013 while creating the file in SharePoint Document Library File Explorer. After creating the excel file in explorer once I open the file to enter the record Its shows below message. However in Development environment its I'm able to add excel file using Open With Explorer and Edit the file there after creating the file this message will not come.

    Checked Out Required to modified the server work book

    Please advice.

    Thanks


    • Edited by SP2013Devp Tuesday, August 20, 2019 10:05 AM change
    Tuesday, August 20, 2019 5:49 AM