none
Power Query Installation Issues

    Question

  • System Information: Excel 2013 ProPlus (O365) 64-bit running on 64-bit Windows 8.1 Pro.

    I installed PowerQuery_2.8.3443.101 (64-bit) [en-US].msi, which was working fine until I had to uninstall Office due to an unrelated issue.  Upon reinstalling Office ProPlus, it has not been possible to activate the PowerQuery add-in.

    Even after running the installation wizard or selecting the .com add-in it has not been possible to get PowerQuery working.

     https://www.dropbox.com/s/m62umb8lldcjltn/Screenshot%202013-10-26%2023.52.03.png

    I would be grateful for any help

    Saturday, October 26, 2013 3:58 PM

Answers

All replies

  • Hi, This is a known issue where the add-in get disabled through Microsoft Office, we have a fix in the works. In the meantime you can use the following workaround to re enable to addin 1. Close all instances of Excel. 2. Click Start, and then type: Run 3. Type: Regedit 4. If you’re running 32-bit Office on 64-bit Windows, do the following: Navigate to HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel and change the value of LoadBehavior to 3. Navigate to HKEYCURRENT_USER\Software\Wow6432Node\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel. If the registry key exists, change the value of LoadBehavior to 3. 5. If you’re running 32-bit Office on 32-bit Windows or 64-bit Office on 64-bit Windows, do the following: Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel and change the value of LoadBehavior to 3. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel . If the registry key exists, change the value of LoadBehavior to 3. 6. Start Excel and enable Power Query by clicking File > Options > Add-Ins. In the Manage box, pick COM Add-Ins and click Go. Let us know if this helps. Thanks

    Zafar Abbas

    Sunday, October 27, 2013 5:27 AM
  • I followed the instructions outlined below and changed the value of HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel from 2 to 3.  After restarting Excel and picking the COM add in manually, I noted the following message on the load in behavior.   

    https://www.dropbox.com/s/gza1bns65jorbwf/Screenshot%202013-10-27%2011.11.18.png

    Due to the error loading the add-in, the registry entry is reverting from 3 back to 2.  When starting Excel for the first time after changing the registry entry, a small black pop-up window appears and disappears.  I assume it is the error message for failing to load PowerQuery.

    I have tried the workaround individually with

    1. PowerQuery_1.5.3296.2082 (64-bit).msi
    2. PowerQuery_2.8.3443.101 (64-bit) [en-US].msi without success.

    Recent changes I made to my computer that potentially caused the PowerQuery add-in to fail to load was a fresh install of Office 365 ProPlus and upgrading to Windows 8.1.

    Please let me know if I could provide you with any other information to diagnose this issue.

    Sunday, October 27, 2013 5:30 AM
  • Hi Ryan,

    Have you tried uninstalling Power Query, and then reinstalling it?

    Regards,
    Anita Oakley

    Tuesday, October 29, 2013 10:02 PM
  • Yes I have tried uninstalling/reinstalling.  I'm getting help directly from the PowerQuery team.  I'll post back with results when the issue is resolved. 
    Wednesday, October 30, 2013 3:14 AM
  • Did you get this resolved?  I am having the same issue.
    Monday, November 25, 2013 7:11 PM
  • I had to reinstall a fresh copy of Windows 8.1 and Office in order for the issue to be resolved.
    Tuesday, November 26, 2013 2:42 AM
  • Thank you
    Tuesday, November 26, 2013 7:02 PM
  • I have the same problem.  I am running Windows 8.1, Office 2013 Pro Plus and the latest version of the PowerQuery add-in.  I have tried the following to date:

    Repair/re-install Windows 8.1

    Repair/uninstall/re-install Office 2013 Pro Plus

    Repair/uninstall/re-install PowerQuery add-in

    With no success.

    Each time I activate the add-in, it reverts to an inactive application add-in.  I have also tried the registry edits.  

    If this is know issue what is causing it? When will the fix be released?  

    Any additional information would be helpful.


    Monday, December 23, 2013 10:46 PM
  • I am running 64 Bit 8.1 and 32 Office 2013 Pro Plus and am having the same issue.  Any additional information would be helpful.

    jb

    Monday, January 06, 2014 9:08 PM
  • same issue here.

    any solution?

    Thursday, January 09, 2014 7:29 PM
  • The addin might be disabled in the C2R settings in HKLM which can override the HKCU settings. If you find this registry key below, please update the value of LoadBehavior  to 3.

    32-bit Office on 64-bit OS:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0\ClickToRun\REGISTRY\MACHINE\Software\Wow6432Node\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel

    LoadBehavior = 1

    Office and OS arch aligned:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0\ClickToRun\REGISTRY\MACHINE\Software\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel

    LoadBehavior = 1


    Zafar Abbas

    Tuesday, April 08, 2014 1:25 AM
  • It looks like I have the same issue. I've got a new computer running Win 8.1 64-bit. I installed Office 365 64-bit. Then I installed Power Query.  It didn't show up in the menu.  Under "Add-ins" I see "Microsoft power query for excel" listed as an "Inactive Application Add-ins"
    Tuesday, April 29, 2014 3:56 AM
  • Any updates to this issue. My loadbehavior was already set to 3 in the registry. I am running 8.1 64-bit 2013 office. Excel version is 15.0.4569.1504 and installed the latest version of PowerQuery. So far I have tried everything listed in this post, including an uninstall/reinstall of office.
    Thursday, May 08, 2014 5:38 PM
  • Did you install Excel using Click-to-Run? If so, does deleting the Microsoft.Mashup.Client.Excel key mentioned in Zafar's post solve your issue?

    Thanks.

    -Alejandro

    Wednesday, May 14, 2014 10:00 PM
  • Me too on a Windows Pr0 7.0 32-bit laptop with Office Pro 2013 32-bit.  I have tried every solution on this thread nothing works.

    My only other thought is to have our Service Desk reimage my machine and do a fresh install of everything.

    Wednesday, May 14, 2014 10:26 PM
  • I have install the last version of Power Query 32 bits for Office 2010 (32 bits) on 4 identicals TS servers and the add-in can't be loaded on 3 servers...

    I have uninstal/install 10 times and it's always the same problem.

    So how to resolve this problem? It's maybe a conflict with another add-in we use ?

    Thanks for your help.

    Thursday, July 10, 2014 2:27 PM
  • Yes I have tried uninstalling/reinstalling.  I'm getting help directly from the PowerQuery team.  I'll post back with results when the issue is resolved. 

    Could you share the fix or solution you have receive from the "PowerQuery team" ?

    Thanks.

    • Proposed as answer by Telecom_Nerd Friday, July 18, 2014 3:47 PM
    Friday, July 11, 2014 6:58 AM
  • I had to do the same thing.
    Friday, July 18, 2014 4:02 PM
  • I had to have my PC reimaged then it installed correctly.
    • Marked as answer by RyanR996 Friday, July 18, 2014 4:06 PM
    Friday, July 18, 2014 4:03 PM
  • No need to re-image!!

    Go to File, Options, Addins

    Check if you have disabled add-ins.

    If you have then use the dropdown Manage options to select disabled items.

    Select Power Query in the Disabled box that comes up and enable it.

    From the text shown in this box Excel had disabled Power Query to protect itself at some point.

    Presumably as I had removed and re-installed it beforehand any problems I had had probably been ironed out. 

    Re-starting Excel then brought up Power Query. FINALLY!!! Hope this helps.

    • Proposed as answer by ceceo Monday, July 06, 2015 7:00 AM
    Tuesday, August 26, 2014 10:22 AM
  • In 5 step, HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel,

    I don't have Microsoft.Mashup.Client.Excel in addins.

    Friday, August 29, 2014 9:30 PM
  • it worked. Thank you!
    Tuesday, September 02, 2014 8:04 AM
  • It's true, I had to go down to the "Disabled" drop down instead of COM Add-ins to enable Power Query again. Then I had to go back to COM Add-In to check the box and hit okay. The Power Query tab showed up again. 

    Thank goodness, no re-imaging needed. Thanks. 

    Monday, July 06, 2015 6:59 AM
  • Brilliant! This is the one that worked for me. Thanks!!!!
    Wednesday, August 12, 2015 4:44 PM
  • Thanks, Carl! This worked for me!
    Tuesday, October 06, 2015 1:17 AM
  • No need to re-image!!

    Go to File, Options, Addins

    Check if you have disabled add-ins.

    If you have then use the dropdown Manage options to select disabled items.

    Select Power Query in the Disabled box that comes up and enable it.

    From the text shown in this box Excel had disabled Power Query to protect itself at some point.

    Presumably as I had removed and re-installed it beforehand any problems I had had probably been ironed out. 

    Re-starting Excel then brought up Power Query. FINALLY!!! Hope this helps.

    I tried everything above and the only thing that worked was your fix!  Thank you!  Thank you!
    • Proposed as answer by fredmart3 Thursday, February 11, 2016 5:39 PM
    Thursday, February 11, 2016 5:38 PM
  • It WORKED! Thanks, this was driving me nuts. Note: I had to close Excel and reopen Excel after Re-enabling the add-in to use.
    Tuesday, May 10, 2016 2:40 PM
  • This did the trick. So simple and took so long. Thank you.
    Thursday, June 15, 2017 4:51 PM
  • Thank you millions, The 'disabled' list was the problem to get the add in to load.

    When the message is only 'not loaded' with no further error, the disabled items should be checked first.

    Works again.

    Friday, September 01, 2017 7:56 AM