locked
Only Administrators Can View Drillthrough Via Show Details RRS feed

  • Question

  • I have been struggling with this problem all morning and can't figure out what's happening.

     

    When a user attempts to right-click on a grid value and select Show Details, another window appears, but with an error. A warning is generated in the Application event log on the server:

     

    Source: PerformancePoint Monitoring Server

    Event ID: 11

    Description: A user with insufficient permissions has attempted to perform a system action.

    User ID: 'MYDOMAIN\Username'. Action: Access 'Sales Team Sales by Period (Chart)' Report.

     

    In addition, an ASP.NET unhandled exception warning appears in the Application event log.

     

    Exception Message: You do not have permission to see this report. ({0})

    Start of Stack Trace: Microsoft.PerformancePoint.Scorecards.Server.PmServer.VerifyAnalyticReportReaderRights(ReportView reportView, String message)

     

    I've taken a look at the code in this method and it appears it's checking the permissions on the report itself, checking to see if the user is an administrator, and if the user has either Editor or Reader rights to the report. I.e., this doesn't appear to be related to Analysis Services security.

     

    If I add the user to the Admnistrators group on the server holding the PerformancePoint Monitoring Server, which is a separate server from the Analysis Services server, it works fine.

     

    I have assigned NT AUTHORITY\Authenticated Users as a Reader to all of the dashboard reports. I also tried assigning the specific user in question as a reader.

     

    Does anyone have any ideas of what I'm missing here? It's obviously a permissions issue, but I can't figure out where to configure the appropriate permissions.

     

    Thanks!

    Dave

     

     

    Monday, June 2, 2008 5:28 PM

All replies

  • Verify that the application pool user identity has permissions to drillthrough on the SSAS cube. If you are viewing from MOSS/WSS you need to check the MOSS/WSS app pool user id, if viewing from preview, check the preview app pool user identity.

     

     

    Monday, June 2, 2008 6:42 PM
  • Hi, Alyson. Thanks for your reply.

     

    I didn't mention that I did verify that the AppPool user is configured as a member of a role in SSAS. That user is configured as part of a role to which Administrator access has been granted (in the SSAS role.)

     

    That AppPool user is also an administrator on the server running both Sharepoint as well as PerformancePoint Monitoring Server.

     

    I suspect this is NOT a SSAS permissions issue, since adding the user who was trying to access the dashboard to the Administrators group on the box running PP Monitoring Server, and NOT on the box running SSAS.

     

    Thanks,

    Dave

     

    Monday, June 2, 2008 8:33 PM
  • Yikes, I have no idea - so sorry.  You have tried everything I know.

     

    Monday, June 2, 2008 9:05 PM