none
Hyper-V 2016 - Unable to add NIC to new team - Incorrect parameter

    Question

  • Hi,

    I've inherited a Hyper-V 2016 server that has two NICs installed.  One NIC is bound to a virtual switch which is also used for the management traffic thus has a static IP address assigned to it. The second NIC isn't used.

    I wanted to create a new NIC team and bundle the NICs together.  I've created the team with the spare NIC which has created properly, I am now trying to add the second NIC to the team.  However when I try and apply the changes to the team I get an error at the top of the windows saying "The parameter is incorrect".  No information to say which parameter is incorrect which is slowing down finding a resolution.

    I suspect the issue is that the management traffic is using this NIC, however because it's server core I am using this IP to manage the server so I can't remove it (I am doing the admin remotely). 

    Is this normal behaviour? or am I hitting another issue?

    Cheers

    Rob

    Wednesday, April 12, 2017 12:50 PM

Answers

  • You cannot create a team with a NIC if that NIC is already assigned to a virtual switch.  Remove the virtual switch, create the team, then create team NICs on the NIC team (I dislike the terminology).  On one team NIC re-create your virtual switch and use another team NIC for other traffic, such as Host management.

    tim

    • Marked as answer by RobC_UK Wednesday, April 12, 2017 8:29 PM
    Wednesday, April 12, 2017 1:10 PM

All replies

  • You cannot create a team with a NIC if that NIC is already assigned to a virtual switch.  Remove the virtual switch, create the team, then create team NICs on the NIC team (I dislike the terminology).  On one team NIC re-create your virtual switch and use another team NIC for other traffic, such as Host management.

    tim

    • Marked as answer by RobC_UK Wednesday, April 12, 2017 8:29 PM
    Wednesday, April 12, 2017 1:10 PM
  • Thanks for the reply, makes perfect sense.
    Wednesday, April 12, 2017 8:29 PM