locked
The B2B upgrader timer job failed RRS feed

  • Question

  • I recently tried applying the December cummulative patch on WSS 3.0SP1.  And I have ran into some problems.  The sharepoint configuration wizard keeps failing at step 8 of 9 and I get the following problem in the resulting log:

    Begin trace logging for SharePoint Products and Technologies Configuration Wizard.  Version 12.0.6300.5000
    03/06/2009 04:33:29  1  INF  Entering function PsconfigUserInterfaceMain.Main
    03/06/2009 04:33:29  1  INF    Entering function Common.SetCurrentThreadCultureToInstalledCulture
    ....
    03/06/2009 04:38:31  9  INF        Starting Service SPTimerServiceInstance
    03/06/2009 04:38:31  9  INF        Leaving function UpgradeTask.StartAllServices
    03/06/2009 04:38:54  1  INF        Not running in high contrast, so we will paint the background with our trademarked image
    03/06/2009 04:38:54  1  INF        Not running in high contrast, so we will paint the background with our trademarked image
    ....
    03/06/2009 04:42:42  9  ERR                    The B2B upgrader timer job failed.
    03/06/2009 04:42:42  9  INF                    Entering function StringResourceManager.GetResourceString
    03/06/2009 04:42:42  9  INF                      Resource id to be retrieved is UpgradeTaskFailConfigSyncDisplayLabel for language English (United States)
    03/06/2009 04:42:42  9  INF                      Resource retrieved id UpgradeTaskFailConfigSyncDisplayLabel is Failed to upgrade SharePoint Products and Technologies.
    03/06/2009 04:42:42  9  INF                    Leaving function StringResourceManager.GetResourceString
    03/06/2009 04:42:42  9  INF                    Entering function Common.BuildExceptionMessage
    03/06/2009 04:42:42  9  INF                      Entering function StringResourceManager.GetResourceString



    The update log shows the following error:

    .....
    [SPManager] [DEBUG] [3/6/2009 3:10:25 AM]: [Microsoft.SharePoint.Administration.SPIisWebSite] Running 3 of 9 steps
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: Begin Initialize()
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: End Initialize()
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: Begin Upgrade()
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: Application Web Config for this IIS site (2141706545) is found at C:\Inetpub\wwwroot\wss\VirtualDirectories\16064\web.config.
    [EnsureWebConfigSettings] [3.0.5.0] [WARNING] [3/6/2009 3:10:25 AM]: Failed to create <securityPolicy> web.config element.
    [EnsureWebConfigSettings] [3.0.5.0] [WARNING] [3/6/2009 3:10:25 AM]: Failed to create <trust> web.config element.
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: Application Resource Web Config for this IIS site (2141706545) is found at C:\Inetpub\wwwroot\wss\VirtualDirectories\16064\wpresources\web.config.
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: End Upgrade()
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: Begin Commit()
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: End Commit()
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: Begin Dispose()
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: End Dispose()
    [EnsureWebConfigSettings] [3.0.5.0] [DEBUG] [3/6/2009 3:10:25 AM]: Elapsed time: 00:00:00.2187500.
    [SPManager] [DEBUG] [3/6/2009 3:10:25 AM]: [Microsoft.SharePoint.Administration.SPIisWebSite] Running 4 of 9 steps
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/6/2009 3:10:25 AM]: Begin Initialize()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/6/2009 3:10:25 AM]: End Initialize()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/6/2009 3:10:25 AM]: Begin Upgrade()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/6/2009 3:10:25 AM]: Application Web Config for this IIS site (2141706545) is found at C:\Inetpub\wwwroot\wss\VirtualDirectories\16064\web.config.
    [SPIisWebSiteWssSequence] [ERROR] [3/6/2009 3:10:25 AM]: Action 3.0.9.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
    [SPIisWebSiteWssSequence] [ERROR] [3/6/2009 3:10:25 AM]: Object reference not set to an instance of an object.
    [SPIisWebSiteWssSequence] [ERROR] [3/6/2009 3:10:25 AM]:    at Microsoft.SharePoint.Upgrade.AddSiteMapToWebConfig.EnsureProvider(XmlNode nodeProviders, String strName, String strType, String strSitemapFile)
       at Microsoft.SharePoint.Upgrade.AddNavigationProviderToWebConfig.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/6/2009 3:10:25 AM]: Begin Rollback()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/6/2009 3:10:25 AM]: End Rollback()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/6/2009 3:10:25 AM]: Begin Dispose()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/6/2009 3:10:25 AM]: End Dispose()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/6/2009 3:10:25 AM]: Elapsed time: 00:00:00.0156250.
    [SPManager] [ERROR] [3/6/2009 3:10:25 AM]: Upgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed.
    [SPManager] [ERROR] [3/6/2009 3:10:25 AM]: Object reference not set to an instance of an object.
    [SPManager] [ERROR] [3/6/2009 3:10:25 AM]:    at Microsoft.SharePoint.Upgrade.AddSiteMapToWebConfig.EnsureProvider(XmlNode nodeProviders, String strName, String strType, String strSitemapFile)
       at Microsoft.SharePoint.Upgrade.AddNavigationProviderToWebConfig.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()

    ....


    I will really appreciate if any one can tell me how to resolve this problem.. I haven't been able to find any solution to this problem in regular forms and/or any place else.

    Thanks in advance

    Friday, March 6, 2009 5:06 AM

Answers

  • Hi,

    The problem is in your web.config file and if I read the error messages correctly it get's an Object rference not set to an instance of an object error when it tries to add (and presumably locate) a certain element in the web.config file. Have you got other environments that you CAN upgrade? I think it would be worth a shot to compare the web.config  C:\Inetpub\wwwroot\wss\VirtualDirectories\16064\web.config to another one that doesn't cause problems. Maybe you can even compare the web.config that generates the error with another one of another web application in the same environment.
    I deleted a web.config file from the wpresources folder and that caused my upgrade to fail, when I restored it I didn't have any problems anymore, so changed web.configs can definitely break your SP2 upgrade.

    Hope this helps...


    Mirjam --http://www.sharepointblogs.com/mirjam
    Thursday, May 7, 2009 11:40 AM

All replies

  •  

    Hello,

     

    Please go to \Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN and try to run the following command to complete your configuration upgrade:

     

    psconfig -cmd upgrade -inplace b2b -force -wait

     

    If the problem still persist, please feel free to let me know.

     

    Regards,

    Jerry


    Xing-Bing Yu
    Thursday, March 12, 2009 7:09 AM
  • Jerry thanks for the reply, unfortunately that didn't solve my problem.  After running psconfig as you mentioned, it failed at task 3 of 4 and gave following mesages:

    Performing configuration task 3 of 4
    Upgrading SharePoint Products and Technologies...

    Total number of configuration settings run: 3
    Total number of successful configuration settings: 2
    Total number of unsuccessful configuration settings: 1

    The resulting log contains:


    [SearchDatabaseSequence] [DEBUG] [3/19/2009 8:07:36 PM]: Search SharedDatabaseSequence returns BuildVersion 12.0.6237.1000
    [SearchDatabaseSequence] [DEBUG] [3/19/2009 8:07:36 PM]: Search SharedDatabaseSequence returns BuildVersion 12.0.6237.1000
    [SearchDatabaseSequence] [DEBUG] [3/19/2009 8:07:36 PM]: Search SharedDatabaseSequence returns TargetBuildVersion 12.0.6237.1000
    ...
    03/19/2009 20:07:29  9  INF            Leaving function TaskCommon.TraceToPsconfigLogAndUpgradeManagerLog
    03/19/2009 20:08:02  9  ERR            Task upgrade has failed with an unknown exception
    03/19/2009 20:08:02  9  ERR            Exception: Microsoft.SharePoint.Upgrade.SPUpgradeException: Upgrade completed with errors.  Review the upgrade.log file located in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Logs\Upgrade.log.  The number of errors and warnings is listed at the end of the upgrade log file.
       at Microsoft.SharePoint.Upgrade.SPManager.RunUpgradeSession(IUpgradable root, Boolean bRecursive)
       at Microsoft.SharePoint.PostSetupConfiguration.UpgradeTask.Run()
       at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()
    03/19/2009 20:08:02  9  INF            Entering function Common.BuildExceptionMessage
    03/19/2009 20:08:02  9  INF              Entering function StringResourceManager.GetResourceString
    03/19/2009 20:08:02  9  INF                Resource id to be retrieved is ExceptionInfo for language English (United States)
    03/19/2009 20:08:02  9  INF                Resource retrieved id ExceptionInfo is An exception of type {0} was thrown.  Additional exception information: {1}
    ...
    03/19/2009 20:08:02  9  INF            Leaving function Common.BuildExceptionInformation
    03/19/2009 20:08:02  9  ERR            An exception of type Microsoft.SharePoint.Upgrade.SPUpgradeException was thrown.  Additional exception information: Upgrade completed with errors.  Review the upgrade.log file located in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Logs\Upgrade.log.  The number of errors and warnings is listed at the end of the upgrade log file.
    Microsoft.SharePoint.Upgrade.SPUpgradeException: Upgrade completed with errors.  Review the upgrade.log file located in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Logs\Upgrade.log.  The number of errors and warnings is listed at the end of the upgrade log file.
       at Microsoft.SharePoint.Upgrade.SPManager.RunUpgradeSession(IUpgradable root, Boolean bRecursive)
       at Microsoft.SharePoint.PostSetupConfiguration.UpgradeTask.Run()
       at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

    ...
    03/19/2009 20:08:02  9  INF            Entering function Common.BuildExceptionInformation
    03/19/2009 20:08:02  9  INF              Entering function Common.BuildExceptionMessage
    03/19/2009 20:08:02  1  INF            Leaving function TaskDriver.FireOnTaskDriverEvent
    03/19/2009 20:08:02  1  INF          Leaving function TaskDriver.OnTaskDriverStop
    03/19/2009 20:08:02  1  INF        Leaving function TaskDriver.Stop
    03/19/2009 20:08:02  1  INF        UnLocking the task driver for exclusive use while we ran tasks
    03/19/2009 20:08:02  1  INF      Leaving function TaskDriver.Run
    03/19/2009 20:08:02  1  ERR      Post setup configuration was not run successfully when using the command line task driver module
    03/19/2009 20:08:02  1  INF    Leaving function PsconfigCommandLineMain.Main

    The upgrade log is following:

    ...

    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/19/2009 8:08:01 PM]: Application Web Config for this IIS site (2141706545) is found at C:\Inetpub\wwwroot\wss\VirtualDirectories\16064\web.config.
    [SPIisWebSiteWssSequence] [ERROR] [3/19/2009 8:08:01 PM]: Action 3.0.9.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
    [SPIisWebSiteWssSequence] [ERROR] [3/19/2009 8:08:01 PM]: Object reference not set to an instance of an object.
    [SPIisWebSiteWssSequence] [ERROR] [3/19/2009 8:08:01 PM]:    at Microsoft.SharePoint.Upgrade.AddSiteMapToWebConfig.EnsureProvider(XmlNode nodeProviders, String strName, String strType, String strSitemapFile)
       at Microsoft.SharePoint.Upgrade.AddNavigationProviderToWebConfig.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/19/2009 8:08:01 PM]: Begin Rollback()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/19/2009 8:08:01 PM]: End Rollback()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/19/2009 8:08:01 PM]: Begin Dispose()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/19/2009 8:08:01 PM]: End Dispose()
    [AddNavigationProviderToWebConfig] [3.0.9.0] [DEBUG] [3/19/2009 8:08:01 PM]: Elapsed time: 00:00:00.
    [SPManager] [ERROR] [3/19/2009 8:08:01 PM]: Upgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed.
    [SPManager] [ERROR] [3/19/2009 8:08:01 PM]: Object reference not set to an instance of an object.
    [SPManager] [ERROR] [3/19/2009 8:08:01 PM]:    at Microsoft.SharePoint.Upgrade.AddSiteMapToWebConfig.EnsureProvider(XmlNode nodeProviders, String strName, String strType, String strSitemapFile)
       at Microsoft.SharePoint.Upgrade.AddNavigationProviderToWebConfig.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [SPManager] [ERROR] [3/19/2009 8:08:01 PM]: Action 3.0.9.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
    [SPManager] [ERROR] [3/19/2009 8:08:01 PM]:    at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
    [SPManager] [DEBUG] [3/19/2009 8:08:01 PM]: Elapsed time upgrading [Microsoft.SharePoint.Administration.SPIisWebSite]: 00:00:25.
    [SPManager] [ERROR] [3/19/2009 8:08:01 PM]: ReflexiveUpgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed.
    [SPManager] [ERROR] [3/19/2009 8:08:01 PM]: Object reference not set to an instance of an object.
    [SPManager] [ERROR] [3/19/2009 8:08:01 PM]:    at Microsoft.SharePoint.Upgrade.AddSiteMapToWebConfig.EnsureProvider(XmlNode nodeProviders, String strName, String strType, String strSitemapFile)
       at Microsoft.SharePoint.Upgrade.AddNavigationProviderToWebConfig.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [SPManager] [ERROR] [3/19/2009 8:08:01 PM]: Action 3.0.9.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
    [SPManager] [ERROR] [3/19/2009 8:08:01 PM]:    at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
    [SPManager] [DEBUG] [3/19/2009 8:08:01 PM]: Disposing Microsoft.SharePoint.Administration.SPIisWebSite.
    [SPManager] [INFO] [3/19/2009 8:08:01 PM]: Resetting the status of PersistedUpgradableObject: SPWebApplication Name=SharePoint - 16064 Parent=SPWebService to Online.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: ReflexiveUpgrade [SPWebApplication Name=SharePoint - 16064 Parent=SPWebService] failed.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: Object reference not set to an instance of an object.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]:    at Microsoft.SharePoint.Upgrade.AddSiteMapToWebConfig.EnsureProvider(XmlNode nodeProviders, String strName, String strType, String strSitemapFile)
       at Microsoft.SharePoint.Upgrade.AddNavigationProviderToWebConfig.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: Action 3.0.9.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]:    at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
    [SPManager] [INFO] [3/19/2009 8:08:02 PM]: Resetting the status of PersistedUpgradableObject: SPWebService Parent=SPFarm Name=SharePoint_Config to Online.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: ReflexiveUpgrade [SPWebService Parent=SPFarm Name=SharePoint_Config] failed.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: Object reference not set to an instance of an object.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]:    at Microsoft.SharePoint.Upgrade.AddSiteMapToWebConfig.EnsureProvider(XmlNode nodeProviders, String strName, String strType, String strSitemapFile)
       at Microsoft.SharePoint.Upgrade.AddNavigationProviderToWebConfig.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: Action 3.0.9.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]:    at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
    [SPManager] [INFO] [3/19/2009 8:08:02 PM]: Resetting the status of PersistedUpgradableObject: SPWebServiceInstance Parent=SPServer Name=servemanint to Online.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: ReflexiveUpgrade [SPWebServiceInstance Parent=SPServer Name=servemanint] failed.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: Object reference not set to an instance of an object.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]:    at Microsoft.SharePoint.Upgrade.AddSiteMapToWebConfig.EnsureProvider(XmlNode nodeProviders, String strName, String strType, String strSitemapFile)
       at Microsoft.SharePoint.Upgrade.AddNavigationProviderToWebConfig.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: Action 3.0.9.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]:    at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
    [SPManager] [INFO] [3/19/2009 8:08:02 PM]: Resetting the status of PersistedUpgradableObject: SPServer Name=servemanint Parent=SPFarm Name=SharePoint_Config to Online.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: ReflexiveUpgrade [SPServer Name=servemanint Parent=SPFarm Name=SharePoint_Config] failed.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: Object reference not set to an instance of an object.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]:    at Microsoft.SharePoint.Upgrade.AddSiteMapToWebConfig.EnsureProvider(XmlNode nodeProviders, String strName, String strType, String strSitemapFile)
       at Microsoft.SharePoint.Upgrade.AddNavigationProviderToWebConfig.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]: Action 3.0.9.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
    [SPManager] [ERROR] [3/19/2009 8:08:02 PM]:    at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveUpgrade(Object o, Boolean bRecurse)
    [SPManager] [INFO] [3/19/2009 8:08:02 PM]: Resetting the status of PersistedUpgradableObject: SPFarm Name=SharePoint_Config to Online.
    [SPManager] [INFO] [3/19/2009 8:08:02 PM]: Inplace Upgrade session finishes. root object = SPFarm Name=SharePoint_Config, recursive = True. 7 errors and 2 warnings encountered.



    I appreciate all your help.. thanks

    Thursday, March 19, 2009 9:26 PM
  • Hi Farhan,

    If you have configured your farm using the least privileges method, add your farm account (this is the account that runs the Windows SharePoint Services Timer service) to the local Administrators group, log on with that account and run the "psconfig -cmd upgrade -inplace b2b -force -wait" command again as Jerry suggested.  This account should now have the required permissions to push this through.

    Once it completes successfully, remove the farm account from the local Administrators group and log off.

    Hope this sorts the problem.

    Regards,

    Daniel

    Friday, March 27, 2009 12:45 PM
  • Daniel,

    Thanks for your response.  Well the account that I am using for running this command (psconfig) does belong to local administrators group.  Unfortunately I don't have the credentials of the farm account (the account that runs WSS Timer Service) which is the Administrator account.

    Anyway I can push this through using other than using the farm account?

    Regards,
    Farhan Shahid

    Saturday, March 28, 2009 7:50 PM
  • Hi Farhan,

    One of the first things that I tried was making the farm account a member of the local administrators group, but even adding those permissions didn't work for me.  The only way I managed to force the upgrade through was by logging on with the farm account after it had been granted local administrator privileges and running that command directly.

    Sorry I can't be of further assistance, but the stated method did work for me if.  Is there no way you can find out what the farm account password is?

    Regards,

    Daniel

    Monday, March 30, 2009 8:11 AM
  • Hi Faran,

    Check the upgrade.log there you might find the system expection error. I have posted a solution on my blog, please check http://epmimplementations.blogspot.com/2009/04/systemruntimeinteropservicescomexceptio.html

    -Rohit
    Thursday, April 9, 2009 9:21 PM
  • Daniel,

    Thanks for your help.  I managed to get hold of the administrator account, but that didn't help either.  Still got the same error.  Any other idea will be much appreciated.

    Thanks.
    Wednesday, April 15, 2009 11:30 AM
  • Hello Rohit,

    Thankyou for response.  I have included the upgrade.log in earlier messages in this thread.  I don't think I am getting the exception which you pointed out in your blog.  Any other idea will be much appreciated.  I am stuck with this problem for a long time now..

    Regards,
    Farhan Shahid
    Wednesday, April 15, 2009 11:32 AM
  • I ran into the same problem guys.........:D. and i was able to fix it

    Resource id to be retrieved is UpgradeTaskFailConfigSyncDisplayLabel

    This error has nothing related to the language pack, I tried installing english languagpe pack too... But it failed

    You have to go to the solution management and retract the custom solution from there, My recommendation use the technet article http://technet.microsoft.com/en-us/library/cc288570.aspx, because when you retract a solution it creates a timer job which takes its own sweet time so if you are as impatient as me run the stsadm -o execadminsvcjobs command and remove the solution

    Now initiate the PSconfig wizard.... it works like magic  :D

    Hope it helps !!!!
    Monday, April 27, 2009 3:18 PM
  • I am experiencing the same issue installing WSS SP2 with the same "Action 3.0.9.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed." errors in my upgrade.log

     - I have MOSS installed at SP1. This was slipstreamed into the original installation rather than applied afterwards.
     - There is only one web application other than central admin/ssp and it was imported from a SharePoint Portal Server 2003 content database
     - I do have a least priviliege installation
     - I only had 3 custom solutions installed, and all 3 were stadm extensions rather than solutions deployed to the web application. I have retracted all three.
     - I have added the farm account to the local administrators group, logged in and run the upgrade command under that account
     - I also tried changing the web.config NTFS security so that everyone had full control

    None of these have helped. Does anyone have any further ideas?
    Thursday, May 7, 2009 10:43 AM
  • Hi,

    The problem is in your web.config file and if I read the error messages correctly it get's an Object rference not set to an instance of an object error when it tries to add (and presumably locate) a certain element in the web.config file. Have you got other environments that you CAN upgrade? I think it would be worth a shot to compare the web.config  C:\Inetpub\wwwroot\wss\VirtualDirectories\16064\web.config to another one that doesn't cause problems. Maybe you can even compare the web.config that generates the error with another one of another web application in the same environment.
    I deleted a web.config file from the wpresources folder and that caused my upgrade to fail, when I restored it I didn't have any problems anymore, so changed web.configs can definitely break your SP2 upgrade.

    Hope this helps...


    Mirjam --http://www.sharepointblogs.com/mirjam
    Thursday, May 7, 2009 11:40 AM
  • That certainly helped.

    The <system.web> node had been wrapped inside a <location path="." inheritInChildApplications="false"> node in order to prevent SharePoint settings affecting other web applications that were running in virtual directories under the SharePoint site. Commenting out that node allowed the upgrade to proceed.
    Thursday, May 7, 2009 12:18 PM
  • Mirjam,

    Please do not propose your own posts.

    Instead propose the good quality posts of other people and WAIT for your posts to be proposed in the same way.

    (Moderator)

    WSS FAQ sites: http://wssv2faq.mindsharp.com and http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 / MOSS 2007 Books (including foreign language) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
    Thursday, May 7, 2009 2:28 PM
  • That certainly helped.

    The <system.web> node had been wrapped inside a <location path="." inheritInChildApplications="false"> node in order to prevent SharePoint settings affecting other web applications that were running in virtual directories under the SharePoint site. Commenting out that node allowed the upgrade to proceed.

    This was my exact issue. My problem presented exactly the same as the OP. Attempting upgrade from WSS 3.0 SP1 -> SP2 and hit a wall. After reading Paul's entry above, things clicked. I had modified my web.config in the exact same way, and for the exact same reasons - running other web apps under the sharepoint virtual root. Commented out my change and things went thru successfully.

    THANK YOU PAUL! Made a crappy night SIGNIFICANTLY less crappy than it was shaping into =)
    Wednesday, October 21, 2009 10:25 AM
  • I met the same problem about the B2B upgrader timer job failed.
    Wednesday, November 24, 2010 10:20 AM