locked
NAP XP SP3 Client, 802.1x, HP ProCurve RRS feed

  • Question

  • I've been working on getting NAP setup for my network.  I've been successful in getting it to work using Windows 7, however, the rest of the network uses Windows XP which I have not been able to get to work.  When I plug my 7 box into my HP ProCurve switch I get the following information in the debug on the switch:

    I 09/11/09 09:23:11 ports: port 23 is Blocked by AAA
    I 09/11/09 09:23:11 ports: port 23 is now on-line

    And everything is right with the world, when I plug in my XP box in the switch I get this:

    I 09/11/09 09:23:47 ports: port 33 is Blocked by AAA

    The XP box never goes to the on-line mode.  On the XP box itself it just goes to a limited or no connectivity.  I check the logs on my NAP server and it doesn't show anything coming from this XP box.

    I followed the setup on the Lazy Admin site for XP SP3:


    I'm wondering if it has to do with my NAP using 802.1x as my connection method.  I used EAP (ID#79623) so my actual command I used on the XP box is:

    netsh nap client set enforcement ID = 79623 Admin = "Enable"

    When I run netsh nap client show configuration is shows that EAP is enabled.  I'm having a very difficult time with this as there doesn't seem to be a large amount of info online for XP.  Can anyone point me in the right direction here?
    Friday, September 11, 2009 1:31 PM

Answers

  • Okay, this is so easy and obvious I can't believe it's not part of a doc somewhere.  All you have to do is enable the service, Wired AutoConfig on the XP box!
    • Marked as answer by gunnarwb Friday, September 11, 2009 2:14 PM
    Friday, September 11, 2009 2:14 PM
  • Also, the XP Client shoudl have the NAP Client servers running.  Refer to this technet article to setup the client.

    http://technet.microsoft.com/en-us/library/dd314156(WS.10).aspx

    • Marked as answer by gunnarwb Thursday, September 17, 2009 5:07 PM
    Thursday, September 17, 2009 5:07 PM

All replies

  • Okay, this is so easy and obvious I can't believe it's not part of a doc somewhere.  All you have to do is enable the service, Wired AutoConfig on the XP box!
    • Marked as answer by gunnarwb Friday, September 11, 2009 2:14 PM
    Friday, September 11, 2009 2:14 PM
  • Also, the XP Client shoudl have the NAP Client servers running.  Refer to this technet article to setup the client.

    http://technet.microsoft.com/en-us/library/dd314156(WS.10).aspx

    • Marked as answer by gunnarwb Thursday, September 17, 2009 5:07 PM
    Thursday, September 17, 2009 5:07 PM