locked
Slow transfer speeds from host to hyper-v vm RRS feed

  • Question

  • Not sure if this is the proper forum or not but here it goes. I have windows server 2012 setup on physical machine with dual intel 82574l NICs. On this server I am hosting two hyper-v vms. The issue here is that when I transfer files from either host to vm or vm to host I get at best 6MB/s on average I get around 3MB/s. The cards are set for 100 MB Full Duplex and it seems they should be transferring much faster than this. I have read some other posts but could not find anything that helped. Perhaps it is the virtual switch configuration, the host config... I am just not sure. What I do know is that when I try to backup 150 Gb at 5MB/s it takes a very long time. I need this faster. Any information you need to assist in solving this problem please let me know, I am stumped.

    Setup:

    6 HDD's in Raid 6, 15K

    Virtualization is enabled in BIOS, both bits

    No AntiVirus

    VM switch is setup External, not sharing with host, Allocated 12Gb RAM with Dynamic Memory enables

    Using 4 of 8 processors and have bumped all cpu/mem settings to have this VM take precedence. Does not matter if both vm's are running. Still slow.

    I have disabled the TCP Offloading on VM, no difference, reenabled

    Would setting us the VM with an iSCSI controller make difference, right now it is just set up on hyper-v as IDE controller due to server 2012 os on there, should I modify this to have server 2012 on boot and setup another .vhdx as iSCSI to store data? This vm is a file server.

    • Edited by CZStech Monday, February 25, 2013 7:58 PM
    Monday, February 25, 2013 7:42 PM

Answers

  • Okay, I don't know if this will work for you but it worked for me. I went into the Hyper-V switch configuration manager, removed the virtual switch for the vm, created a new External switch enabling SR-IOV. Went back to the VM and reset the network adapter to the new virtual switch. This got my transfer rates right about 10 MB/s. After that I test the transfer to another vm that has the, Allow managing OS to share this adapter. I was getting 25 MB/s transfer. So I enabled it on the other vm and guess what? 20 - 30 MB/s transfer consistently. Not sure if this will work for you or not but that's what fixed mine. Anybody see any issues with this setup for a file server?
    • Marked as answer by CZStech Monday, February 25, 2013 9:46 PM
    Monday, February 25, 2013 9:46 PM

All replies

  • First, there is a Hyper-V forum at http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/threads which is a better place to post questions like this.

    When you assigned the NIC to the VM, did you assign a Network Adapter or a Legacy Network Adapter?  Legacy adapters are emulated so perform much slower than Network Adapters.

    How have you set the cards to be only 100 Mbps?   Is this a limitation in your switching environment or physical cards?  6MBs on 100Mbps means you are using about half the available bandwidth.  Do you have the 2012 drivers for the NICs you are using?

    VMs can have SCSI data disks, but it must boot from IDE.  No, that makes no difference in performance. 


    .:|:.:|:. tim

    Monday, February 25, 2013 8:20 PM
  • Hopefully the moderators will see this and move to the Hyper-v Section

    It appears to be a Network adapter NOT legacy, when I check the settings in Hyper-V manager it shows a Network Adapter for the the virtual switch, NOT Legacy Network adapter.

    In the card settings themselves there was the option for Auto Negotiate, 10 half, 10 full, 100 half, 100 full, so they have been set for 100 full. I just updated the drivers today from Intel's website for the server 2012 drivers and saw no difference.

    Good to know that a SCSI disk will make no difference here.

    It seemed to be working okay yesterday, I was getting about 10MB/s on my backup but today performing a file transfer I hang around 3 MB/s and I started a backup to see what my speeds were and got around 4 or 5 MB/s

    Monday, February 25, 2013 8:29 PM
  • Okay, I don't know if this will work for you but it worked for me. I went into the Hyper-V switch configuration manager, removed the virtual switch for the vm, created a new External switch enabling SR-IOV. Went back to the VM and reset the network adapter to the new virtual switch. This got my transfer rates right about 10 MB/s. After that I test the transfer to another vm that has the, Allow managing OS to share this adapter. I was getting 25 MB/s transfer. So I enabled it on the other vm and guess what? 20 - 30 MB/s transfer consistently. Not sure if this will work for you or not but that's what fixed mine. Anybody see any issues with this setup for a file server?
    • Marked as answer by CZStech Monday, February 25, 2013 9:46 PM
    Monday, February 25, 2013 9:46 PM