none
Rebuilding the reporting database causes the cube building process to fail RRS feed

  • Question

  • Hi all,

    I'm running SQL 2008, MSPS 2007 and Windows Server 2008.

    I was having an issue (FK constraint when trying to publish) with enterprise custom fields and read online that the reason was because my reporting and publish database weren't in sync and that in order to fix the issue, I had to rebuild my reporting database by doing the following:

    1. Go into PWA->Server Settings->Administrative Backup.

    2. Select Enterprise Custom Fields and then back it up.

    3. Go into PWA->Server Settings->Administrative Restore, select Enterprise Custom Fields from the Item menu and restore.

    It did seem to fix my publishing issue but then I could not build my cube.  I now get the following error:

    Failed to build the OLAP cubes. Error: Invalid call to GetJoinForCustomFieldDimension. Cannot join "Task Non Timephased" fact with a custom field of entity Assignment

    PWA log:

    Critical    Standard Information:PSI Entry Point:   Project User: XRXNA\MSPS_SrvFarm_Svc  Correlation Id: 8ee1f45b-9c49-493a-b9f3-ce7f994e3a95  PWA Site URL: http://can6800vm024/PWA  SSP Name: SharedServices1  PSError: CBSMetadataProcessingFailure (17005) Cube build internal error. Fail to create the internal representation of the OLAP database structure. CBS queued message: Setting UID=00007829-4392-48b3-b533-5a5a4797e3c9 ASServerName=can6800vm024 ASDBName=Analysis12 ASExtraNetAddress=can6800vm024 RangeChoice=0 PastNum=1 PastUnit=0 NextNum=1 NextUnit=0 FromDate=08/10/2011 16:16:20 ToDate=08/10/2011 16:16:20 HighPriority=True. Error: Invalid call to GetJoinForCustomFieldDimension. Cannot join "Task Non Timephased" fact with a custom field of entity Assignment    8ee1f45b-9c49-493a-b9f3-ce7f994e3a95

    I read online that it was an easy fix and that all I had to do was remove the dimensions from the assignment cube, save the configuration, then add them back again and save again.  Unfortunately that did not work for me as I still receive the same error.

    Any ideas on how to fix this?

     

    Thanks!

    Andre

    Friday, August 12, 2011 1:44 PM

Answers

  • Hi all,

    I managed to fix the issue by doing the following:

    1. Remove any and all custom configurations from the cube (Server Settings->Configuration).  Save.

    2. Do an Administrative Backup of the Enterprise Custom Fields.

    3. Do an Administrative Restore of the Enterprise Custom Fields.  This will take some time, around 20 mins for me.  You know it's complete when the Reporting Database Refresh job is complete.

    4. Rebuild the cube. 

    5. Re-add your custom configurations for the cube.

    6. Rebuild the cube.

     

    Worked for me, hope this helps someone!

     

    Andre

    Friday, August 12, 2011 7:16 PM