none
Custom field data not displaying in new Timesheet view RRS feed

  • Question

  • Howdy!

    I created a task level custom field a few weeks ago, and it is required.  I just built a timesheet view that includes this custom field.  When I select the view, though, I do not see data for all of the rows in this field... I see it for some, but not for all.  I've verified that there is data for each row if viewed via the project schedule.  Any ideas what I have done wrong here?

    Marika

    Tuesday, April 26, 2011 4:47 PM

Answers

All replies

  • Hi Marika,

    when you defined your field, have you selected check box "roll down unless manually specified"? This will copy your task level values to assignment level - and in timesheet and task view, you look at assignment level.

    Does that help?
    Barbara

    Tuesday, April 26, 2011 4:57 PM
    Moderator
  • Yup, it is selected "roll down unless manually specified."

    Anything else I should check/try?

    Marika

     

     

    Tuesday, April 26, 2011 4:59 PM
  • Hi,

    sorry for my first question: you wrote that you see it for some lines but not for all of them. Have you published your project with missing data in timesheet lines after entering data and before timesheet creation? Could you just try to open task usage view in Project client, add your field, check if field has values on assignment level, and publish. Delete a timesheet and create it once more. Does that change anything?

    Barbara

    Tuesday, April 26, 2011 5:04 PM
    Moderator
  • Sorry I took a while to respond.  That does seem to have helped, for that particular project!  Thank you!  Does that mean I need to open, add to view, republish each project? Gah.
    Wednesday, April 27, 2011 12:59 PM
  • Hi Marika,

    you will not like my answer, I am afraid.... Any change on Enterprise Custom fields require to open your project and re-publish. Sorry!

    Regards
    Barbara

    Wednesday, April 27, 2011 1:12 PM
    Moderator
  • And I don't imagine there's a way to open all project and re-publish at once, is there?

     

    Just hoping :-)

    Wednesday, April 27, 2011 2:14 PM
  • Hi Marika,

    sorry, no - I had mentioned if there was an UI for this. You can do it by custom code, e.g. using PSI or a VBA macro reading all existing projects from RDB to open and publish. Depending on your number of projects, this can be much more effort than doing manually.

    Barbara

    Wednesday, April 27, 2011 2:21 PM
    Moderator
  • Hi,

    sorry for my first question: you wrote that you see it for some lines but not for all of them. Have you published your project with missing data in timesheet lines after entering data and before timesheet creation? Could you just try to open task usage view in Project client, add your field, check if field has values on assignment level, and publish. Delete a timesheet and create it once more. Does that change anything?

    Barbara

    Hello Barbara,

    Sorry to bring back this question, but I am in the same situation(I have a project with an enterprise custom field (Task)). And with me your solution doesn't fix it. I have already re-published to project. And after this republishing I have also deleted and recreated the timesheet. And I have selected Roll down, unless manually specified (Calculation for Assignment Rows). But the field stays empty on the timesheet. (single entry mode is enabled).

    Do you have another idea which I can try?

    Thank You.

    Wim Cant.

    Friday, June 10, 2011 1:40 PM
  • Wim

    I am glad you wrote... the presented solution didn't fix my problem, ultimately, either and I really need to figure it out.  Does anyone else have any idea what might be going on?

    Tuesday, June 14, 2011 2:30 PM
  • Hello Marika,

    As you said that you made the changes in Task level CF in project & published. But you don't see the data in newly created time sheets.

    1. Open the same project plan where you had set up the Task level CF & verify if they are there or not.
    2. Delete the Project cache from machine , Open the Plan & setup the task CF values, publish & create new time sheet or delete & recreate the old one to verify.


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    Wednesday, June 15, 2011 11:44 AM
  • Hi Wim and Marika,

    I am still not able to reproduce your issue on my system. But I saw this in the meantime on a customer's system. No re-publish of project or recreation of timesheet does help in this situation. I will follow up, if have any new information on it - sorry!

    Barbara

    Wednesday, June 15, 2011 12:15 PM
    Moderator
  • Hi,

    I was able to reproduce the issue on my test system (Feb 2011 CU). And it seems like a bug to me.

    I have two Task level Custom Field (one with lookup table and with as free text) both with setting 'Roll down, unless manually specified'. Both fields show the same problem.

    Observation: none of the rolled down values are available on the timesheet. All manually specified values on assignment level are available in the timesheet.

    The values are published correctly however. To verify this, try the following:

    • Create a task and specify a custom field value. Assign yourself to the task. (let the CF value roll down, do NOT specify a value manually)
    • Open your timesheet -> The custom field value is not available
    • Select the task on the timesheet and click 'Remove Task'
    • Do NOT save the timesheet!!! Stay on the timesheet page
    • Click 'Insert Row -> Insert Task' and add the task again to the timesheet
    • => Remark that the custom field values are available now on the timesheet. So they have been published correctly.

    Based on this, I can only conclude it must be a bug.

    Can you try the above please? What's your opinion?
    What CU do you have installed? I haven't had the time yet to instal and test with April CU.

    Regards,
    Hans


    My EPM blog: Projectopolis
    Wednesday, June 15, 2011 5:50 PM
    Moderator
  • Having it also (with SP1 + June CU).

     

    Barak

    Wednesday, September 21, 2011 11:14 AM
  • Solved by October CU
    • Proposed as answer by Barak _ Bester Tuesday, December 13, 2011 2:11 PM
    Tuesday, December 13, 2011 2:10 PM