locked
Application Virtualization Client Trouble RRS feed

  • Question

  • Hi,

    my app-v packet wont start on the Client.

    it comes up with the error code XXXXXX-XXXXXXXX-20000194 on the Client side, which means the sft file cant be found.

    The Log file on the Server says, cant find packet at ...\content\putty\putty_3.sft.

    But the file is right in that directory.

    Is there something else i need to take care of?

    I am using the app-v 4.6 Client for the 64 bit ability but the management server is still 4.5. is that might the issue?
    Tuesday, December 8, 2009 10:56 AM

Answers

All replies

  • Hello,

    Does the client / user have access to the file?

    /Znack
    Tuesday, December 8, 2009 11:09 AM
  • Hi,

    yep i can manually go to the file from the client by using the same user.
    none of the app-v packets worked yet :(
    Tuesday, December 8, 2009 11:52 AM
  • Tuesday, December 8, 2009 11:55 AM
  • Have you followed this article;
    http://support.microsoft.com/kb/930614
    and read this blog-article;
    http://blogs.technet.com/softgrid/archive/2007/02/06/some-common-softgrid-errors.aspx

    /Znack
    Thanks for the answer Znack.

    Well,

    44808 "Unable to locate {provider_policy}."
    44811 "Unable to open {path}\{filename}.sft."

    My log file says 41520 so none of those two met.

    The putty_3.sft file is stored in content\putty\putty_3.sft
    The OSD URL says HREF="RTSP://app-v:554/Putty/Putty_3.sft".
    I already checked the regedit key if the content folder is correct aswell.
    The Server log files points on the right sft file, thats the weird thing, but it comes with the error 41520.

    The Shortcut gets created on the client and the icon is set correctly aswell.
    When i double click on the shortcut the XXXXXX-XXXXXXXX-20000194 Error pops up.

    I might misst something hopefully u can help me.

    Thanks 
    Tuesday, December 8, 2009 1:34 PM
  • Hi,

    1) you should verify that the App-V Management Server service points to the right location.
    To do this, check the server's registry (32bit machine):
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\Server  Check the SOFTGRID_CONTENT_DIR value
    On a 64bit server, it is in the SOFTWARE\WOW-something node

    2) Also, you should double-check in the App-V Management console, Packages Node that the right path to the SFT is listed there. In the above example, your entry also should mention "3" in the "Version" column.
    (don't get confused if those "Packages" paths sometimes are seperated with "\" and sometimes with "/"

    3) You also should verify that your user is member of the group that is configured for the Default Provider (Server-MMC / Providers node, double click on Default provider, --> [Group Assignment] tab)

    4) I suppose you understand German, so http://blogs.msdn.com/sgern/archive/2009/10/26/app-v-4-5-service-pack-1-ein-erfahrungsbericht.aspx might provide some helpful information for you as well (if you upgraded your servers from a previous version)


    Falko
    Tuesday, December 8, 2009 2:52 PM
    Moderator
  • You should also read the error message generated on the client of what it actually referes to. As a environment variable might not be set, etc etc
    Tuesday, December 8, 2009 2:56 PM
  • Hello,

    Loads of stuff while googling for your error message;
    Just something that might give some more possibilities...
    http://www.softgridguru.com/viewtopic.php?p=10438&sid=6021ce4661729916a300fcfb78429060

    /Znack
    • Marked as answer by z3ratul Thursday, January 21, 2010 9:40 AM
    Wednesday, December 9, 2009 7:01 PM
  • Thanks Znack!

    Thats been it :)

    The App-V Management service was not running as System.
    The account its been using had not rights to the content folder....
    after i gave the right security rights it worked like a charm :)
    Thursday, January 21, 2010 9:43 AM