locked
Missing Feature in SP2010 Environment from Database Attach Method of SP2007 RRS feed

  • Question

  • I've used the database attach method to upgrade our 2007 Sharepoint farm to 2010. The farm is up and running but I've got several errors about missing features showing up in the Health Analyzer as follows ...

    [MissingFeature] Database [WSS_Content_2007] has reference(s) to a missing feature: Id = [featureID]. The feature with Id featureID is referenced in the database [WSS_Content_2007], but is not installed on the current farm. The missing feature may cause upgrade to fail. Please install any solution which contains the feature and restart upgrade if necessary.

    We obviously chose to upgrade without having these features installed as they were not causing the upgrade to fail and the features were not required anymore.  (i.e. we are manually dealing with old content that used these features) 

    Question ... How can I remove the missing features so these errors can get cleaned up?

    Monday, November 8, 2010 9:32 PM

Answers

All replies

  • I think you will probably have to track down any sites and / or pages that you know were using that feature and remove the reference to it.  It's kind of a manual process, but it should work.  
    Corey Roth blog: www.dotnetmafia.com twitter: @coreyroth
    Monday, November 8, 2010 10:42 PM
  • Hi Joanne,

    You might find this http://featureadmin.codeplex.com/ tool useful for removing missing Features and cleaning up the environment.  I've used it on upgraded environments with good results.

     


    Dennis Bottjer | Follow Me: @dbottjer | Blog: Dennis Bottjer.com
    • Marked as answer by GuYuming Tuesday, November 16, 2010 7:38 AM
    Tuesday, November 9, 2010 6:32 AM