none
DNS request timed out with nslookup - SBS 2008 (solved)

    General discussion

  • I have set up   SBS 2008   with forwarders in DNS. DNS is configured to forward to a   non-recursive DNS server (the gateway). I added in DHCP an external public   DNS server as secondary DNS – for users could be independent from SBS DNS. Just in case.

    One day SBS stops accepting DNS queries, either internal or external. When I run DNS queries ON the actual server, it resolves OK. But any other computer in the subnet doesn't.

    The DNS zone entries are set by default. The server is configured to listen on ALL IPs, both in IPv4 and IPv6. But for some odd reason it stops working. Nothing is logged in the application or system log relating to DNS. Then running NSLOOKUP on the client or server it reports:

     DNS request timed out.
      timeout was 2 seconds.

     

    So it looks like DNS server on SBS 2008 not respond. Restarting DNS service, clearing DNS cache or rebooting server does not help.

    Solution.

    From the SBS Console choose Network tab, then Connectivity and from the right block run Fix My Network Wizard (FNCW )

    In my case the wizard found issues, one of them was DHCP v6 INVALID OPTION. I let wizard to solve this very issue and DNS was magically recoverd

    Log events of the "Fix My Network" wizard could be find here: C:\Program Files\Windows Small Business Server\Logs\fncw.log


    Denis Ivchenkov
    Thursday, October 21, 2010 12:24 PM

All replies

  • Denis, thanks for posting your issue and your resolution. We often recommend running the Fix My Network wizard when dealing with network related configuration issues. Glad to hear that the wizard did what it is supposed to do -- that is, fix your network!
    -Kevin Weilbacher (SBS MVP)
    "The days pass by so quickly now, the nights are seldom long"
    KW Support MVP Blog
    MVP's do NOT work for Microsoft. We give our time freely to support the SBS community!
    Thursday, October 21, 2010 12:59 PM
  • I know this is an old thread but the problem Denis outlined, perfectly describes my current situation and I'm really stuck without a solution.  

    I've tried to run the Fix My Network Wizard on the server but the only thing it comes up with is that I have Forwarders setup instead of root hints (which is the correct setup for my situation) and this can't be automatically "fixed" anyway.  

    I've read many articles/forum threads that talk about ensuring I have a reverse look-up zone created so that the PTR records can be created/stored there.  This exists and was automatically setup with DNS however for some reason no new PTR records are getting created even though the zone is set to allow secure/dynamic creation.  Even if I manually add the PTR record for a particular host, this has no effect on the issue.  I'm stumped, any help would be greatly appreciated!

    Thanks in advance for your time!

    -John Livingston

    Wednesday, January 18, 2012 6:07 PM