locked
How can we add Special Characters to the KPI names? RRS feed

  • Question

  • Hello friends,
    I need to add KPI with its name as Marketing(%)  to my SSAS Cube. By default its not allowing to add the special characters to the KPI name. Actually i need to show units of measurement along with the KPI name. here for my requirement its "%". Why it is not allowing the Special characters?.
    abinjaik
    Tuesday, July 7, 2009 9:49 AM

Answers

  • hi,

    you could use translations for such purposes
    for example if your cube's language is set to Englisch (United States) - also add a translation for Englisch (United States) to your cube
    as caption for Translations you can use caracters like %, / and so on

    so call your KPI "KPI_Percent" and add a translation as "KPI %"

    greets,
    gerhard
    - www.pmOne.com -
    • Marked as answer by Jaik Antony Wednesday, July 8, 2009 9:05 AM
    Tuesday, July 7, 2009 5:53 PM
    Answerer
  • Ah clever Gerhard! :D

    Abin: You need to open your solution and double click your cube in the solution explorer. Then click on the Translations Tab, Right Click, Choose a language (It doesn't matter which really) and then you  can name or "translate" your KPIs. It's a bit like giving it an alias and you'll be able to use your special characters now.

    Now when you change the langauge settings in your cube it will display the "translation"

    HTH

    J
    “It's kind of fun to do the impossible.” - Walt Disney
    • Marked as answer by Jaik Antony Wednesday, July 8, 2009 9:05 AM
    Wednesday, July 8, 2009 7:27 AM

All replies

  • Hi there

    Well it's just an SSAS quirk.  I would perhaps use the word [Percentage] instead. If this was a measure, rather than a KPI, you could create a calculated measure based on the base measure which allows you to use the the % character...

    Sorry it's not a magic answer!

    Jo
    “It's kind of fun to do the impossible.” - Walt Disney
    • Proposed as answer by TheOLAPFairy Tuesday, July 7, 2009 12:12 PM
    Tuesday, July 7, 2009 12:12 PM
  • But its not allowing to enter "%" sign on the name field of the KPI
    abinjaik
    Tuesday, July 7, 2009 1:35 PM
  • hi,

    you could use translations for such purposes
    for example if your cube's language is set to Englisch (United States) - also add a translation for Englisch (United States) to your cube
    as caption for Translations you can use caracters like %, / and so on

    so call your KPI "KPI_Percent" and add a translation as "KPI %"

    greets,
    gerhard
    - www.pmOne.com -
    • Marked as answer by Jaik Antony Wednesday, July 8, 2009 9:05 AM
    Tuesday, July 7, 2009 5:53 PM
    Answerer
  • Can you please tell me where to add translations... I am very new to SSAS... After all we can set the KPI names with Special Characters.r8?
    abinjaik
    Wednesday, July 8, 2009 5:29 AM
  • Ah clever Gerhard! :D

    Abin: You need to open your solution and double click your cube in the solution explorer. Then click on the Translations Tab, Right Click, Choose a language (It doesn't matter which really) and then you  can name or "translate" your KPIs. It's a bit like giving it an alias and you'll be able to use your special characters now.

    Now when you change the langauge settings in your cube it will display the "translation"

    HTH

    J
    “It's kind of fun to do the impossible.” - Walt Disney
    • Marked as answer by Jaik Antony Wednesday, July 8, 2009 9:05 AM
    Wednesday, July 8, 2009 7:27 AM
  • These translations are not viewed on my sharepoint KPIList. Why?
    abinjaik
    Wednesday, July 8, 2009 2:04 PM