locked
Unable to configure new Server 2016 KMS host RRS feed

  • Question

  • When trying to go to the configuration aspect of the Volume Activation Tools on my new 2016 server I get the following error:

    Description:

    Indicates two revision levels are incompatible

    I don't get any obvious error in eventviewer and I'm at a loss.

    Here's my environment, and what I'm trying to do:

    My AD level is 2008R2 and I currently have a 2008R2 server performing KMS duties; so no AD based or Win10/2016 activation in my current system setup.  I'm attempting to transition to this new server as a KMS host server when I get the error.  I can see where the server is adding the DNS SRV record, I am an Enterprise admin as well as Domain Admin (single Domain) and local administrator on the server.  I started Volume Activation Tools utility as an administrator as well.

    Any thoughts?

    Thank you.

    Thursday, January 19, 2017 3:52 PM

All replies

  • Hi MadMaxZ1R,

    It seems there are not much information about the error.

    Which KMS host key are you using?

    To make the Server 2016 KMS server, just run command slmgr /ipk to install the KMS key.

    https://technet.microsoft.com/en-us/library/ff793416.aspx

    If the old KMS server is not required, run slmgr /upk to uninstall the KMS key and delete the related DNS SRV records.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 20, 2017 6:37 AM
  • Thank you for the Feedback Leo,

    There seems to be a bug with Server2016 and the Volume Activation Role

    I thought that maybe the problem I was having was that this was the first 2016 server I deployed with a new VMWare template,  and maybe there was a problem with my Template.  So I decided to try a fresh install of server 2016 standard with GUI.  Unfortunately the problem presented itself in the same manner.

    I've tried:

    • sfc /scannow without error.
    • I've given additional explicit access security permission to specific COM services for 'SYSTEM' as I pick through specific event log errors related to appid and clsid's and lack of permissions for the System
    • etc ...a lot of other things.

    The last attempt was to connect the Volume Activation tool from my Windows10 install to the server and I get the following error as mentioned by Server Core team in October on the following blog post ( https://blogs.technet.microsoft.com/askcore/2016/10/19/windows-server-2016-volume-activation-tips/ )

    Regrettably, the blog has not been updated with news of a fix.   ..MY first 2016 server for production = fail.  However it does seem to be processing activation request as I do see Volume activation events processing.

    If you have any information about an upcoming fix please let us know as I see some folks have had trouble with installing Office Keys as well.

    Monday, January 23, 2017 2:59 PM
  • Hi MadMazZ1R,

    >>If you have any information about an upcoming fix please let us know as I see some folks have had trouble with installing Office Keys as well.

    I would wait for later official documents and post here if I got any updates on it.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, January 24, 2017 5:43 AM
  • Hi Mad,

    i have exactly the same issue, after updating to Build 14393.729,

    before we had the Build 14393.447, we only get the gui crash

    did someone already find a solution for this issue?

    Best Regards,

    Sebastian

    Friday, February 17, 2017 7:08 AM
  • Same problem here with a new Server 2016 KMS host. Unable to configure it.
    Tuesday, February 28, 2017 9:56 AM
  • Try setting the server up briefly with internet access. The first time you install the KMS host key - the server will obviously attempt to validate itself against MS Servers - it will fail if it can't get there - obviously once activated you would remove the proxy settings etc.

    Hope that helps

    Wednesday, March 1, 2017 3:05 PM
  • Hi,

    I have the same problem. "Indicates two revision levels are incompatible."

    Is there any solution? The Server (MS Server 2016 Standard) has direct internet-connection.

    Thank you!!

    Martin

    Wednesday, March 1, 2017 10:51 PM
  • It runs now on my Server MS 2016.

    Here is the solution:

    ======================================

    I got it working. I had to do it through command line differently then I did before.

    Steps are as follows

    - Install Office 2016 on the KMS Server

    - From Command Prompt enter your license

    c:\Windows\system32> slmgr.vbs /ipk XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

    - From Command Prompt 

    "cd  c:\Program Files (x86)\Microsoft Office\Office16"

    "c:\Program Files (x86)\Microsoft Office\Office16>cscript ospp.vbs /act"

    You should then get a read out telling you that 

    VL_KMS_Host edition

    <Product activation successful>

    =====================================================

    h**tp://social.technet.microsoft.com/Forums/windowsserver/en-US/4fcb2955-cd35-4e11-b3bb-757722a7d0a8/setup-kms-host-on-server-2016-for-office-2016?forum=winserverManagement

    **, because I am not allowed to ad links :o(

    Thursday, March 2, 2017 8:23 PM
  • I also have this problem hope that Microsoft will make an update soon. ( i updated today 24-03-2017)

    My issue as off today i am missing Windows 7 Activation.

    • I got Office 2010,2013,2016 to activate successfully.
    • And as i understand it the KMS 2016 superseeds all server versions below ( 2008R2,2012R2)
    • Windows 10 should also be covered by 2016 ?

    I case some of you missed the office 2010 key issue here it is: REF comments on https://blogs.technet.microsoft.com/askcore/2016/10/19/windows-server-2016-volume-activation-tips/
    ------------------------------------------------------------------------------------------------------------------------

    If you just try to install Microsoft Office 2010 KMS Host License Pack  (or 2013) it will fail with the “Unsupported operation system” error. This is a expected behavior, but running in compatibility mode will not fix it. Instead, you should:

    1) Install Office KMS Host Licence Pack (version 2010, for example). Ignore the OS error.

    2) Go to C:\Program Files (x86)\MSECache\OfficeKMS  and patch the kms_host.vbs file. After code block
    ‘ win8 or greater
    If (Ver(0) = “6” And Ver(1) >= “2”) Or (Ver(0) >= “7”) Then
    folder = “win8”
    Exit For
    End If

    insert another one (taken from Office 2016)
    ‘future OS’s
    If (CInt(Ver(0)) >= 10) Then
    folder = "in8"
    Exit For
    End If

    3) Continue installation and activation process by running
    cd C:\Program Files (x86)\MSECache\OfficeKMS
    cscript kms_host.vbs
    It will install the Office key files into the KMS store, and activate it (for Office 2010) or try to do so (for Office 2013+, if you face the vmw.exe bug too).

    4) Repeat 1-3 for Office 2013, it will owerwrite kms_host.vbs. Then install Office 2016 key files as usual, installer will work without modifications, it is fully supported. Now you can better understand, why after Windows 8 we have a Windows 10 – even Mocrosoft code sometimes fail to check versions properly.

    Ok, now you have to activate the Office – but if you, like I do, face te vmw.exe error, it has to be done via the command line and product GUID.
    Office 2010 – activate
    slmgr /ato bfe7a195-4f8f-4f0b-a622-cf13c7d16864
    And check activation (and activated clients, if any)
    slmgr /dlv bfe7a195-4f8f-4f0b-a622-cf13c7d16864

    Office 2013 – activate
    slmgr /ato 2E28138A-847F-42BC-9752-61B03FFF33CD

    Office 2016 – activate
    slmgr /ato 98ebfe73-2084-4c97-932c-c0cd1643bea7

    If activation online fails for any product, it may be needed to import proxy settings from IE into systev via the
    netsh winhttp import proxy source=ie
    command. You can reset them back to (nothing) via netsh winhttp reset proxy.
    Done! Now your new KMS server will activate Windows and Office (all available KMS versions).



    Friday, March 24, 2017 7:36 AM
  • I'm facing the same Issue. Did you get Feedback so far?

    Regards,

    Roger

    Thursday, April 6, 2017 12:23 PM
  • Hi all,

    i have the same issue on an Germany Windows Server 2016 Datacenter. I only want to Post the German Error Text for Searchs:

    Der folgende Fehler ist aufgetreten. Behebn Sie den Fehler, und wiederholen Sie den Vorgang.

    Beschreibung:
    Dies zeigt an, dass zwei Revisionsstufen nicht kompatibel sind.

    Please let me know if there is an Solution.
    Activation with slmgr is working for us at the moment.

    Regards


    Hi

    Wednesday, April 26, 2017 10:28 AM
  • I have the same problem. "Indicates two revision levels are incompatible."

    Install before without update - ok. With updates - no.
    Friday, April 28, 2017 7:12 AM
  • Same problem here - any updates on this issue ?
    Thursday, May 4, 2017 12:49 PM
  • This issue is happening to me too. 

    I have found, however, that if I open up a .CILX file that I was trying to export from our old 2012R2 server, it does let me open up VAMT. I imported, and things look like they're working, but I can't confirm that. I still can't directly access VAMT from the start menu. I can reopen it if I act like I'm going to reimport the .CILX and just cancel it. That's not a fix though. 

    Hopefully a fix is found soon, but since this has been apparently going on for 6 months, I don't have my hopes up. MS broke MDT with 8443 so I looked at upgrading to 2016, and now they broke VAMT on 2016.  

    Thursday, May 4, 2017 9:00 PM
  • Hi all,

    please check if the following works for you too:

    1) Install all Windows KMS host key using slmgr /ipk, do not use the GUI
    2) Do not use slmgr /ato now !
    3) Use slmgr /dlv all to get user Activation IDs for your KMS Host Key
    4) Finally use slmgr /ato "Activation ID" to activate the keys
    5) Do a final check using slmgr /dlv all

    Hope this helps !

    Friday, May 5, 2017 11:21 AM
  • Running the GUI (Volume Activation Tools) from Server 2012R2 and remotely connecting to the Server 2016 box worked for me.
    • Proposed as answer by ItzikTXT1 Wednesday, May 24, 2017 8:28 AM
    Monday, May 22, 2017 3:25 PM
  • Having the same issue here. nothing seems to work :(

    EDIT: OMG the post above me by abcdefg1123 had the solution, simply add the Office license using a different computer and it works for both 2013 and 2016.

    Important note : Make sure u run Volume Activation Tools on the KMS server itself once first and get the error. Otherwise VAT won't accept ur KMS Host Key.


    • Edited by ItzikTXT1 Thursday, May 25, 2017 8:53 AM Solution.
    Tuesday, May 23, 2017 4:37 PM
  • Hi all, 

    We are in an endless of entering the license and delete the key on configuring activation objects. 

    Wednesday, June 14, 2017 7:49 PM
  • slmgr /ato works in an internet connected environment, what about experiencing this (KMS activation) issue on a dark site?

    No server 2012 available for now.

    • Edited by wr19 Thursday, June 15, 2017 11:05 AM
    Thursday, June 15, 2017 11:04 AM