none
Recovery point fails - Consistency Check/Synchronization completes with warning RRS feed

  • Question

  • I have a replication to our DR that works fine except for one system.  In particular just one drive on that one system.  It will not create a recovery point for that particular drive.  When you do a consistency check or synchronization they both complete but give this description.

    The job completed successfully with the following warning:
    The synchronization job failed due to an internal error (ID 117).

    The main site has no issues with creating RP's for this particular system/drive.  All other systems work just fine on the DR replica as well.

    Any ideas?

    Tuesday, October 4, 2016 1:43 PM

All replies

  • An old post, but check this out:

    https://social.technet.microsoft.com/Forums/en-US/e8da0766-6e75-4f3b-b6f3-0c4b7484988f/secondary-dpm-servers-recovery-points-fail-for-primary-dpm-servers-file-volumes?forum=dpmdrbackup

    The last reply in the post above will get you to check if case sensitivity has been enabled on the primary DPM server. Not sure if this is still relevant has it's pretty old, but worth a shot.


    Hope this helps, Stephane

    Tuesday, October 4, 2016 6:01 PM
  • Yeah I saw that post.  That however is not the case here.  Wish it were that easy!
    • Edited by Dusty Zook Wednesday, October 5, 2016 11:11 AM
    Tuesday, October 4, 2016 6:22 PM
  • Would have been too simple :)

    Have you tried to enabled the verbose logs on DPM to see if you can find any more detailed errors?

    You can use this blog on how to enable them:

    https://blogs.technet.microsoft.com/dpm/2015/05/20/an-in-depth-look-at-the-registry-settings-that-control-microsoft-dpm-2012/


    Hope this helps, Stephane

    Tuesday, October 4, 2016 11:52 PM
  • Enabled verbose logging.  After looking through the logs I do not see anything out of the normal.  There is only one section that shows "error" and it shows regardless of verbose or not.

    WARNING Parameter: [0x80070002], FilePath = \\?\Volume{88ade340-88ae-11e6-943b-d89d672add1d}\efd4ee5b-8533-4f88-9228-b59de56d576b\FailedFilesLog.txt

    WARNING Failed: Hr: = [0x80070002] : CreateFile failed \\?\Volume{88ade340-88ae-11e6-943b-d89d672add1d}\efd4ee5b-8533-4f88-9228-b59de56d576b\FailedFilesLog.txt with error :2

    This happens twice in a row then spits out this line.

    WARNING Failed: Hr: = [0x80070002] : Failed to open file: lVal : hr

    That's the only thing I can see with errors/failed/warning. 

    Wednesday, October 5, 2016 1:40 PM
  • This error usually indicates a "File not found", so the agent seems to get in trouble trying to backup a file that was removed, doesn't exist or is unaccessible.

    Are you just backing up a folder on the server or the an entire partition (or multiple)?
    Is the System partition part of that for bare metal recovery purposes?

    I've seen a few issues out there when the poeple are backing the system partitions when those were created by third partition or hardware manufacturers during the initial setup. Is there any hidden partitions (for example, HP creates a 100MB hidden recovery partition in front of the system disk).

    Another troubleshooting step:

    Try to access the above mentioned volume (which you can find under "the DPM installation folder"\Volumes) and see if you can find anything "abnormal" or see what is in the "failedfileslog.txt" file (not sure if that was created by DPM or if it's part of your data).


    Hope this helps, Stephane

    Wednesday, October 5, 2016 11:11 PM
  • It's backing up a standard partition.  The "E" drive of the server.  But this is actually the replication from main site to DR.  The main DPM server backs the server up with no issues or errors.  I can restore from the original server perfectly fine as well.  It's just the replication when it tries to sync or anything, it appears to work but then gives that error ID 117 and you cannot create a recovery point.

    When looking in the volume for the failedfileslog.txt, there is no log file.  

    • Edited by Dusty Zook Thursday, October 6, 2016 12:44 PM
    Thursday, October 6, 2016 11:01 AM
  • Have you tried to completely delete the backup on the DR site (including all data) for that server and recreate the it from scratch?


    Stephane

    Thursday, October 6, 2016 11:52 PM
  • Yes I've tried that.  Still comes back with the same error.
    Friday, October 7, 2016 12:22 PM
  • A couple of quick questions:

    1. What version of DPM and UR are you running on both servers?
    2. What's the OS of the protected server?
    3. Are the other servers that you are protecting and that works the same OS version as the one that doesn't?


    Stephane

    Sunday, October 9, 2016 11:22 PM
  • 1. Both servers are running DPM 2012 R2 version 4.2.1417.0

    2. Server is 2008

    3. We have a variety of servers and including 2008, 2k8R2, 2012, and 2012R2.  Everything works fine on all systems except this drive on that particular server.  And it's only the replication portion from one DPM server to the DR site.  

    Monday, October 10, 2016 12:41 PM