none
Windows, Cups printing and the remote username RRS feed

  • Question

  • Hi,

    I'm trying to print to a remote CUPS printer server using Windows Internet printing. The CUPS server does not use authentication. The remote printers use a smartcard to actually print things (follow-me mode): if I present my company smart card to the printer, all jobs that I submitted are printed on that particular printer.

    As long as my local Windows username is *exactly* the same as what is stored/linked to the smartcard this works fine. However, if I try to print from any other local Windows account (e.g. from a privately owned laptop), then the username that is sent to the cups printer is the local Windows username, resulting in unprintable jobs : I can see them in the cups job list with the wrong userid.

    In Linux, this problem is easily overcome by adding "username <remote-user>"  to the cups client.conf file, but how can this be achieved in Windows 7/8/10 ?   I've played with the Internet printer port settings but it always results in EITHER sending the local username OR in wanting to do full authentication using username+password.

    thanks for any help

    Monday, July 15, 2019 9:18 AM

All replies