Key not working after SlipStream


  • Hello,
    I've slipstreamed SP3 into our Volume License copy of XP Pro. When I install 
    our key will no longer work.
    Anyone know of issues with SP3 changing the installation type (Volume, OEM, 
    retail...) when it is integrated into a particular installation point? or 
    what else might be the cause? 
    Thursday, December 20, 2007 1:45 AM


  • Marco,


    The integration feature has not changed for XP SP3.

    If you slipstream in an existing VL Build (using /integrate), then the new build recieved would be a volume licence copy.


    Have you gotten a chance to confirm if the original base build and the new obtained OS copy are both VL (as explained on the thread).

    We would like to understand your problem better.

    Can you please let us have your email for the purpose?







    Thursday, December 27, 2007 8:54 AM

All replies

  • Hey,

    If you run setup within Windows and where it asked for the CD Key, that screen tells you what "distro" of Windows it is.

    And no just intergrating a service pack does not change the "distro" of Windows. So it still is a VL copy.

    Should you not be getting support though commerical channels and not on a forum for the general public.

    Not accusing you but most people who ask this question on public forums are piraters and are trying to phish information.

    Anyhow, if your serious you should be going though privace channels as this is a prodcut activation issue. (Sorry I meant licensing not activation)

    Take Care,

    Thursday, December 20, 2007 11:26 AM
  • Thanks for taking the time to answer, however keep your silly opinions about my intentions to yourself. That is very insulting, obviously my question was very general and wouldn't yield any information that would be of use in piracy. It's nice to know you give people the benefit of the doubt, please spare me a long winded response about the internet and blah blah blah....


    Since this is an RC product, typically the user base has a larger knowledge of issues that any support channels at this point.


    Let me point out  this is NOT an activation issue. I'm not even at the point of activation. It won't accept the key during setup. Forgot to specify that in my original post. This is an unusual issue, just thought I would throw it out there and see if it was a known issue to some. I'm installing for an installation point that is definetly VL version.





    Thursday, December 20, 2007 3:44 PM
  • Can you let me know what method you used to perform the slip stream?


    Thanks, Shad

    Thursday, December 20, 2007 7:07 PM

    It should work fine


    I slipstreamed SP3 into an OEM (dell recovery cd) version of xp home with no problem.


    The OEM cd did NOT ask me for a key (one was specified when i opened it up using Nlite)


    Those CDs all use dell volume licencing keys. (yes, oddly the serial on the recovery disks is the exact same for a number of my freinds dell pcs and does NOT match the one on the PC sticker - for some reason the key on the sticker is an unused XP retail one - maybe in case yout recovery cds break or get lost)


    NLite is a great software for slipstreaming and cutting down/tweaking

    Thursday, December 20, 2007 7:29 PM
  • Sure, this is the same method I have always used for monthly patches, although since this is a service pack


    I have an installation point that is a non-updated baseline Windows XP w/sp2, downloaded from I applied SP3 to that installation points using CMD


    windowsxp-kb936929-sp3-x86-enu /integrate:c:\pathtoOSfiles


    The integration finishes successfully, installation proceedes normally. When prompted for the key I am using the same VL key that I know works for the pre-slipstreamed installation. However, it will not accept the key, it says that it is invalid. Normally this would indicate using the wrong type of key, or typing it incorrectly. I can rule out typing it incorrectly.


    Thanks, Marco

    Thursday, December 20, 2007 8:16 PM
  • Look I was not trying to accuse you, just came accross that way, sorry. Forgive me...

    Anyhow, if you run setup from windows you shoud see this screen where you enter the product key:

    Notice it says "Volume License product key" . So does your still say that? If not then yes some how it got switched to a different distro some how.

    Also, open SETUPP.INI within the I386 folder and see if the the third line "Pid=" ends with 270. That tells setup it is a VL copy.

    For info sake:

    Retail = 335
    Volume License = 270
    OEM = OEM
    Friday, December 21, 2007 2:54 AM

    No problem, just FYI my technical knowlegde is very far above the type solution you are suggesting, been doing this work for 15 years. I do appriciate the effort, it's just not that simple.


    I believe after re-doing the process I do have a real bug to report here. I tried again to make sure I wasn't making a silly mistake.


    I installed from my installation point pre-sp3, takes the key no problem. Applied SP3 (see above method) to the install point. Did another fresh install, key not accepted (and Yes, to answer War59312 is still asks for a VL key).


    This would be terrible if it carries over to the RTM version of SP3.

    Friday, December 21, 2007 6:16 PM

    Well now I really feel like I have wasted a bunch of time, A known issue it appears??



    This article references that the problem has been reported to Microsoft since beta, it is highly discouraging that RC1 still has the same issue.


    I would love to know if or where this can be reported. This is quite a serious issue, although I'm sure MS is very aware of it and working to solve it for the RTM for sp3.


    Perhaps we will not be able to SS this update due to changes in activation? Hope that isn't the case. But I guess it would be just as easy to download the XP w/SP3 from MS when available.

    Friday, December 21, 2007 10:33 PM
  • yeah you should be able to push SP3 through WSUS.


    Maybe to stop piracy ms left the bug in?? (99% of pirates are corp/volume licencing editions)

    Friday, December 21, 2007 11:02 PM
  •  vbnOOb wrote:

    yeah you should be able to push SP3 through WSUS.


    Maybe to stop piracy ms left the bug in?? (99% of pirates are corp/volume licencing editions)


    Maybe it's not a "bug". Maybe it is their intent to limit SP3 slipstreaming to VL copies. XP support is not going to last forever and there is much buzz about encouraging volume license holders to migrate to Vista. Besides most VL holders will have WSUS or some other method of pushing this out to clients.

    Saturday, December 22, 2007 4:18 AM
  • This doesn't have anything to do with updating clients, that is a different matter completely, and yes WSUS, SMS, PatchLink, UpdateExpert.... etc I'm sure will all be able to push the update out just fine (actually WSUS doesn't push, but anyway )


    This is a matter of client image building with high security. You want to bring up a new machine with as few vulnerabilities as possible, having install media that is as patched as possible is step number 1.


    There is ZERO chance Microsoft would elminate that to sell another product or other profit motivs, to think so is just foolish. Integration has been a large part of all of their products for many years, and doesn't change in Vista or Office 2007, although the implentation is different (and easier).


    This is simply a matter of a product being broken by the update, as I said I can't imagine they are not aware of this. It's too obvious. If a change is in the works that is fine, but I sure would like to see it documented somewhere, and I have read plenty of official "new in SP3" papers, with no mention of license key changes, other than keyless install. Although I'm sure this "problem" and the changes are most certainly linked.

    Saturday, December 22, 2007 5:49 AM
  • Marco,


    The integration feature has not changed for XP SP3.

    If you slipstream in an existing VL Build (using /integrate), then the new build recieved would be a volume licence copy.


    Have you gotten a chance to confirm if the original base build and the new obtained OS copy are both VL (as explained on the thread).

    We would like to understand your problem better.

    Can you please let us have your email for the purpose?







    Thursday, December 27, 2007 8:54 AM

    I have the same issue slipstreaming Sp3, but I found that it does work correctly now and then, mine is volume when I start and voume when it finishes, but sometimes it hiccups on the OEM key.   I have two fully purchased/legal copies I use in my home network and have been having the same issue with either copy.   I have tried it with Nlite, command prompt using update /s and Integrate.   It has worked a couple of times and of course had an error in one of the ini files, but it has missed more than it has worked.


    Just my 2 cents worth



    Thursday, December 27, 2007 11:41 AM
  • Thanks Denny.

    Very useful feedback indeed.

    Can you please share your email contact? I would have one of the developers who work on product activation interact with you directly.





    Thursday, December 27, 2007 11:43 AM

    Yes, both the base build that I'm using and the post-sp3 integrate show that they are VL versions. I installed using the base installation point without issue. Once the /integrate cmd is used the same installation point will no longer accept the key.


    My email address is in my profile (

    Thursday, December 27, 2007 3:22 PM
  • Sure Shashank;


    It doesn't bother me too much, I've been able to work around it, but my email address is   Also if I install the service pack separately it works fine.   I did manage to make a couple of CDs with SP3 slipstreamed that work as expected, VM makes it a much easier task rather than making coasters by the stack.



    Denny Muller

    Friday, December 28, 2007 4:28 AM
  • I just got the SP3 release candidate and played with it a bit (it is now 4AM!)

    I have slipstreamed it onto an XPProSP2 CD and have had some different results.

    First of all, I was impressed that it still fit on one CD. After that, not so good.

    Why didn't I get the beta thrown at me? I am still a registered tester, aren't I?


    I loaded the NEW SP3 CD onto my Win2K Adv Svr running RIS,

    After a client install, the client thinks that it is Media Center Edition! Yup! The screen saver even thinks so!

    No wonder some are having problems with Product Keys if the OS doesn't know which version it is any more...

    At the same time RIS was loading one machine via unattended mode, I threw the CD in another box and during the attended setup it asked for MCE disk #2! WHY?

    (I told it to just skip it instead of diggin' out my MCE disks, they are with the Mistake Edition CD's in a dark closet)


    For the tech MSFT guys, the disk I used for the slipstreaming is XP Pro SP2 version 2002 with the wavy edge,

    0504 Part No. X10-59871

    spindle code (bottom) X10-59896 (NM.05) 04

    (halographic) ASP0225


    I was impressed with the fact that IE6 was not loaded on either system until I went to Add Windoze Components where it was already checked. Upon exit, it then loaded IE6, which cannot automatically detect the gateway!

    I manually configured TCP/IP settings to "tell it where to go", and it still couldn't find it's way to the internet.

    Did you guys make it so that we would have to load Firefox instead?


    BetaPlace still has my number (right?)


    I will beat on this thing some more when I wake up later today

    Wednesday, January 02, 2008 8:43 AM
  • Beercommercial,


    It seems the base CD you have used is a XP Pro MCE CD.

    Can you please reconfirm the same?




    Wednesday, January 02, 2008 12:03 PM
  • i have a little bit different issue with my productkey.


    after i installed the rc1 3264 on my activated windows xp sp2 home edition (not slipstream)

    it asked for the product key for activation.


    the productkey is worked but i should re-activate the copy.


    oem sb builder;

    windows xp home edition w/sp2 german version;

    not from oem manufacturers and not pre-activated from them;

    Wednesday, January 02, 2008 12:30 PM
  • Greetings Shashank, (that was a quick response)


    You are not going to believe this...

    I tried loading the original source CD on the the system that hiccuped with the sp3 CD, and no MCE freakness.

    I loaded the sp3 slipstreamed (/integrate) CD on the system that was the RIS client, and all is good.

    I then used RIS again with the same client as last night, but I took a Product Key from a dead Dell

    and put it in the \i386\templates\ristndrd.sif file, and now it works as XPPro again.

    You guys have put some corrupt WGA embedded in the service pack!

    I could only imagine the hate you would generate if corpoarate (VLK) IT guys like Marco@ucla started putting this on their servers.


    The same flat RIS image with a different product key should not make a difference which OS is the end result.


    Do you want me to say more in a public forum?


    To confirm the source you questioned, here is the code from the last RIS client install,

    (type 3 OEM)



    I have another disk still in the plastic wrap but the code is a bit different

    instead of NM.05 it is ES.01, and the ASP number is 0525.

    different factory?


    I hope this helps you find the nasty bug.



    Thursday, January 03, 2008 4:53 AM

    Why does this come up as answered,  it is NOT answered? (edit: I just unmarked as answer)


    I appreciate the responses from people with similar issues, but I seem to have the most straight forward issue and don't seem to be getting any useful info at all, where should these problems be reported officially?

    Thursday, January 03, 2008 4:43 PM
  • I apologize Marco, I thought that our problems were directly related. If you look at it from the perspective that a working RIS server with a flat image of XP Pro SP2 with integrated updates, has a product key in the answer file that has always worked for XP Pro, then why would the new image using the same source files come up as XP MCE? The only difference is SP3. Conversely, if the installation of SP3 on an established or activated system has some wierd erronious WGA hash which caused my problem, then it is the same kind of thing that could make your WGA invalid, requiring reactivation. If SP3 can make XPPro think it is XP MCE, then it is certainly not a far stretch to believe that the same code could cause XPPro (VLK) to think it is XPPro (OEM). I believe that might be the answer. Now the next question. If that is the problem, what will it take to fix it?


    I certainly hope they get SP3 working soon because I like the fact that it still fits on one CD when slipstreamed, and few of the older systems I reload have a DVD drive. For persons who are always doing clean installs/system reloads, it would be fantastic not to have to pound on Windows Update for hours after even an integrated install, and I'm sure MS could use the spare network bandwidth for something else. Previously, I could only put integrated updates to last March on the install CD. I know a few IT guys were unhappy when MS gave a Cease and Desist Order to the folks with an alternative Windows Update solution on CD. I know that WSUS is another solution, but I don't like carrying my server and peripherals to a customer's home for mobile support.


    I am also fond of RIS because you can put diagnostics tools on the server as well, easier than carrying a bag full of CD's and bootable memory sticks!


    I noticed that Shashank was not so quick to respond today. Do you suppose they found something?



    Thursday, January 03, 2008 9:34 PM
  • Definitely Beer, it sounds very likely they are related. Didn't mean to sound like I don't want others to post, the more people that have witnessed this type of issue the better. I linked to an another site in a previous post where someone had the same issue.


    This really isn't just a matter of convenience, it really is all about security. It is far safer to bring up a new computer that is already fully patched, or at least as much as possible. I also SS all the monthly patches, my current DVD is up to almost 1GB!





    Thursday, January 03, 2008 9:53 PM
  • Marco,


    This could be because of the pidgen.dll file not integrating properly at your end. I had done the same scenarios at my end it worked fine at my end.


    Could you please share both pidgen.dll files, first from your previous XP volume build and second after integrating the SP3 update package init? It's only pidgen.dll file that will help me to track the root cause of this issue.


    and please update me which SP3 update package you are using. is it Beta or RC?



    Suraj Gupta


    Sunday, January 06, 2008 11:52 AM
  • Marco,


    Please confirm your email contact also, is it ""?, as I'm getting mail failure while sending mail on this id.



    Suraj Gupta

    Sunday, January 06, 2008 12:04 PM
  • I have the files ready for you. From the file version it appears to have updated correctly, but you are welcome to take a look.


    The email address is correct, obviously remove the .nospam.


    The forum confuses me, why is it:


    a) you don't know to remove .nospam, it is recommended to use this by the FAQs of this forum

    b) all the MSFT  - microsoft tagged people have joined dates that are almost brand new

    c) they never have email addresses listed.


    All this makes it seem very shady to give them info!!!

    Sunday, January 06, 2008 2:51 PM
  • Hi Marco,


    Apologize for troubles you face!


    I have dropped you mail for all require info to track the root cause of the issue. Please reply the same and help me to find culprit binary/file if any.



    Suraj Gupta

    Monday, January 07, 2008 12:28 PM
  • .
    All the MSFT guys are new because we are either dev/test or PM's who actually create SP3. Not marketing,support folks who monitor this as their full time jobs. Give us a break willya
    Monday, January 07, 2008 1:57 PM
  • Another note to Shashank,


    It appears you might be correct about the source CD being Media Center Edition - Disk 1. I would not have even began the first post if the CD had a clearly visible indication that it was MCE! I have no idea how it got in the jewel case I keep (had) my original CD in. I get ugly when people even suggest borrowing a disk.


    I did not realize that the MCE disk is flexible as to which OS is loaded, depending on the product key entered. I am still wondering about the first RIS install using the old RISTNDRD.SIF answer file on the server. In previous loads using the suspected MCE flat image with an XPPro key, the end result was always XPPro. It may have been a year or more that the same image has been used with XPPro keys in the answer file. That might also make it impossible for me to track down when my original disk was swapped for the MCE disk (or who the culprit was). As I mentioned before, when I changed the Product Key in the answer file, the next RIS client load came up as XPPro. That was using the XPPro key from the dead Dell. Since I replaced the key in the answer file, I cannot tell what the key was that gave me the MCE result.


    To add insult to injury, I finally broke the seal on the other copy of XPPro I had on the shelf, only to find that it is a very good pirate version with a VBS script in the $OEM$\$1 directory. I didn't even get a chance to try to load it because I was going to check the version when I saw the $OEM$ that set off a few alarm bells... (arrrgh!)


    As for the problem with IE6 not being loaded on the initial install. Opening Windows Components only to find it already checked, and then having it install on exiting the wizard. Would that be related to the fact that an MCE source was used?


    I will also recheck the connection fault for IE.


    I did notice that the "setupxp.htm" file which is copied to the root of the CD image, as well as the "readme.htm" files in the \ic and \ip directories still say "This release of Windows XP includes Service Pack 2 (SP2) for Windows XP."


    While it is true that pieces of SP2 are still going to be there, would it not be more correct to say SP3?


    I will continue poking at the release to see if anything else interesting pops up.





    Tuesday, January 08, 2008 3:20 AM
  • Hi,


    For all those who have noticed an issue with VLK keys failing post integration of SP3, please check the build version that was integrated.

    We should be using the RC1 build (3264).

    To check the build version, pleasefollow the following steps:

    1. Obtain the update exe (windowsxp-kb936929-sp3-x86-xxx.exe)

    2. Execute windowsxp-kb936929-sp3-x86-xxx.exe /x

    3. Point it to a path with suitable disk space (approximately 400MB)

    4. Navigate to the path provided in step 3 and locate the file "autochk.exe" in the i386 folder.

    5. Determine the file version of autochk.exe (right click --> properties --> version).

    6. The last four digit number in the version tell us about the build


    Do let us know, if you notice the issue after integrating build 3264 of XP SP3.




    Tuesday, January 08, 2008 10:23 AM
  • Hi Ismail Demir,


    Can I have your email-id to discuss your issue in detail?



    Suraj Gupta

    Tuesday, January 08, 2008 12:17 PM
  • I used nLite to slipstream SP3 into our Volume License copy of XP pro and ran into the same issue.  I verified it was still a Volume License copy after slipstreaming by looking at the prompt when it asks you for the volume license key and by looking in the source files in the i386 folder at the SETUPP.ini file where its PID ends in 290.
    Tuesday, January 08, 2008 9:29 PM
  • To answer shashank I checked the autochk.exe version and it does end in 3264.
    Tuesday, January 08, 2008 9:43 PM

    My version is 3264. This is the only version I have worked with, I didn't test with the beta version at all.



    Tuesday, January 08, 2008 10:26 PM

    What on earth???. After applying doing a repair install of XP home SP3 (i had the no-booting bug) using an xp pro cd my xp home seems to have morphed. It identifies itself as home but I have things like Local Security Policy that should not be present (oddly users and groups and iis is still absent as is domain functionality?)


    whats going on?

    Tuesday, January 08, 2008 10:51 PM
  • I don't know if this will help, but I found on another forum that if you want your VL key to work you must copy the pidgen.dll file from sp2 to your already slipstreamed sp3 source files.  I did this and my install made it further through the install, but then came up with a validation error.
    Wednesday, January 09, 2008 2:31 AM
  • Hi All,


    It's very odd that your VLK keys are not working on integrated 3264 SP3 update package into your previous XP volume Media.


    Help me to investigate the cause of this, please try the following steps at your end and share results


     - Copy the contents of your Previous XP VLK build to folder C:\XPSP3  (create any folder )

     - download RC SP3 update package (i.e. 3264)

     - Now Run:

    windowsxp-kb936929-sp3-x86-enu.exe /integrate:C:\XPSP3

     - Now you have SP3 integrated XP VLK in C:\XPSP3 folder

     - Check the pidgen.dll file version, date and size from C:\XPSP3\i386 directory and Share it to me

     - Now Run C:\XPSP3\I386\WINNT32.EXE

     - When product key screen appear, enter your valid VL key in that

     - And let me know if it’s accepting your VL key


    It’s just to verify that setup is accepting your VL keys.



    Suraj Gupta


    Wednesday, January 09, 2008 11:14 AM

    I tried the above proceedure, but it doesn't seem to verify that the key is valid. I put in a random characters and it still goes past the screen, it doesn't seem to check the key at all.


    Sorry, but I don't think this method of checking is helpful.

    Wednesday, January 09, 2008 4:52 PM
  • This thread was marked as answered again!!! What is up with that, I didn't mark it. And again, IT IS NOT ANSWERED!

    Wednesday, January 09, 2008 4:53 PM
  • Try another key Marco, with every service pack MS has invalidated ranges of keys. Perhaps yours is in that range.

    Does yours happen to start as FCKGW?


    Wednesday, January 09, 2008 5:18 PM

    I wish it was that simple, I highly doubt that is the issue here. I have tried several of our VL keys, none work. If that were a problem how would we go about find that out?


    The keys issued to our organization are used by tens of thousands of computers, literally. They would not invalidate that range unless they have completely lost their minds.

    Wednesday, January 09, 2008 5:34 PM

    Well after SP2 was released, we had droves and droves of people come into my place of business with pirated xp-pro, You could not install SP2 on most of these machines. Many people needed to buy Retail XP Professional in order to get going again.  That is why I suggested it.


    Also, have you tried another set of hardware math errors coudl cause that on a flaky cpu or ram.

    Wednesday, January 09, 2008 5:42 PM
  • Well, I can safetly rule out anything to do piracy types of issues. Like I said we are a very large organization, not a mom and pop shop. Our keys are for use on thousands of machines, I would *hope* that MS would not make any change to the key structure without notification.


    Also, it isn't being installed on hardware at all, it's VMWARE. And yes, we have also tried installing on a PC, same thing.

    Wednesday, January 09, 2008 6:27 PM
  • We have a developer working with Marco on this issue.

    Would post the conclusion back to the forum.




    Thursday, January 10, 2008 5:26 AM
  • As alluded to by Suraj in one of the previous posts, the problem appears to lie with the pidgen.dll file in the SP3 distribution files. For those looking to continue with testing of slipstream SP3 installations while Microsoft resolves the issue, we have found that by replacing the file with the version from the XP SP2 media, we can work around the problem and the installation proceeds correctly accepting previous product keys.



    Friday, January 11, 2008 2:27 PM
  • Hi,


    Current investigation reveals that this issue happens when the integration process (SP3.exe /integrate) is performed on a Windows Vista machine.

    If anyone facing this issue on a different scenario, please point out.

    We would like to talk to you.




    Friday, January 11, 2008 4:25 PM
  • Hi,


    Please do not use "Nlite" tool for integration as we do not support the same. Go to link to have detail about SP Integration steps and use the same.


    and if anyone facing same issue while performing integration process other than Vista machine please inform us, we'll talk more on same.



    Suraj Gupta



    Saturday, January 12, 2008 2:15 PM
  • I had the same trouble about installing XP with SP3, my key wasn't recognized by the installation when I slipstream my Windows SP2 with SP3. I had tried several steps to try to fix that until I read the last post then I figured out. Everytime I had make my "new" SP3 CD was on Windows Vista, So I decided to try in a diferent way, I installed on Microsoft Virtual Machine, my copy of Windows XP SP2, then there I made my copy of WindowsXP SP3.


    Then I create a new virtual machine and I tested my Windows SP3 CD, and It worked!!! with my old (but original) Key. So if you want to create your own WinXP SP3 SlipStreamed version you *must* do it on Windows XP do *not* on Windows Vista.



    Greetings from Mexico.

    BTW Sorry by my english


    Sunday, January 13, 2008 10:24 AM
  • Also seeing this occur on XP SP2 after the validation checker update...none of our VLKs work either....not sure if it's related or not, but sounds similar.


    Friday, January 18, 2008 3:44 PM
  • I was having the same issue when integrating sp3 into my WinXP source using a Vista machine.  Once I recreated my WinXP source and integrated SP3 using a Windows XP machine the VL key started working again.

    Thanks for the fix!


    Friday, February 29, 2008 4:49 PM
  • to confirm...

    same issue found here on my end with RC2 of service pack 3. Slipstreams using Nlite or not using Nlite with the /integrate switch from the command line do NOT work from vista machines.  They DO work on VM's running XP service pack 2 or SP2 physical machines.


    Jim Herrick

    IT operations manager

    Grant Prideco

    Tuesday, March 04, 2008 5:18 PM
  • I have slipped stream  sp3 to a VL  XP sp2 and it worked ok. I then went thru all the steps again and created another cd with sp3 slipped stream and got invalid key. WEIRD 

    Saturday, March 29, 2008 3:41 PM
  • If you had created the slp media on a Vista/WS08 machine, then this would be expected.





    Monday, March 31, 2008 2:53 PM
  • So is this an RTM issue as well?
    Monday, April 21, 2008 2:21 AM
  • Seems like the same problem in RTM as well.
    Wednesday, April 23, 2008 2:17 AM
  • OK, so I have to ask, is this problem by design?  Check out Waethorn's comments here:


    He says, "The setup program calls setup API's from the currently installed Windows version FIRST, before using its internal setup mechanism."  And in reference to the above-cited pidgen.dll, he says "actually, it's not [a problem] with that particular file - it's with the API calls that reference it.  An installed Windows OS will be 'found' first, before the included pidgen.dll is."


    Is this true, that you can't just make a slipstream any old place you want?!  If so, exactly how long has this been the case for SPs in general?

    Wednesday, April 23, 2008 2:25 AM
  • Thanks for reporting the problem with running slipstream on Vista.
    I am however disappointed that this problem, although discovered on Release Candidates of SP3, made its way to the RTM.
    Wednesday, April 23, 2008 10:40 AM
  • I agree with everybodys saying, coz really I'm becoming cRaZy doin the slipstreaming using Vista. I tought I was doing the wrong way. But right after I read this threads, BOY!!! what a relief!!! Now It doesn't ask for CD key and gives invalid key anymore...


    Doing the Slipstreaming with Windows XP w/ SP2 to Service Pack 3 do it in XP. Even if you have Vista installed to your PC do the Virtual PC install your XP from there! And the rest are SLIPstreamings....


    More power to you guys.... IT REALLY WORKS!



    Edwin Rivera




    Wednesday, April 23, 2008 2:45 PM
  • this whole api/dll behaviour is total madness...

    there is/has been an knowledge base article back from the good old windows 2000 days, when trying to do servicepack integration for windows xp on a windows 2000 machine (for execution/fileintegration into the i386 share) or the other way around....

    there used to be some hint in that knowledge base article that the update.exe stuff needs to be called from inside the service pack standalone .exe installer (sp3.exe -x first, then running the .\update\update.exe -s .... with parameters for the actual slipstream....)

    something like that is what i recall from back those days....

    this is absolutely crazy.... microsoft.... Sad((

    update: this is the kb article i was refering to:

    have fun.
    Wednesday, April 23, 2008 3:27 PM
  • I too....... have confirmed that after the 32** builds of RC for SP3, the slipstream method on Vista fails.  It will not accept my product key.. any product key for that matter.

    I'll have to slipstream on an XP based machine.

    I mentioned this in another thread here at TechNet as well..

    Good luck MS.. be a good thing to fix before Apr 29th.
    Thursday, April 24, 2008 7:29 AM
  • Hey,


      Just found this thread and looks like this is still the case with the RTM version is that true?

    I "slipped" my VL Cd on my vista business machine, and it won't accept my key VLK anymore.



    Thursday, April 24, 2008 5:09 PM
  • It appears that since I first created this thread back in December that Microsoft's solution is don't perform the integration on a Vista machine.

    As much as it bothers me that the host OS has anything to do with the integration, I guess I can live with it since it isn't a procedure I need to do over and over.

    Thursday, April 24, 2008 5:20 PM
  • It reminds me from those past years when the time using diskettes with different versions of DOS. The operating OS have big effect on the target disk. When formatting the disk with different version of FORMAT.COM, it will give error or not supporting the running OS/DOS. When it formats the disk as bootable disk, it will copy the boot file from the running DOS. I don't know if this make sense?


    Just as Slipstreaming to XP using Vista. Its like making bootable disk out of the running system. It will integrate something from vista that makes created XP conflict.


    Wednesday, April 30, 2008 7:31 AM
  • I came across this and found it somewhat incredible, so thought I'd post it here:


    Scroll down to the "warning" section of Step 3. Is doing a "Run as administrator" all that's required to do the integration correctly under Vista?  Up in the "Prerequisites" section, it flatly states that is the workaround. If so, why, and how wasn't this known before?  Surely someone before now in this thread had been doing this in an elevated command prompt and would have mentioned it.


    Wednesday, May 07, 2008 9:39 PM

    @bjf2000: Very excited to see this I went back and repeated the slip stream on my Vista Enterprise 32-bit machine. I followed the instructions to the letter. No luck, doesn't accept the key just as before, sorry. The poster must be incorrect in thinking that solved the issue, or is doing something else that was left out.

    Wednesday, May 07, 2008 11:40 PM
  • I know nLite isn't supported by Microsoft, but...leave it to a third party to have a solution.


    nLite v1.4.5 corrects slipstreaming of SP3 RTM under Vista
    nLite 1.4.5 Final
    Finally the XP SP3 was released so here is the final nLite version update as well.

    Just one important thing changed, SP3 Slipstream under Vista. It would reject your valid CD-Key. Not my doing but it is fixed anyway.
    So in order to fix the XP SP3 CD-Key issues remake the Slipstreamed version from scratch with this nLite version.

    upd: XP SP3 Slipstream under Vista, CD-Key issue


    Friday, May 09, 2008 2:38 AM
  •  Marco@ucla wrote:


    @bjf2000: Very excited to see this I went back and repeated the slip stream on my Vista Enterprise 32-bit machine. I followed the instructions to the letter. No luck, doesn't accept the key just as before, sorry. The poster must be incorrect in thinking that solved the issue, or is doing something else that was left out.

    Thanks for testing that out, but this gets even stranger. The article has not been changed, but during the author's podcast (, 15 minute mark) yesterday, the subject came up and he gave a different version of the workaround in it. No mention of running as admin was made; instead, he said to run the command with Compatibility Mode set to XP. Perhaps that's the part he left out of the procedure. To me, this workaround actually makes a lot more sense than the "run as admin" one (though both may be necessary), but I'm still skeptical.

    Saturday, May 10, 2008 3:35 PM
  • Work around? We already have one!!!  We all figured out back in Dec. that slip-streaming Windows XP SP3 using a Vista system doesn’t work properly but works just fine when using a Windows XP system. Do your Slip-streaming in the native operating system (Windows XP)…problem solved.  There is no need for Microsoft to figure out why it doesn’t work when using a Vista system. They’ve got bigger problems to solve and so do we.

    Sunday, May 11, 2008 2:21 PM
  • You're missing the point there, scarneol, as it's an obvious point of curiosity whether it's possible to do in Vista purely using MS tools. Particularly given that a major site has posted (erroneous, as of this writing) instructions for the workaround, we're doing our best to try to arrive at a solution. If it's as simple as setting a compatibility mode, that needs to be made known.
    Sunday, May 11, 2008 2:32 PM
  •  scarneol wrote:
    Work around? We already have one!!!


    Would you like some cheese with that wine? 

    Sunday, May 11, 2008 2:44 PM
  •  bjf2000 wrote:

    I came across this and found it somewhat incredible, so thought I'd post it here:


    Scroll down to the "warning" section of Step 3. Is doing a "Run as administrator" all that's required to do the integration correctly under Vista?  Up in the "Prerequisites" section, it flatly states that is the workaround. If so, why, and how wasn't this known before?  Surely someone before now in this thread had been doing this in an elevated command prompt and would have mentioned it.


    If all you need is elevated privelages, then it should work if you have UAC turned off. Has anyone tried this?

    Monday, May 12, 2008 8:19 PM
  • @dypsis, continue reading the thread...elevated privileges was found not to help, but my subsequent post two days ago gives more information. So what we're currently waiting on is someone to test compatibility mode, preferably along with elevated privileges.

    Monday, May 12, 2008 8:28 PM
  • OK bjf2000.


    Well this thread is reporting that full retail and volume license installs of Windows XP SP3 are now available in select languages, to MSDN - TechNet Plus subscribers. So I don't think I will mess around with slipstreaming it again.


    Monday, May 12, 2008 8:41 PM
  • Maybe this problem is not fixed with the latest version of nLite.
    Tuesday, May 13, 2008 10:06 AM
  • What I did was followed the steps 1, 2, 3 from the link posted earlier by dypsis May 12-08

    Downloaded ISO recorder for Vista here:

    Downloaded nLite from here:

    In step 3 it explains to use the command code:    C:\sp3\i386\update\update.exe -s:c:\xp\ (I replaced the c:\ with d:\ as i copied my files on that drive instead so it looked like:    d:\sp3\i386\update\update.exe -s:d:\xp\

    I did this while I had my username that has administrative rights in Vista.

    Then I used nLite to create an image only.

    Then because I downloaded the isorecorder powertoy I just inserted a blank disk, right clicked on the iso file i created from nLite and in the list it gives the option to copy image to CD.

    Did that... installed my xp pro on my macbook using bootcamp and the cd key worked and everything turned out just fine.

    Thank the Gods..

    Monday, January 12, 2009 9:32 AM
  • This also fails when you slipstream SP3 on Server 2008 - which makes sense as it's using the same code base as Vista.
    Tuesday, January 13, 2009 2:43 AM
  • have you tried a tool such as nlite to build your installation disc? it allows you to slipstream service packs among many other things..check it out
    Monday, January 26, 2009 5:50 PM
  • wow didnt see all the other "use nlite" bad
    Monday, January 26, 2009 5:51 PM
  • Or just copy your old setupp.ini file over the new one on the disk (in i386 folder). Now with your old cd key installation will continue.
    Friday, July 16, 2010 10:04 AM
  • Hello,

    I've slipstreamed AHCI drivers into our Volume License copy of XP Pro S3. When I install, my ahci issue is solved but 
    our key will no longer work. I saw that lots of people had problems slipstreaming, even if it was mainly to upgrade to SP3 which is not what i'm doing. Moreover i'm not using vista but XP PRO SP3. Also tried a fresh install of windows XP SP3. Maybe SP3 is an issue like Vista ?

    I'm using NLITE I know it's not officially supported, but i read that official ways do not work as well.

    Thanks and sorry for my average english.


    Thursday, August 04, 2011 10:58 AM