locked
Exchange 2003 how to specify the IP address for outbound email when you have two NICs RRS feed

  • Question

  • I have an Exchange server SP2, with a connector to a smart hos for all my outbound emails.

    The server has two NICs, but only one IP address is authorized through the firewall, so I

    have to make sure all outbound emails always use that IP address from one of the NICs.

    In network connections-Advance-Advanced Settings I put the one I want at the top of the list,

    and that worked, but from time to time for some reason the connector starts using the other one,

    and the email get stuck in the outbound queue. then I have to disable the second NIC so that

    the server is forced to use the one allowed through the firewall.

    Is there a way to be sure that the Exchange server will always use the same IP for my outbound emails?

    This problem started after doing a system recovery when a HDD broke down, before that, the configuration

    was the same, and I never had this problem.

    Tuesday, July 10, 2012 1:59 PM

Answers

  • See:

    Getting a send connector to use a specific ip address for sending

    In Exchange 2003/2000, you could specify a SMTP Virtual Server (but not really a specific IP address).
    • Proposed as answer by Xiu Zhang Wednesday, July 11, 2012 7:42 AM
    • Marked as answer by Andres_Iniesta Thursday, July 12, 2012 9:23 AM
    • Unmarked as answer by Andres_Iniesta Friday, July 13, 2012 9:31 AM
    • Marked as answer by Andres_Iniesta Wednesday, July 18, 2012 9:23 AM
    Tuesday, July 10, 2012 2:23 PM
  • How to Assign Ports and IP Addresses to Virtual Servers

    http://technet.microsoft.com/en-us/library/aa996628(v=exchg.65).aspx


    Xiu Zhang

    TechNet Community Support

    • Proposed as answer by Xiu Zhang Wednesday, July 11, 2012 7:46 AM
    • Marked as answer by Andres_Iniesta Thursday, July 12, 2012 9:23 AM
    • Unmarked as answer by Andres_Iniesta Friday, July 13, 2012 9:32 AM
    • Marked as answer by Andres_Iniesta Wednesday, July 18, 2012 9:23 AM
    Wednesday, July 11, 2012 7:46 AM
  • I don't think you have any options, see below. What you can try fiddle with is trying to put a windows static route to the Exchange server on the box route add from source IP on exchange server to the smarthost. May or may not work.

    SMTP Virtual Server Myths Exposed
    http://blogs.technet.com/b/exchange/archive/2005/02/25/380481.aspx

    Myth 4: Virtual Server IP Address Will Be Used For Outgoing Connections

    The last source of misunderstanding is the socket which will be used to open an SMTP connection. This may seem confusing and somewhat contradictory of my first point, but SMTP simply tells the Windows network stack to provide SMTP with a socket. It does not provide a source IP address to use, and as such, you will notice that the source IP address assigned by Windows will be based on the Windows routing table, not taking into consideration the IP of the SMTP VSI that is delivering the message.  A common observation of this is that on a cluster server we are using the physical machine IP as our source IP, not any of the virtual IP addresses.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Tuesday, July 17, 2012 2:20 PM

All replies

  • See:

    Getting a send connector to use a specific ip address for sending

    In Exchange 2003/2000, you could specify a SMTP Virtual Server (but not really a specific IP address).
    • Proposed as answer by Xiu Zhang Wednesday, July 11, 2012 7:42 AM
    • Marked as answer by Andres_Iniesta Thursday, July 12, 2012 9:23 AM
    • Unmarked as answer by Andres_Iniesta Friday, July 13, 2012 9:31 AM
    • Marked as answer by Andres_Iniesta Wednesday, July 18, 2012 9:23 AM
    Tuesday, July 10, 2012 2:23 PM
  • How to Assign Ports and IP Addresses to Virtual Servers

    http://technet.microsoft.com/en-us/library/aa996628(v=exchg.65).aspx


    Xiu Zhang

    TechNet Community Support

    • Proposed as answer by Xiu Zhang Wednesday, July 11, 2012 7:46 AM
    • Marked as answer by Andres_Iniesta Thursday, July 12, 2012 9:23 AM
    • Unmarked as answer by Andres_Iniesta Friday, July 13, 2012 9:32 AM
    • Marked as answer by Andres_Iniesta Wednesday, July 18, 2012 9:23 AM
    Wednesday, July 11, 2012 7:46 AM
  • Thank you for your replys, I think that's what I was looking for, I assigned the desired IP address in the properties of 

    the SMTP Virtual Server, so far was set to use both of them.

    Thursday, July 12, 2012 9:25 AM
  • Hi again,

    unfortunately, today the problem happened again, the exact same behaviour.

    I assigned the IP I want to be used to the Default SMTP Virtual Server, but the outbound queue

    started to acumulate emails, and I had to disable the second NIC for a while and force connection in

    the queue to get it to use the correct IP again.

    Any ideas why this is still happening?

    Thank you.

    Friday, July 13, 2012 9:35 AM
  • Hi again,

    unfortunately, today the problem happened again, the exact same behaviour.

    I assigned the IP I want to be used to the Default SMTP Virtual Server, but the outbound queue

    started to acumulate emails, and I had to disable the second NIC for a while and force connection in

    the queue to get it to use the correct IP again.

    Any ideas why this is still happening?

    Thank you.

    And whats the reason for 2 NICs again? Which one has a DNS server and gateway defined on it?

    Friday, July 13, 2012 12:42 PM
  • On Fri, 13 Jul 2012 09:35:27 +0000, Andres_Iniesta wrote:
     
    >unfortunately, today the problem happened again, the exact same behaviour.
    >
    >I assigned the IP I want to be used to the Default SMTP Virtual Server, but the outbound queue
    >started to acumulate emails, and I had to disable the second NIC for a while and force connection in
    >the queue to get it to use the correct IP again.
    >
    >Any ideas why this is still happening?
     
    You can only assign the IP address that the SMTP Virtual Server
    *listens* on. You can't assign a specific IP address that it will us
    when it sends e-mail.
     
    I'm guessing that the NIC in the machine are bound in the wrong order.
    Put the one you want to use at the top of the binding order.
     
    Better yet, NAT the address and let the firewall/router handle the
    communication with the outside world.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Proposed as answer by Xiu Zhang Monday, July 16, 2012 5:26 AM
    Saturday, July 14, 2012 2:36 AM
  • I bound the NIC in the correct order, but it still happens from time to time.

    I have NAT the address and is the one authorized through the firewall.

    My problem is that, in spite all these settings, the queue gets stuck sometimes,

    and I have to disable the second NIC for a few seconds in order to get the server

    to use the preferred IP address and release the outbound emails.

    The second NIC is used for a VPN, the setup was already done when I came to the job,

    I recently had to do a disaster recovery, and it was then that this problem started(I didn't

    change the previous configuration, AFAIK).

    Monday, July 16, 2012 9:03 AM
  • The second NIC is used for a VPN, the setup was already done when I came to the job,

    I recently had to do a disaster recovery, and it was then that this problem started(I didn't

    change the previous configuration, AFAIK).

    Both NICs have the same configuration, same DNS and gateway.

    Monday, July 16, 2012 9:04 AM
  • I don't think you have any options, see below. What you can try fiddle with is trying to put a windows static route to the Exchange server on the box route add from source IP on exchange server to the smarthost. May or may not work.

    SMTP Virtual Server Myths Exposed
    http://blogs.technet.com/b/exchange/archive/2005/02/25/380481.aspx

    Myth 4: Virtual Server IP Address Will Be Used For Outgoing Connections

    The last source of misunderstanding is the socket which will be used to open an SMTP connection. This may seem confusing and somewhat contradictory of my first point, but SMTP simply tells the Windows network stack to provide SMTP with a socket. It does not provide a source IP address to use, and as such, you will notice that the source IP address assigned by Windows will be based on the Windows routing table, not taking into consideration the IP of the SMTP VSI that is delivering the message.  A common observation of this is that on a cluster server we are using the physical machine IP as our source IP, not any of the virtual IP addresses.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Tuesday, July 17, 2012 2:20 PM
  • OK, I suppose I'll have to live with that.

    What is puzzling me is why we didn't have this issue in the past, with exactly the same configuration.

    Thank you all for your replies.

    Andres.

    Wednesday, July 18, 2012 9:22 AM