locked
SkipAdminPassword rule doesn't work RRS feed

  • Question

  • Hey everyone,

    do you know how skip this step (picture 1)?

    The rule customsettings.ini rule "SkipAdminPassword=YES" doesn't work

    Picture 1 - WDT-SkipAdminPassword

    thanks a lot :)

    Wednesday, February 20, 2019 8:30 AM

All replies

  • If you have multiple task sequences have you modified DeployWiz_SelectTS.vbs to allow for this?
    Wednesday, February 20, 2019 2:38 PM
  • That depends on your priority list. Do you have other sections, specifically one that has it set to NO?

    Daniel Vega

    Wednesday, February 20, 2019 10:16 PM
  • Yes and no. If you have different task sequences with different settings you have to modify the DeployWiz_SelectTS.vbs so it correctly applies the settings. If you only have one task sequence it shouldnt matter.

    Here is a link to how to modify the vbs file. Make a copy of the original first. This seems like what i had done before, https://the-d-spot.org/2012/07/20/how-to-use-different-settings-per-task-sequence-with-mdt-2012.

    I have also seen a site some where that actually created completely separate customsettings.ini files and pointed to those in the task sequence itself.

    Wednesday, February 20, 2019 10:44 PM
  • gregw2 what you're referring to is only needed when you use Priority=TaskSequenceID because rules are processed before a task sequence is chosen.

    Otherwise there's no modification needed if you have multiple task sequences and want SkipAdminPassword=YES to apply to all of them.


    Daniel Vega

    Wednesday, February 20, 2019 10:49 PM
  • OK. I was just thinking if you had multiple task sequences listed in your customsettings.ini file with different settings then that may be an issue if you had not modified the vbs file to make sure it ran those settings correctly. IE:

    [TS_01]

    SkipAdminPassword=YES

    [TS_02]

    SkipAdminPassword=NO

    If that is not the case. Here is a copy of a TS settings that i use. Maybe that will help.

    _SMSTSOrgName=xxx
    DeploymentType=NEWCOMPUTER
    FinishAction=REBOOT
    OSInstall=Y
    SkipCapture=YES
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerBackup=YES
    SkipBitLocker=YES
    SkipComputerName=YES
    SkipDomainMembership=YES
    SkipTaskSequence=YES
    SkipTimeZone=YES
    SkipSummary=YES
    SkipUserData=YES
    SkipLocaleSelection=YES
    SkipApplications=YES
    XResolution=1366
    YResolution=768
    MachineObjectOU=xxxx
    JoinDomain=xxx
    DomainAdmin=xxxx
    DomainAdminDomain=xxx
    DomainAdminPassword=xxx
    NetworkLocation=Work

    As far as I know that page that requests the password is only used for the unattended.xml file. Maybe check that file and make sure it lists the local admin password there. Otherwise the system cannot do an auto logon.

    Thursday, February 21, 2019 1:32 PM