none
Software runs at Admin Level

    Question

  • Hello everyone,

    So I am a beginner in the IT field, I have been doing it for right at a year. My problem is One of my clients just received  a new management software for there practice, The software is on Server 2012 R2 Standard, It uses SQL 2008 R2 for the database.

    The practice has 11 users so I had set up ADDS, The problem I run into is the software has to run at Admin level, So when a domain user clicks the icon to run the software, I get the UAC popup asking for the Domain Admin username and password.

    Is there a group policy that I can give a user that will let the user run that software at Admin, without exposing the Admin credentials to everyone.

    oh yea,  Each Workstation has software on it that allows it to communicate with the server side management software. 

    I have UAC and windows firewall disabled on each workstation, but when my domain user connects there UAC is turned on.

    I hope this makes some sense,  Any help would be greatly appreciated. Thanks Michael.

    Sunday, September 20, 2015 2:48 PM

Answers

All replies

  • Can you make user as administrator on their work station.

     To do this, open comupter management -> local Users & groups -> Groups-> and select administrators.

    Add the users [domain user account] to this group. This will give admin access to users and they should be able to run the application / software as administrator.

    Monday, September 21, 2015 2:11 AM
  • Hi Maptech,

    Thanks for your post.

    You may try to configure some of the policies to control the UAC prompt. However, this may reduce the security of the system.

    You could check if you  follow the steps below and change the registry. (before change registry, you need to backup)

    http://windows.microsoft.com/en-us/windows-vista/how-do-i-change-the-behavior-of-the-user-account-control-message

    https://technet.microsoft.com/en-us/library/dd835564(WS.10).aspx

    And usually “run as administrator” means the account is used and required privileges.  You could search and change the required permissions with ProcessExplorer so the users are still able to run it.  But it may require changes in the registry or file system. So you need to do the test in the virtual machine first and backup the registry.

    Best Regards,

    Mary Dong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, September 22, 2015 8:42 AM
    Moderator
  • To mark an application to always run as an administrator, do the following: 
    1. On the Start menu, locate the program that you want to always run as an administrator. 
    2. Right-click the application’s shortcut, and then click Properties. 
    3. In the Properties dialog box, click the Compatibility tab. 
    4. Do one of the following: 
    • To apply the setting to the currently logged-on user, select the Run This Program As An Administrator check box, and then click OK.
    • To apply the setting to all users on the computer and regardless of which shortcut is used to start the application, click Change Setting For All Users to display the Properties dialog box for the application’s .exe file, select the Run This Program As An Administrator check box, and then click OK twice.
    Tuesday, September 22, 2015 9:15 AM