locked
Edit Hyperlink Dialog - Browse Button Fails to Return URL in Firefox RRS feed

  • Question

  • We are using MOSS 2007 and testing on English, German and Arabic machines.

    When I click the button to insert a hyperlink in a rich text editor, the Edit Hyperlink Properties dialog (AssetEditHyperLink.aspx) appears. Then I click the Browse button and select a link. When I am returned to the Edit Hyperlink dialog, the URL I selected should appear in the "Selected URL" text box and it does when I am using IE 7. However when using Firefox under the conditions described below the "Selected URL" text box remains blank.

    Firefox 3.5 the issue occurs in the English version of SharePoint but it does not occur in Arabic or German localized Sharepoint machines. On the Arabic and German machines, the URL appears in the textbox correctly.

    Firefox 2.0.0.20 just the opposite. The URL appears correctly in the English version, but not in the Arabic or German versions. Another little twist on the English version, though, when I first return to the Edit Hyperlink dialog after selecting a Link the "Selected URL" textbox IS blank, but if I click in the textbox, the URL appears. Unfortunately it does not appear in the Arabic and German versions even after clicking the textbox.

    Why does Firefox not fill in the "Selected URL" text box after browsing and selecting a link? And how could we fix it so that it does?

    Any thoughts or ideas would be greatly appreciated.

    Thanks,
    -ctribble
    • Moved by Mike Walsh FIN Wednesday, July 15, 2009 5:28 PM not programming q (From:SharePoint - Development and Programming)
    Wednesday, July 15, 2009 5:16 PM

All replies