none
Cannot complete psconfig.ps1 -action p RRS feed

  • Question

  • Hi, I've installed FAST SP1 and am attempting to complete the post-configuration script: .\psconfig.ps1 -action p, but I'm getting the error:

    Unable to regenerate schema. Please check that the user running this script is a member of the FASTSearchAdministrators group and that the admin services and configuration server are running.
    Unable to apply schema updates. Please check that the user running this script is a member of the FASTSearchAdministrators group and that the admin services and configuration server are running.

    I am logged on to the server with a Windows account that has administrator privileges to the server and is an explicit member of the FASTSearchAdministrators group. All 6 of the FAST Search services are running. I also have verified that the World Wide Web Publishing Service is running, as a Microsoft document suggests.

    I found the following error in the install log:

    3/7/2013 10:18:49 AM Error Utility.WriteException - Exception -  : Exception - Microsoft.SharePoint.Search.Extended.Administration.Common.AdminException: Failed to communicate with the WCF service. ---> System.ServiceModel.ServiceActivationException: The requested service, 'http://SERVER.DOMAIN.COM:23257/SchemaService.svc' could not be activated. See the server's diagnostic trace logs for more information.

    Server stack trace:
       at System.ServiceModel.Channels.HttpChannelUtilities.ValidateRequestReplyResponse(HttpWebRequest request, HttpWebResponse response, HttpChannelFactory factory, WebException responseException, ChannelBinding channelBinding)
       at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)
       at System.ServiceModel.Channels.RequestChannel.Request(Message message, TimeSpan timeout)
       at System.ServiceModel.Dispatcher.RequestChannelBinder.Request(Message message, TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
       at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.SharePoint.Search.Extended.Administration.Service.SchemaService.GetManagedProperty(String name)
       at Microsoft.SharePoint.Search.Extended.Administration.Schema.ManagedPropertyCollectionImpl.<>c__DisplayClassb.<get_Item>b__a()
       at Microsoft.SharePoint.Search.Extended.Administration.Common.ServiceClientExceptionHandlingInterceptor.Execute[T](Func`1 target, String errorCode, String[] values)
       --- End of inner exception stack trace ---
       at Microsoft.SharePoint.Search.Extended.Administration.WCF.ServiceClientExceptionHandler.TranslateException(Exception e)
       at Microsoft.SharePoint.Search.Extended.Administration.Common.ServiceClientExceptionHandlingInterceptor.Execute[T](Func`1 target, String errorCode, String[] values)
       at Microsoft.SharePoint.Search.Extended.Administration.Common.ServiceClientExceptionHandlingInterceptor.Execute[T](Func`1 target)
       at Microsoft.SharePoint.Search.Extended.Administration.Schema.ManagedPropertyCollectionImpl.get_Item(String Name)
       at Microsoft.SharePoint.Search.Extended.Administration.Commandlets.Schema.SetMetadataManagedPropertyCommand.ProcessRecordInternal()
       at Microsoft.SharePoint.Search.Extended.Administration.Commandlets.CommandBase.Execute(Action target)
    3/7/2013 10:18:49 AM Error Utility.WriteException - Exception Stack Trace -

    I checked the IIS role in Server Manager and it comes back with screens containing no errors. Any other ideas where to look for issues?

    Thursday, March 7, 2013 8:05 PM

Answers

  • We must have missed this server when patching Win Server to SP1. It was this issue caused by the January .NET patch:

    http://blogs.msdn.com/b/jaskis/archive/2013/01/11/net-patch-ms13-004-kb-2756920-causing-problem-on-sharepoint-exchange-2010-net-web-apps.aspx

    After upgrading the OS to SP1, the patch install was successful.

    • Marked as answer by David - SRP Thursday, March 14, 2013 8:35 PM
    Thursday, March 14, 2013 8:34 PM

All replies

  • Did you recently apply any CUs, patches or Service Packs?

    SharePoint MVP, Microsoft VTSP, http://www.arcovis.com

    Wednesday, March 13, 2013 1:06 PM
  • We must have missed this server when patching Win Server to SP1. It was this issue caused by the January .NET patch:

    http://blogs.msdn.com/b/jaskis/archive/2013/01/11/net-patch-ms13-004-kb-2756920-causing-problem-on-sharepoint-exchange-2010-net-web-apps.aspx

    After upgrading the OS to SP1, the patch install was successful.

    • Marked as answer by David - SRP Thursday, March 14, 2013 8:35 PM
    Thursday, March 14, 2013 8:34 PM
  • Natalya,

    I have installed SP2 for FAST search and getting below error.

    .Net Framework 4.5.2 was installed but i have uninstalled but still getting same error, any suggestion please

    Unable to regenerate schema. Please check that the user running this script is a  member of the FASTSearchAdministrators group and that the admin services and configuration server are running.
    .Unable to apply schema updates. Please check that the user running this script is a member of the FASTSearchAdministrators group and that the admin services and configuration server are running. 
    Exception - Microsoft.SharePoint.Search.Extended.Administration.Common.AdminException: Failed to communicate with the WCF service. ---> System.ServiceModel.CommunicationException: An error occurred while making the HTTP request to https://server.domain.com:13258/SchemaService.svc. This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. 
    This could also be caused by a mismatch of the security binding between the client and the server. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host 


    jpbond

    Friday, February 17, 2017 5:53 AM