locked
SP3 Failure of CAS Role RRS feed

  • Question

  • Hi Im running SP3 upgrade. On the CAS server I am getting the following error:

    Exchange Server component Client Access Role failed.

    Error: Error:

    The following error was generated when "$error.Clear();

              $fullPath = [System.IO.Path]::Combine($RoleInstallPath, "ClientAccess\Owa\Bin\Microsoft.Exchange.Clients.Owa.dll");

              $appBase = [System.IO.Path]::Combine($RoleInstallPath, "bin");

              precompile-ManagedBinary -BinaryName  $fullPath -AppBase $appBase;

            " was run: "Process execution failed with exit code -1.".

    Process execution failed with exit code -1.

    Any ideas?

    Tuesday, June 16, 2015 7:12 PM

Answers

  • Hi berket,

    Thank you for your question.

    We could refer to the following steps to check if the issue persist:

    1) We went ahead and removed all the versions of .net using dotnetfx_Cleanup_tool by the following link:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    2) Then we rebooted the Exchange Server and then installed .Net 2.0 SP2 x64

    https://www.microsoft.com/en-us/download/details.aspx?id=1639

    3) Then we again rebooted the Exchange Server and tried installing the CAS role  to check if the issue persist.

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard,

    Jim


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Wednesday, June 17, 2015 5:20 AM
    Moderator