locked
Mapped Drives HELP RRS feed

  • Question

  • Is the Policy forcing the Home drive not to Map?  If I manually map a drive (and reconnect) the drive does not stay.  Is the group policy setting forcing the drives to disconnect?

     

    User receives 2 drives

    Home Drive (V:) via Native AD Profile Home Path and Drive Letter

    Share Drive (S:) via Group Policy Preferences

                      -Action = Update

                      -Use first available starting with S

                      -Filtered by security group

     

    End State is intermittent by the following occurs:

    User Always receive S: drive but not home drive

    Thursday, October 13, 2011 9:47 PM

Answers

  • hi,

    It's not expected. I configured these three settings, but still cannot repro. During a logon procedure, the system will load profile info first and then apply GPOs. As it's a Windows 7 machine, we may have to enable Userenv / Profile Tracing to troubleshoot the issue. Technet forum is limited in receiving the attachment. To find out the root cause, please visit the below link to see the various paid support options that are available to better meet your needs. http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    As a workaround, how about change drive V to the first redirected drive?

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Edited by Brian Re - MSFT Wednesday, November 2, 2011 1:04 PM
    • Marked as answer by Rich1221 Thursday, November 3, 2011 3:12 PM
    Wednesday, November 2, 2011 1:03 PM

All replies

  • Hello,

     

    You can use the folder redirection group policy to create the users home drive.

     

    Automatic creation of user folders for home, roaming profile and redirected folders.

     

    Regards

    • Proposed as answer by VenkatSP Wednesday, August 8, 2012 12:44 PM
    Thursday, October 13, 2011 10:11 PM
  • Thanks patris,

     

     

    I don't want to know an alternative method, but want to know what these results occur.

    Thursday, October 13, 2011 11:29 PM
  • How does the setting work?  Does it disconect all drives first and then map the drives?  This seems like what is happening.

     

    "Use first available drive starting at"

    Friday, October 14, 2011 12:21 AM
  • Hi,

     

    For your information, the action Update does NOT delete the mapped drive-- it only modifies the mapped drive with the new settings. Group Policy Drive Maps use the drive letter to determine if a specific drive exists. Please check the following link for more information:

     

    Using Group Policy Preferences to Map Drives Based on Group Membership

    http://blogs.technet.com/b/askds/archive/2009/01/07/using-group-policy-preferences-to-map-drives-based-on-group-membership.aspx

     

    When the issue occurs (the home drive V: does not appear), can you access the UNC path defined in Active Directory Users and Computers? If not, any errors when accessing the share? If the share can be accessed, please check event log for clues first. If any error is received, please paste the whole entry here for research.

     

    Best Regards,

     

    Nina

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, October 14, 2011 7:58 AM
  • Nina,

    The user can still access their drive by UNC path.  Infact, I would MANUALLY map the drive and have the user log off.  When they login again the drive is gone.

    Any drives mapped after S:  is removed.  If I was to MANUALLY map these drives to letters prior to S: the drives stay connected after a logoff/login.  Clearly, by this example the setting:

    "Use first available drive starting at S:"

     

    Is removing any drives after S:; doesn't seem to make any sense if that is the case......Why even have the setting if you have to hard code the drive letter?

    There are no errors.  GP seems to run without errors as well.

    Friday, October 14, 2011 1:37 PM
  • Hi,

     

    According to my research, if the drive you select on a drive mapping that is set to use first available is not available, it will use the next available letter. Something to keep in mind is that the order of application is very important. For example, if you say first available starting at F, but F is not available and G is used, if there is another drive mapping within the scope of the user that is set to G after the previous drive was mapped to G, the new drive will be mapped to G and you will effectively lose the mapping that was assigned to “first available starting with F”. Please avoid the conflicting drives, such as use the drive letter prior to S in your case, or assign a specific drive letter to the mapped drive, select Use.

     

    Thanks.

    Nina


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, October 17, 2011 8:10 AM
  • Nina,

    That is exactly how I understand use first available. (Configured to start at S:)

    **Any 1 user will only have the option to map 2 Drives (With these settings it should be S:  and T: )***

    Users only have a V: letter drive, but this letters gets disconnected when this policy is processed.

    Monday, October 17, 2011 3:47 PM
  • I found a pattern:

    Scenerio 1:

    Drive Map settings: use S:

    Both Drive Map S: and Home Drive V: maps on every login

     

    Scenerio 2:

    Drive Map settings: use first availabe starting at S:

    Both drive Map S: and Home Drive V: maps on every OTHER login

    login 1: Both S: and V: appear

    login 2: Only S: appear

    login 3: Both S: and V: appear

    login 4: Only S: appear

    etc...

     

     


    • Edited by Rich1221 Monday, October 17, 2011 8:35 PM
    Monday, October 17, 2011 8:32 PM
  • Adding........

    The disconnecting of drives is not specific to the V: or Home Drive.  You can manually map any share; Local or network and the drives will be disconnected.   Only on every other login.

    Monday, October 17, 2011 11:36 PM
  • I think I resolved my issue.......It was a design issue

    Settings were set to:

    Replace - (To remove it not applied)

    Use 1st available -

     

    Replace - Will DELETE AND RECREATE

    Because of the setting to use 1st Available; I believe it is deleting/disconnecting all drives on and after the letter specified.

    Can Microsoft confirm this? Can anyone confirm this?

    Tuesday, October 18, 2011 2:17 PM
  • Hi,

     

    Which Action did you choose when configuring Drive Maps Group Policy Preferences? Update or Replace? The compelling difference between Replace and Update is that Replace deletes the mapped drive and then creates a new mapped drive with the configured settings. Update does NOT delete the mapped drive-- it only modifies the mapped drive with the new settings. Group Policy Drive Maps use the drive letter to determine if a specific drive exists. Please describe all your settings in detail, so that I can test it in my lab. You can also use Process Monitor for further research.

     

    First, please log on with the administrator account on a Windows 7 client for troubleshooting, take the following steps:

     

    1. Visit the following Web site: http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx   

    2. Download and install Process Monitor. Double-click the Procmon file to start Process Monitor.

    3. Use the “Switch user” option, log on with the problematic user account. Wait for the issue reoccurs. Log off and log back to the administrator account.

    4. Go to the Process Monitor window, and then click the microscope icon in the toolbar to stop the capture.

     

    Thanks.

    Nina


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 20, 2011 6:22 AM
  • Try a batch .bat like that and deploy user-logon via GPO.

    net use <DriveLetter>: /delete

    net use <DriveLetter>: \\UNC-Path-To-Share

     


    Best regards Biswajit Biswas Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights. MCP 2003,MCSA 2003, MCSA:M 2003, CCNA, MCTS, Enterprise Admin
    Thursday, October 20, 2011 6:30 AM
  • Nina Liu,

    I used Replace to remove drives when no longer applied to the user.

    I combined Replace with Use first available, starting at to give targeted users the ability to Map muliple shares.

    Because Replace DELETES; I believe the setting Use first available, starting at actually deletes ALL drives in which you start at.

    Because my policy starts at S: - it DELETES drive letters S through Z.

    Because my users Home drives are the letter V; this drives gets deleated.

     

    Is this expected behavior by Microsoft?  I can not believe that this is.  What gives?

     

    Biwjit -

     

    Thank you, I do not want to use logon scripts.

    Thursday, October 20, 2011 12:45 PM
  • Hi,

     

    Replace deletes the mapped drive and then creates a new drive. Group Policy Drive Maps use the drive letter to determine if a specific drive exists. It does not delete “ALL drives in which you start at” as you mentioned. I have test it on my side. In GPP, new drive, set action as Replace, choose use first available, starting at S:, then set home drive to V: via AD Users and Computers. Also, I have manually mapped a drive on Windows 7 client, they are working as expected. Any clues after running Process Monitor for troubleshooting?

     

    Thanks.

    Nina


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, October 25, 2011 8:20 AM
  • Nina Liu,


    Alright, you are right.....simply with the two settings Replace and Use first available, Starting at

    does not delete ALL Drives......

    I forgot to mention, you also have to have this setting in place:

    Remove this item when it is no longer applied

    With all three settings it deletes ALL drives.  With only the 2 settings it does NOT delete ALL drives.....

    • Edited by Rich1221 Tuesday, October 25, 2011 1:28 PM
    Tuesday, October 25, 2011 1:07 PM
  • Nina Liu,

    While running the process monitor I see the following differences from results when drives are deleted and not.

    Drive Deleted:

    Process name = services.exe or svchost.exe or searchindexer.exe  (All these processes have these entries)

    Path = HKCU\Volatile Enviornment

    Details = Index 7, Name:HomeShare, Type: Reg_SZ, Length 64, Data: \\mcsd01fs01c\1gb$\testuser

     

     

    Drive NOT Deleted:

    Process name = wmiprvse.exe (only this process)

    Path = HKCU\Volatile Enviornment

    Details = Index 7, Name:HomeShare, Type: Reg_SZ, Length 64, Data: \\mcsd01fs01c\1gb$\testuser

     

    Really not sure if this tells me anything or not......

    • Edited by Rich1221 Tuesday, October 25, 2011 4:36 PM
    Tuesday, October 25, 2011 4:34 PM
  • Hi,

    I tried to repro the issue (Replace with Use first available) on my side, it failed. The settings are nothing to do with Home Directory Drive. Could you let us know your requirement and we can figure out how to change the settings?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Saturday, October 29, 2011 6:37 AM
  • Hi Brian,

    You have to use three settings (Replace with Use first available and Remove this item when it is no longer applied) .  With those 3 settings, it deletes ALL drive mappings after the letter you've seletected to start with.

    I finally understand that it has nothing to do with Home directory drive, but the simple fact that the home drive is using letter V.  Because this is after S, it deletes it.  In fact, it deletes all drive letters after S, and nothing before S.

     

    We have 65 schools each with an indivudal "School Share".  These schools share are mapped as S.  Depending on the person security group, they get mapped the appropriate school share.  Some teachers teach at multiple schools and thus needing multiple school shares.  They will receive an S, T, etc if they are members of two security groups.

     

    Thank you

    Monday, October 31, 2011 1:44 PM
  • Brian,

    This thread has been opend because originally V: drives (Home Directory Drives) were dissapearing.  It turns out that the Drive Map Preference configured with (Replace with Use first available and Remove this item when it is no longer applied); deletes all drives. (S-Z)

    I have since changed the configuration to (Replace with Use:and Remove this item when it is no longer applied); with this change users that need muliple Mapped are not accomodated.

    Is this expected behavior?

    Monday, October 31, 2011 5:51 PM
  • hi,

    It's not expected. I configured these three settings, but still cannot repro. During a logon procedure, the system will load profile info first and then apply GPOs. As it's a Windows 7 machine, we may have to enable Userenv / Profile Tracing to troubleshoot the issue. Technet forum is limited in receiving the attachment. To find out the root cause, please visit the below link to see the various paid support options that are available to better meet your needs. http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    As a workaround, how about change drive V to the first redirected drive?

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Edited by Brian Re - MSFT Wednesday, November 2, 2011 1:04 PM
    • Marked as answer by Rich1221 Thursday, November 3, 2011 3:12 PM
    Wednesday, November 2, 2011 1:03 PM
  • Thank you for the response and and will follow up with this behavior.  We do have workaround that can be implemented with the following settings:

    Update

    Use first available

    and to remove the device - instead of Remove this item when it is no longer applied - We can add a delete statement for S: drive, T: drive, and U: drive.

    We will follow up with microsoft paid support.  Thank you!

    Thursday, November 3, 2011 3:12 PM
  • Brian/Nina,

    Just wanted to share updates with you because I have support open with Microsoft.

    I am not sure how you both did not reproduce the results because it is expected behavior and should have deleted your drives as well.  Currently, Microsoft is giving me a workaround using KB255103.

    Thanks,

    Richard

    Thursday, November 17, 2011 2:04 PM
  • Hello Rich,

    We are experiencing the same issue.  Unfortunately, the KB article is not displayed on the support site.  Would you mind telling me what the workaround is the MS provided?

    Thanks,

    Josh

    Friday, December 30, 2011 4:46 PM
  • Chauncey,

     

    I actually didn't use the workaround, however I did test the workaround and it did resolve the issue.  I actually re-engineered the drive mappings.  Here is the email that was sent from Microsoft.

     

    Ø  Configured policy by following steps below and that resolved the issue

    Ø  Deploy Hotfix: http://support.microsoft.com/default.aspx?scid=kb;EN-US;2551503

    o   This fixes an issue where GPP drive maps are tattooed to the registry when you do a create.

    o   Without this hotfix the drives will not be removed after the policy is no longer applied. 

    Ø  Create Group Policy Object for the Drive Maps

    Ø  Create the Drive Map Preference with the following settings

    o   General Tab

    §  Action: Create

    §  Location:\\server\sharename

    §  Reconnect: UNCHECKED

    §  Drive Letter: Use first Available, starting at: S

    o   Common Tab

    §  Check Run in logged-on user’s Security context(user policy option)

     

    Policy should look like the following:

     

    Richard, I also would like to inform you that in case you require any further assistance on the same issue, we can always reopen the same case. All that would be required is a simple email to either me or any contacts in my signature line.

     

    Again thanks for your time and patience in this matter. Based on our last conversation, I am closing your case.

     

    Thank you for choosing Microsoft!

    Thursday, January 12, 2012 3:14 PM
  • Chauncy,

     

    Let me know if you need me to break that down.  Like I said I didn't use the workaround, but re-engineered our shares.  The workaround did work, but I wasn't happy with the processing time of the many shares that we had.  We originally had 45+ shares.  (We are a school district and had a share for each school).  Instead of a share per school, I created a single share with eachs schools folder under the share and set permissions on each folder.

    With this setup, when each user connected to the share, they could only see the folder they had permission to.

     

    Richard

    Thursday, January 12, 2012 3:19 PM