Printing service running in 32 bit? RRS feed

  • Question

  • So I recently deployed about 80 workplaces using a mix of clean install (Windows 10 1903 nl-NL x64) and HP factory images. Deployment was done using Autopilot for the new machines from HP and AAD join for the clean installs.

    Factory images were 1809, so they are gradually being updated to 1903 via Windows Update, and here comes the issue:

    On some devices after the 1903 update, the printing service or print management thinks that it is 32-bit. So when I try to install the driver that has previously worked on that machine (1809) I now get an error stating that "the element could not be found" or "The specified file could not be found". In the event viewer, it will state the following: "the driver is for a different processor architecture than the destination computer".

    The strange thing is, when I select the 32-bit driver, it will try to install the driver, but will eventually fail (of course). So I am suspecting that the printing service thinks it is running in 32-bit instead of 64-bit, but I can't find the cause/solution.

    I have tried the following to fix this:

    • SFC /ScanNow (three times)
    • Dism.exe with /CheckHealth, /ScanHealth, /RestoreHealth
    Monday, July 22, 2019 12:28 PM

All replies

  • Hi,

    It's suggested to contact with printer manufactory, to check the printer drivers for Windows 10 1903. Make sure it's the correct version. 

    Install the latest updates by checking for updates to make sure your pc up-to-date.

    Besides, try to use this method to uninstall printers completely, then reinstall them to check result: 

    Open Run dialog and  type printui /s /t2, remove printers in Print Server Properties/Drivers tab interface.

    Best regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Tuesday, July 23, 2019 6:04 AM
  • Hi Yilia,

    • Other computers with Windows 10 1903 are able to use this driver
    • All updates have been installed
    • We uninstalled the drivers via printmanagement.msc. Does this do the same as using printui?


    Tuesday, July 23, 2019 9:46 AM
  • Hi Yilia,

    Any feedback on my reply?


    Wednesday, July 31, 2019 9:47 AM