locked
Possible to Edit Manifest? - Install / Deploy Legacy Client Version in a 1511 Environment RRS feed

  • Question

  • Hey Guys - 

    I recently started at a company which started the installation of Configuration Manager 1511 about a month prior to my arrival.  I was brought in in part due to my prior experience with SCCM and to assist getting many parts of it up and running.

    The Story

    Recently, during initial client deployment; they found out that .NET 4.5.2 was the minimal .NET Framework version for the 1511 client.  Unfortunately, there are many key applications used by the ~10,000 staff which are incompatible with .NET.  I put a "fix" together which seemed to work for most that basically enabled .NET's legacy mode, but to test it the proper way would take a long time and important deployments plus other tasks are lining up daily.

    After much discussion, it was decided to test deployment of the latest "legacy" SCCM client to the environment instead of the 1511 version - at least for a month or two.  The reason is mostly due to it's pre-requisite not being .NET 4.5.x mostly.  Even though 1511's latest features may not work, I got word from Microsoft that everything else would work fine.

    Yes, I understand that this may not be the first choice of many and wasn't for me, either; until I thought of the times in the past when a primary was upgraded and some clients which never were still worked as desired.  

    What Has Been Tried

    I didn't plan on replacing the actual client installation files on the Primary, but deploying using a different method therefore grabbed the files from a 2012 R2 ISO, placed them in a share, create ClientPatch folders, added the latest MSPs, and started testing.

    I then attempted installation on a couple of VMs which had an OEM installation of Windows 7 x64 Pro (what we use), pointing to the source I created, and using a few strings similar to the below:

    "ccmsetup.exe" /source:"\\server\2012R2Client\CLIENT" /mp:PrimaryNetBIOS SMSSITECODE=ABC SMSCONFIGSOURCE=P

    The Issue

    No matter what string I tried, ccmsetup.log kept showing that the installation would download and use the Client source from the Primary.  Once I looked more closely at the log, I saw why (I think.)  Seemingly, the client is checking the manifest stored in AD as is seeing that the client I'm trying to install doesn't meet the minimum version requirement therfore is downloading it despite my string configurations.  Below are a few lines showing what I'm talking about...

    CcmSetup version: 5.0.7958.1000
    Checking if manifest version '5.00.8325.1000' is newer than the ccmsetup version '5.0.7958.1000'
    Downloaded manifest from the source and its newer than the running ccmsetup. Will download ccmsetup from source as well.

    So - assuming this is correct, is there a workaround that I may use to get around this?  

    Any suggestions are appreciated - Thanks!


    Ben K.

    Friday, March 18, 2016 10:11 PM

All replies

  • What happens if you copy the client install files to a local folder (like C:\Temp) then run ccmsetup.exe directly from that location instead of using the /source parameter to specify a UNC path?
    Saturday, March 19, 2016 7:17 AM
  • Configuration Manager 1511


    So please post to the Current Branch Forums next time (https://social.technet.microsoft.com/Forums/en-US/home?category=ConfigMgrCB). Thanks

    Torsten Meringer | http://www.mssccmfaq.de

    Monday, March 21, 2016 6:48 AM
  • Thanks for the reply...

    I tried exactly that (copying locally and not using /source switch) earlier on and got the same results.  Below are the different things I've attempted - all of which still pulled the client from the Primary:

    • Copied Locally used /source Switch pointing to UNC
    • Copied Locally used /source Switch pointing to local copy
    • Copied Locally without using source switch
    • Copied all exe files it usually copies into ccmsetup folder intop the folder prior to execution
    • Numerous other switches as originally listed

    One thing I did find odd was that I obtained the client installation files from a mounted copy of the 2012 R2 ISO.  When copying them over, I saw that many of the pre-req exes located in the folders had a "0" file size.  I assume this is because during installed, the newest versions are downloaded.  I downloaded all of the pre-reqs and replaced the ones with no bytes - and they all pass verification via the ccmsetup log.  I know this because the initial Silverlight exe I added didn't pass hash checks and had to put in an earlier version.  Anyways, didn't know if that made a difference, but still doesn't work overall :(

    Any more suggestions?  Thanks!


    Ben K.

    Monday, March 21, 2016 1:55 PM