OWA + ECP First login slow RRS feed

  • Question

  • Hi there,


    My Exchange 2010 OWA and ECP are very slow when I restart the server.

    This happens for the first login. ECP takes something like 1-2 minutes to start. OWA mostly 30 secs.

    Is this normal?



    Thursday, April 15, 2010 12:47 AM

All replies

  • not on my server. it seems to be pretty quick after a reboot. is the CAS phsyical or virtual. and do you have Anti-virus running or not.
    Mitch Roberson |MCITP:Enterprise Server Admin, Messaging 2007, 2010 |MCTS:OCS with Voice Achievement |MCT |MCSE 2000\2003 |MCSE Messaging 2000\2003
    Thursday, April 15, 2010 1:31 AM
  • Hi ricdgr,

    This is normal and has been an issue with some IIS applications for the past few years.  Basically what happens is, when the worker processes are idle for a certain period of time, they unload themselves from memory.  This supposedly keeps everything running better and prevents memory leaks.  If you have sharepoint, the same thing is true.  The first login of the day will be extra slow while the services are loaded into memory.  I don't know of a *specific* solution for owa 2010, but some people have solved the sharepoint issue by having a script that loads the page a few times in the early morning hours so that the first person doesn't experience that slow load.  There are settings in iis to tell it not to unload out of memory, but nothing has solved that "first slow load of the day" for us other than to have some process auto load the page. 


    • Proposed as answer by Fiona_Liao Monday, February 20, 2012 7:09 AM
    Thursday, April 15, 2010 1:33 AM
  • PRiming the page like I mentioned will fix your issue but for OWA that first slow load should be no more than 10 seconds.  If you are waiting minutes, you might have an issue mentioned here:



    "We had a similar problem and it turned out to be Windows timing out checking for the revocation of signing certificates. Check to see if your server is trying to call out somewhere (e.g. crl.microsoft.com). Perhaps you have a proxy setting incorrect? Or a firewall in the way? We ultimately determined we had enough control over the server and did not want to 'call home', so we simply disabled the check. You can do this with .NET 2.0 SP1 and later by adding the following to the machine.config.

    <runtime> <generatePublisherEvidence enabled="false"/> </runtime> 
    • Proposed as answer by ssssstew Tuesday, November 23, 2010 4:17 AM
    Thursday, April 15, 2010 1:51 AM
  • Is the ECP (if you click "options" from OWA) fast as well?
    Thursday, April 15, 2010 10:08 AM
  • Can anybody give me a quick benchmark results.

    After a "iisreset /noforce", how long does it take for OWA to open (after login), and ECP to show up after clicking "Options"?


    Saturday, April 17, 2010 6:26 PM
  • This happens for the first login. ECP takes something like 1-2 minutes to start. OWA mostly 30 secs.

    Is this normal?

    1-2 minutes for ECP sounds a little long, but yes it is normal for the first load to be slow as others have said. If the Test-* cmdlets are run before you login it may prime IIS and speed things up.
    Brian Day, Overall Exchange & AD Geek
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Microsoft MVP, Exchange Server
    • Proposed as answer by Fiona_Liao Monday, February 20, 2012 7:10 AM
    Saturday, April 17, 2010 10:16 PM
  • Hi,

    This is most likely an issue relating to CRL checking. If the server the Client Access component is installed on does not have direct Internet Access, for example, access to crl.microsoft.com, it is common for .NET Framework when loading the digitially signed binaries to validate the certificates on the package. After a period of time, the certificate validation checks timeout and the modules load in IIS.

    This can be reproduced by disabling access to the internet from the CAS server, performing an IISRESET /NOFORCE, then opening a user's mailbox via the CAS server. The time out could take anywhere from 15s to 120s, in my experience. Common scenarios include building Exchange an isolated test environment.

    Note: a similar problem is experience when installing Exchange without direct internet access. The installation may take a long time. This article may help http://technet.microsoft.com/en-us/library/ee221147(EXCHG.80).aspx

    To resolve this issue (if this is the issue), modify the following files and add the indicated line to the <runtime> section.

    Add the line between the <runtime> and </runtime> lines:
        <generatePublisherEvidence enabled="false" />

    The contents of Aspnet.Config should look similar to:

    <?xml version="1.0" encoding="UTF-8"?>
        <generatePublisherEvidence enabled="false" />
        <legacyUnhandledExceptionPolicy enabled="false" />
        <legacyImpersonationPolicy enabled="false" />
        <alwaysFlowImpersonationPolicy enabled="false" />
        <SymbolReadingPolicy enabled="1" />

    Restart the IIS components (IISRESET /NOFORCE) and attempt to access the OWA site. This should take much less time than before

    An article which touches on similar CRL certificate validation issues :

    Hope this helps



    • Proposed as answer by ssssstew Tuesday, November 23, 2010 4:17 AM
    Friday, August 13, 2010 9:27 AM
  • thanks for the detailed information colin, i impletented this change on our new install and it worked perfectly :)

    Tuesday, November 23, 2010 4:17 AM
  • tnx a lot. U saved my day :)

    Be real

    Monday, February 11, 2013 8:19 AM
  • Are you sure it worked?
    Wednesday, April 23, 2014 5:42 PM